IIS 6 FTP Login Problems

We have a default ftp site setup on our IIS 6 server. We can't get any users to login to it though. We checked local permissions for the folder structure. It constantly returns the following error:

User mckeough failed to log on, could not access the home directory /

The IIS server logs the same error in its system logs. mckeough is the admin account for the local machine, and I made sure it had full permissions on the FTP root folder. Maybe somebody could give me the steps to creating a new FTP user, pointing them to the correct FTP folder, and giving them the correct permissions. That would be great! We're operating on Windows 2003 server with IIS 6 along with Plesk. Thanks!
mckeoughAsked:
Who is Participating?
 
InfinityinfoConnect With a Mentor Commented:
In my environment I setup User Isloation. The path to the ftp root directory is F:\ftproot.

I have been using this article as a reference.
http://www.windowsnetworking.com/articles_tutorials/Creating-Configuring-FTP.html

0
 
InfinityinfoCommented:
I am having the Exact same issue...
0
 
Dave_DietzCommented:
Was the FTP site configured to use any form of User Isolation?

What is the path to the FTP root directory?

Dave Dietz
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
AndresMCommented:
0
 
InfinityinfoCommented:
Followed the article posted by AndresM and I am setup correctly still having issues.
0
 
AndresMCommented:
0
 
InfinityinfoCommented:
Thanks AndresM I appreciate and if I had control of the thread I would give you the points. That link helped resolve my issues.

Adding the Localuser folder resolved my issue. Here is the resolution from that website.

I got this error due to a setup mistake. I setup a new FTP site in IIS 6 using the "Isolate Users" option. I then created folders in ftproot for each user getting access. What I did not realize is that IIS 6 expects a folder indicating the source of the account. Here is what I mean:

\\ftproot\LocalUser\%UserName%
\\ftproot\%DomainName%\%UserName%

I was missing the middle folder in my structure.

Thank you!
0
 
AndresMCommented:
You're welcome!. I'am glad I could help, this are my first comments after 2 or 3 years of inactivity in Experts-Exchange, I hope I have time to participate again in this site.

Regards,
AndresM
0
 
mckeoughAuthor Commented:
Infinity, Thanks for that link. That was EXACTLY what I was looking for, and it immediately resolved my issues. Thanks!

Thanks to everyone else who contributed. I appreciate all of the participation!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.