Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 184
  • Last Modified:

vb com port settings

I am writing a vb application that uses com ports.
For some reason I get some errors when I run it.
Not vb errors, but I was getting the wrong responses from the device
I was talking to.

When I go to my control panel->System->device manager->Com Port->Port Settings->Advanced
Then I slide the 2 sliders all the way to the left the program works.

Is there any way to make this setting programmatically?
0
jackjohnson44
Asked:
jackjohnson44
  • 4
  • 3
  • 2
1 Solution
 
GrahamSkanCommented:
Are you using MSComm control?

There is a settings property

    ' Use COM1.
     MSComm1.CommPort = 1
     ' 9600 baud, no parity, 8 data, and 1 stop bit.
     MSComm1.Settings = "9600,N,8,1"
0
 
jackjohnson44Author Commented:
I am using those settings.

Check the control panel setting to see what I am talking about.
0
 
GrahamSkanCommented:
What sort of flow control are you using? How are you servicing the VB buffers? Are you getting problems on both send and receive?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
jackjohnson44Author Commented:
The problem only happens after running it a few hundred times.

I am not getting errors, I ask it a question and it gives me strange responses.

Either way, the setting seems to work.

Any idea how to change this setting programmatically?
0
 
GrahamSkanCommented:
Sorry, No. I guess that you might be able to use use a driver API, but I'm not into it.

This may help you to get an overview.

http://www.wd-3.com/archive/SerialAttachedDevices.htm
0
 
EDDYKTCommented:
The data may not come back in one shot. You need to read all data to determine whether the data is received

Show us your MSComm1_OnComm() routine
0
 
jackjohnson44Author Commented:
I am specifically asking how to programmatically set the slider that I mention above.

Please do not give alternatives, it is too late to change code.
0
 
EDDYKTCommented:
I think the problem lies on your MSComm1_OnComm() routine. When you increase to highest performance means you will get all data back in one shot. Which implies you do not handle received data correctly
0
 
jackjohnson44Author Commented:
That is not the problem, the problem seems to be that my computer is not sending the commands exactly when I want, I think it might save them up sometimes.  If I send one command, I might have to wait to send the next.  I think they are both being sent really close together and my wait is being ignored. The machine I talk to gets confised.  Reguardless of the problem, the way I got around it was playing with this setting.  It has already been tested and agreed upon.  Instead of putting it in the release notes, I want to set it myself.  This is the only thing I am interested in.  Thanks for your help, but I am only looking to change this setting.
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 4
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now