Solved

Routing out to the internet.

Posted on 2006-11-08
8
317 Views
Last Modified: 2012-06-27
From a laptop connected to F0/0 I can ping 169.224.98.1 and 70.12.96.245 (FastEthernet0/1) however I cannot get to the internet from the laptop.  Anyone know why??  See Below...

________________________________________
interface FastEthernet0/0    (Local Network)
 ip address 169.224.98.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1  (internet modem connection)
 ip address dhcp
 duplex auto
 speed auto
!
interface Serial0/0/0         (not used)
 no ip address
 shutdown
 clock rate 2000000
i
nterface Async0/1/0      (dial backup solution)
 description Dial Backup to Data Center
 ip unnumbered FastEthernet0/0
 no ip redirects
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 20
 dialer string 12345678900
 dialer string 12345678900
 dialer hold-queue 10
 dialer watch-disable 15
 dialer watch-group 5
 dialer-group 1
 async mode dedicated
 snapshot server 15 dialer
 priority-group 10
 pulse-time 3
 ppp authentication pap
 ppp pap sent-username classc password 7 384029834092830
 routing dynamic
!
router eigrp 7
 passive-interface FastEthernet0/1
 network 10.0.0.0
 network 168.119.0.0
 network 169.224.0.0
 distribute-list 10 out
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 70.12.96.1  (tried using - ip route 0.0.0.0 0.0.0.0 dhcp)
ip route 0.0.0.0 0.0.0.0 Async0/1/0 240
ip route 1.1.1.1 255.255.255.255 Async0/1/0
ip route 169.224.0.0 255.255.0.0 Async0/1/0 240

sh ip route - results...
Gateway of last resort is 70.12.96.1 to network 0.0.0.0
 
     1.0.0.0/32 is subnetted, 1 subnets
S       1.1.1.1 is directly connected, Async0/1/0
     192.168.13.0/32 is subnetted, 1 subnets
S       192.168.13.31 [254/0] via 70.12.96.1, FastEthernet0/1
                      [254/0] via 70.12.96.1
     70.0.0.0/24 is subnetted, 1 subnets
C       70.12.96.0 is directly connected, FastEthernet0/1
     169.224.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       169.224.98.0/24 is directly connected, FastEthernet0/0
S       169.224.0.0/16 is directly connected, Async0/1/0
S*   0.0.0.0/0 [1/0] via 70.12.96.1

InternetTest#sh ip int br
Interface                  IP-Address       OK? Method   Status                       Protocol
FastEthernet0/0        169.224.98.1    YES NVRAM   up                             up      
FastEthernet0/1        70.12.96.245    YES DHCP      up                             up      (dynamic ip assigned by the ISP)
Serial0/0/0               unassigned       YES manual   administratively down down    
Async0/1/0               169.224.98.1    YES TFTP      down                         down
0
Comment
Question by:Zands
8 Comments
 
LVL 19

Expert Comment

by:simpswr
ID: 17903135
How are you connedcting? . . the 169 . . . range indicates you have not been assigned an IP address from the modem or router.

Do you have your network connection configured to automatically assign IP address?
0
 

Author Comment

by:Zands
ID: 17903903
I have one class C configured on the FastEthernet0/0 interface.  169.224.98.1/24
169.224.98.x/24 is the local network.  All machines on that network have a 169.224.98.x static IP address with the gateway of 169.224.98.1 for internet access.  Normally the serial interface would be connected to the T-1 but this site cant get installed prior to opening so we are using an internet connection back to the network where I will configure a VPN back into the firewall if I can ever figure out why I cant access the internet from the 169.224.98.x/24 network but I can from the FastEthernet0/1 interface of the router.
0
 
LVL 16

Expert Comment

by:btassure
ID: 17904930
I don't like the fact that your Async and your FA0/0 addresses are the same. Can one of them be changed? At least for testing?

169.224.0.0/16 is variably subnetted, 2 subnets, 2 masks

The router is getting confused about which network is which. I think it may be routing your return traffic to the wrong interface. Change the IP of the Async (even if just temporarily) to a 10.* or something.

It will probably clear the routes on its own but if not you will need to delete whatever it is still showing as a route for 169.x.x.x and add
ip ro 169.x.x.x 255.255.255.0 fa0/0

As I was typing this I looked back up and realised, it's the static route for the Async that is the problem:

C       169.224.98.0/24 is directly connected, FastEthernet0/0
S       169.224.0.0/16 is directly connected, Async0/1/0

169.224.98.0 will fall WITHIN 169.224.0.0/16 so you have a static route telling it to send your reply traffic (the webpages) out on the Async interface.

Delete that route and it will probably fix it straight away. Otherwise do the rest of what I said.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:Zands
ID: 17907223
Deleted the routes as suggested, no good.  I have removed all access-l, took the steps described above.  this should work and isnt



interface FastEthernet0/0
 ip address 169.224.98.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address dhcp
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface Async0/1/0
 no ip address
 no ip redirects
 encapsulation slip
 shutdown
!
router eigrp 7
 passive-interface FastEthernet0/1
 network 10.0.0.0
 network 168.119.0.0
 network 169.224.0.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 dhcp
______________________________________

Gateway of last resort is 70.12.74.1 to network 0.0.0.0
 
     192.168.13.0/32 is subnetted, 1 subnets
S       192.168.13.31 [254/0] via 70.12.74.1, FastEthernet0/1
                      [254/0] via 70.12.74.1
     70.0.0.0/24 is subnetted, 1 subnets
C       70.12.74.0 is directly connected, FastEthernet0/1
     169.224.0.0/24 is subnetted, 1 subnets
C       169.224.98.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 70.12.74.1
_______________________________________
0
 

Author Comment

by:Zands
ID: 17907525
This is so lame.  Just to rule out no routing issues I removed everything but a simple config.  Why cant I get this to work?
I can ping the gateway (169.224.98.1) from the laptop.
I can ping the interface FastEthernet0/1 dhcp address from the laptop.
I can ping www.google.com from the router.
I CAN NOT ping www.google.com from the laptop...(or the F0/0 Int)

InternetTest#ping
Protocol [ip]:
Target IP address: 72.14.205.99
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: FastEthernet0/1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 72.14.205.99, timeout is 2 seconds:
Packet sent with a source address of 70.12.74.7
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 196/409/1204 ms
InternetTest#ping          
Protocol [ip]:
Target IP address: 72.14.205.99  
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: FastEthernet0/0
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 72.14.205.99, timeout is 2 seconds:
Packet sent with a source address of 169.224.98.1
.....
Success rate is 0 percent (0/5)
InternetTest#
___________________________________________________________________________________________________

InternetTest#wr t
Building configuration...
 
Current configuration : 1444 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname InternetTest
!
boot-start-marker
boot-end-marker
!
logging buffered 5012 debugging
enable secret 5 $1500123456789362C
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!        
!
ip domain name XYZ.corp
!
!
!
username wanusr password 7 1500123456789362C
username admin privilege 15 secret 5 $1500123456789362C
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 169.224.98.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address dhcp
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface Async0/1/0
 no ip address
 no ip redirects
 encapsulation slip
 shutdown
!
router eigrp 7
 passive-interface FastEthernet0/1
 network 10.0.0.0
 network 168.119.0.0
 network 169.224.0.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 dhcp
!
ip http server
no ip http secure-server
!
snmp-server community 1500123456789362C RO
snmp-server community 1500123456789362C RO
snmp-server enable traps tty
!
!
control-plane
!
!
line con 0
line aux 0
line 0/1/0
 password 7 1500123456789362C
 no flush-at-activation
 modem InOut
 modem autoconfigure type mica
 transport input all
 autoselect ppp
 stopbits 1
 speed 115200
 flowcontrol hardware
line vty 0 4
 password 7 1500123456789362C
 login
 transport input telnet ssh
!
scheduler allocate 20000 1000
end
0
 

Author Comment

by:Zands
ID: 17915840
I figured it out, thx anyway.  I had not added the NAT statement back into the config when I had switched routers to do the troubleshooting.
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 18199877
PAQed with points refunded (500)

Computer101
EE Admin
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Multicast in a layer 2 to layer 3 migration 1 51
VOIP: SIP vs. proprietary Broadview Networks Silnet ?? 12 92
Routing 2 local networks together 8 70
Viber-Only Restriction 6 21
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now