Solved

VS Installed Before IIS - Unable to start debugging on the server - Cant use localhost as server

Posted on 2006-11-08
22
1,102 Views
Last Modified: 2012-08-13
I have came across this problem before...

IIS was installed after VS was.  Last time i had to uninstall visual studio, and do it in the right order.  I was wondering if anyone knew the tricks to making IIS configured to work normally with Visual Studio in this situation.  Here is the error i am getting

I am using VS2005 with IIS5 (for XP Pro)

"Unable to start debugging on the web server.  <html><head><title>Server Application Error </title></head><body><h1>Server Application Error</h1>The server has encountered an error while loading an application during the processing of your request.  Please refer to the event log for more detail information.  Please contect the server administrator for assistence.</body></html>

Make sure the server is operating correctly.  Berify there are no syntax errors in web.config by doing a Debug.Start Without Debugging. You may also want to refer to the ASP.NET and ALT Server debugging topic in the online documentation."

Any help greatly appreciated.  Or if there is a way to configure this to work with Cassini that would be great as well.  This is a website that i loaded from VSS and it automatically loaded as http://localhost/MyWebsite, so if there is a way for this to work for cassini for me, but keep it as localhost for vss, that would be great as well.

0
Comment
Question by:rodmjay
  • 6
  • 5
  • 4
  • +2
22 Comments
 
LVL 2

Expert Comment

by:santhoshx
ID: 17903840
Using visual studio command prompt run regiis_asp -a. If you jsut type in regiis_asp  you will get different options
0
 
LVL 2

Expert Comment

by:santhoshx
ID: 17903856
sorry regiis_asp -i
0
 
LVL 1

Expert Comment

by:Orlando15767
ID: 17903875
you may also want to check if your iis is running (service is started) as well as check your web.config and make sure you are in debug mode.
0
 
LVL 8

Author Comment

by:rodmjay
ID: 17903947
when i run that command i get

'regiis_asp' is not recognized as ain internal or extarnal command, operable program of batch file.
0
 
LVL 8

Author Comment

by:rodmjay
ID: 17903964
I ran aspnet_regiis -i and it still doesnt work.
0
 
LVL 2

Expert Comment

by:santhoshx
ID: 17904295
Check yor IIS check Directory Security of your application. Does it allow Anonymous access + Windows Integrated Authen.
Also In your machine - Admin tools - computer management - Local Users and Groups -> check to which group does ASPNET belongs

Check this article on VS2003, this will give some hints for you

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dv_vstechart/html/vsdebug.asp
0
 
LVL 8

Author Comment

by:rodmjay
ID: 17904531
I look in the event viewer and this is the message i get

The server failed to load application '/LM/W3SVC'.  The error was 'The specified metadata was not found.
'.
For additional information specific to this message please visit the Microsoft Online Support site located at: http://www.microsoft.com/contentredirect.asp.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0
 
LVL 2

Expert Comment

by:santhoshx
ID: 17904576

 I think this a problem with user rights for ASPNET, IWAM_ XXX and  IUSER_XXXX users. Grand them admin rights and give a try
0
 
LVL 12

Expert Comment

by:sandip132
ID: 17904652
Search and get the path for aspnet_regiis.exe.
Go to .net framework command prompt.
Paste the whole  path + aspnet_regiis.exe -i   (Press Enter)

Reboot... n' Check it.



0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 12

Expert Comment

by:sandip132
ID: 17904660
Make sure the "ASP.NET State Service" Service is running.
0
 
LVL 8

Author Comment

by:rodmjay
ID: 17904701
ive tried everything you guys have thrown at me, ive even uninstalled and re-installed visual studio.

Any more ideas?
0
 
LVL 2

Accepted Solution

by:
santhoshx earned 168 total points
ID: 17904733
So everything is bouncing , did u re-install IIS also ?

http://www.codecomments.com/ASP_.NET/message333121.html  - wrote

"
Irealized that I hadn't uninstalled and reinstalled IIS.  So I did that.
Still didn't work.  Then, I ran aspnet_regiis -i. Still didn't work.  then,
I
ran the install for my little ASP.NET application.  It worked!  I then
uninstalled my application and recreated the links in IIS to my source
directories for the various ASP.NET projects.  It still worked!
"
0
 
LVL 8

Author Comment

by:rodmjay
ID: 17904746
i did that too.  What do you mean "ran the install for my asp.net application"?
0
 
LVL 8

Author Comment

by:rodmjay
ID: 17904762
another option would be to make change the project to use cassini instead of iis.  The project is source controlled, how could i do this?
0
 
LVL 12

Assisted Solution

by:sandip132
sandip132 earned 166 total points
ID: 17904885
try this :
go in iis settings
right click you website, select property.
Go in "Directory security".
Click the button there, and verify that the first and last checkbox is checked.
0
 
LVL 1

Assisted Solution

by:siobi
siobi earned 166 total points
ID: 17904919
I had encounter the same issue...
What I did was,

Register the IIS, u haddid it...

Start Internet Services Manager from Administrative Tools.
Your computer will appear under Internet Information Services. Right-click on your computer and choose Properties.
Select Master WWW Service in the drop-down, then click Edit....
Select the Directory Security tab.
Under Anonymous access and authentication control click Edit...
In the Authentication Methods form, make sure Anonymous access and windows Authentication is checked, then click Edit....
The default username will be IUSR_NAME. We need to replace this with NAME\IUSR_NAME where NAME is your computer name. You can type it in manually or use these steps:
Click the Browse... button.
On the Select User form click the Advanced... button in the bottom left.
Click the Find Now button in the middle-right of this form.
Select IUSR_NAME in the user list at the bottom of the form, then click OK
Click OK to dismiss the Select User form.
Uncheck Allow IIS to control password. (This is important!)
Click OK to dismiss the Anonymous User Account form.
Click OK to dismiss the Authentication Methods form.
Click OK to dismiss the WWW Service Master Properties form.
Click OK to dismiss the Computername Properties form.

make sure u did this as well

Configure Home Directory
With Internet Services Manager:
Your computer will appear under Internet Information Services. Click on your computer to expand its list of servers.
Right-click on Default Web Server and choose Properties.
Select the Home Directory tab.
In the Application Protection drop-down under Application Settings choose Low (IIS Process).
Click OK to dismiss the form.

remember to give me the 500 points.... :P
0
 
LVL 1

Expert Comment

by:siobi
ID: 18206484
I need my point!!!!
0
 
LVL 1

Expert Comment

by:siobi
ID: 18241502
where is my point???????

I want my point!!!!!
0
 
LVL 1

Expert Comment

by:siobi
ID: 18249761
I need my point!!!!
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

AJAX ModalPopupExtender has a required property "TargetControlID" which may seem to be very confusing to new users. It means the server control that will be extended by the ModalPopup, for instance, if when you click a button, a ModalPopup displays,…
Lots of people ask this question on how to extend the “MembershipProvider” to make use of custom authentication like using existing database or make use of some other way of authentication. Many blogs show you how to extend the membership provider c…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now