Solved

Encrypted file size increases using ftp client but stays same when e-mailing.

Posted on 2006-11-09
2
183 Views
Last Modified: 2010-04-11
No idea how to troubleshoot this.  An encrypted proprietary file type is roughly 7,000kb when created by the application.  When e-mailed using groupwise the file is the correct size and seems to be ok (it imports but with errors)  and e-mailing secure files is not a viable option.

When the file is transferred using Glub Tech secure ftp 2.5.9 the file size changed to over 12,000 kb and was totally un usable, would not import.  
We have done this exact process at other sites without this problem.  This is specific to this machine/network/firewall/os.  Where do I begin to check settings to find out why this happened from this site?  The file itself is not readable or comparable but I do know when its unencrypted its an .xml file.

I have over 75 files to get transferred and ftp is the only approved way.  I'd rather not just use a different ftp client but instead get to the bottom of why this happens from this site.
0
Comment
Question by:KathleenR
2 Comments
 

Expert Comment

by:JMBowers
ID: 17906224
Try the simple things first: make sure you are doing a binary transfer and not ascii.
Look in your ftp log files - if unexpected characters have been found and/or translations applied you will probably get error messages.
As an experiment you could try uuencoding the file before ftping it then uudecode at the other end.
0
 
LVL 38

Accepted Solution

by:
Rich Rumble earned 500 total points
ID: 17927793
You can FTP via the cmd line, or with a script/batch file. you may need to check to see if your using Binary mode or Ascii mode... if your transferring text files, ascii is good to use, if your transferring a word doc or excel spread sheet, binary is better to use, same for an .exe, .zip, etc... most transfers should be binary.
http://security.sdsc.edu/software/secureftp/docs/options.shtml

open a cmd window (you can use the same commands they do... copy and paste ;)
http://www.nsftools.com/tips/MSFTP.htm
https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/ftp__ascii.mspx?mfr=true
https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/ftp__binary.mspx?mfr=true

Since version
# 2.0.9 [CLI] [20030721]:
# Allow for auto transfer mode (we determine binary/ascii transfer).
They seem to use auto-detect, I have a feeling it's not working correctly, and you can set it manually, or try it via the cmd line or via a browser.
-rich
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Find out what Office 365 Transport Rules are, how they work and their limitations managing Office 365 signatures.
Every computer eventually fails. When that happens, your valuable data is only as safe as your current backup.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now