DUAL NIC... NEED INTERNET EXPLORER ONLY TO USE A CERTAIN ONE

Hi There,

I have two nic's in a new terminal server, and need to have it so that when a user connects to anything, it can only use the one on the LAN side so that it goes through the main content filter...
any ideas?

I'm using the WAN one so that there is a dedicated router/IP for the terminal server, but i need that content filtering for the users...

Thanks!
LVL 2
inspirednetworksAsked:
Who is Participating?
 
PeterMacConnect With a Mentor Commented:
Essentially this is a routing problem, how easy it will be to solve depends on exact use of WAN NIC card. Comments below assume this is only incoming terminal server traffic from remote client PC's. If this is not the case please advise details and I will look at problem again.

If you have a proxy server available comment from dlangr is good, will force all browser traffic via proxy server, and therefore through your content filtering.

If no proxy server, you can force internet traffic through LAN NIC using gateway settings on TCP/IP  properties screens.
Set gateway on LAN NIC to point to your content filtering system. Do not set any gateway on WAN NIC. All external traffic will then route via the LAN NIC and your WAN NIC will only handle incomming terminal server traffic - routing for this is set up and handled by terminal server app. If you need more detail on this please post request.
0
 
dlangrCommented:
assuming you have an proxy server wich is doing the content filtering:

Configure the browser to use the proxy and make sure they cannot change it (limit rights, use a policy, etc..). see http://support.microsoft.com/kb/135982 for configuring the browser manually.



0
 
MrkarasCommented:
I would agree with that, set a proxy. if you don't already have a proxy you probably need one, there are several arount and some of them must alloy you to direct the traic to one perticular NIC.
0
 
denistyCommented:
do you use a router for your internet?  if you do, you can configure your router not to send data to the ip address of the nic you don't want the users to use.  i hope this works. :-)
0
 
inspirednetworksAuthor Commented:
thanks PeterMac, the no gateway is working, i guess i better buy another static!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.