Solved

DSL-G604T no web access, only email, ping, telnet.

Posted on 2006-11-10
13
227 Views
Last Modified: 2013-12-14
The wireless connection is there, with access to email and some utilities, but it won't let the browser onto the 'net. I've searched all the settings and firewall stuff, but nothing helps.
0
Comment
Question by:krakatoa
  • 7
  • 6
13 Comments
 
LVL 20

Expert Comment

by:ElrondCT
Comment Utility
Most likely problems are 1) corrupted TCP/IP stack, or 2) spyware messing up IE.

To reset the TCP/IP stack:

Open a command prompt window (Start/Run, type "cmd" in the box and click OK) then give the command

netsh int ip reset c:\resetlog.txt  

or use the tool
http://www.spychecker.com/program/winsockxpfix.html

Spyware will generally need antispyware software to clean up. Ad-Aware is a freebie, but Spybot Search & Destroy is probably the top-rated. You could also use the freebie HiJackThis to check for "browser helper objects" that are clinging to IE, but that program isn't particularly friendly to novices.

Just to make sure: Have you checked to see if the results are different if you're plugged in by cable rather than using the wireless connection?
0
 
LVL 16

Author Comment

by:krakatoa
Comment Utility
ElrondCT:

I'm not sure that it is the fault of IE at the moment, since when I change to another router using the same PC, everything is fine, and that's wireless too.
0
 
LVL 20

Expert Comment

by:ElrondCT
Comment Utility
OK, that makes for a very different story. What happens if you plug the computer directly into the router that isn't passing the web pages? Does it work correctly, or fail? Can you access the router's setup page via your browser? It would be ideal if you could try out another computer on the problem router, but that may not be as easy to do. Do you have encryption enabled for the connection? If so, what happens if you turn the encryption off?
0
 
LVL 16

Author Comment

by:krakatoa
Comment Utility
I haven't plugged the PC directly into the G604T yet, as I was convinced it could be configured / problemsolved, via wireless. I can however access the router's admin pages no problem - as I said, I've changed about everything, and tried all I know. (Not much). I have also enabled, and disabled encryption, but it makes no difference.

I just downloaded IE7 and tried to get it to come up with some news, but all it reports is that it could be a DNS issue or Firewall issue.

As you rightly guessed, I would have trouble fetching another PC to the task at the moment, but if the very worst came to the worst ...
0
 
LVL 20

Expert Comment

by:ElrondCT
Comment Utility
OK, at this point the problem looks to be the router rather than the computer. Has the router ever worked, or is this an initial installation? If it previously worked, were there any changes to the router, your Internet connection, or your computer at about the same time as it stopped working?

Have you tried doing a factory reset of the router? To do that, press in the reset button, which is just above the power plug, for seven seconds (you'll probably need to stick a pen or pencil into the hole to get the button to depress. Make sure you first know your DSL connection information (account number/name, password, PPPoE or other connection method, etc.). Once the reset is complete, you'll have to re-enter all that information.
0
 
LVL 16

Author Comment

by:krakatoa
Comment Utility
I have also reset the router several times, with no luck using the button. I think you are on the right track though, because I think it is possibly the PPPoE info that is misconfigured. Trouble with the password thing is that I either don't have one, or one is not needed, and I cant remember which is the case. The router that works is locked up for admin (reason I want to change to the DLink), and I cant retrieve that information from the 2Wire unit.
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 20

Expert Comment

by:ElrondCT
Comment Utility
Please clarify your setup. What is the significance of the 2Wire? Is that what you're trying to replace, or is it still in use and the DLink DSL-G604T is connected to it somehow? The DSL-G604T is designed to be the DSL modem itself, not to work through another modem, much less a modem/router like a 2Wire is. This could be the source of your issues.

If the 2Wire is part of your connection to the Internet, please specify 1) the exact model number of the 2Wire, and 2) how the 2Wire and D-Link devices are attached to each other (cable or wireless; if cable, which port on the D-Link is it plugged into?).

I would highly doubt that your DSL account wouldn't have a password; that's an unreasonable lack of security. You should be able to get that information from your ISP, after providing reasonable proof of identity (if the ISP is your phone company, they'll probably want your account number off a recent phone bill).
0
 
LVL 16

Author Comment

by:krakatoa
Comment Utility
Yup, the 2Wire and the DLink are separate - I don't have them in tandem or on simultaneously. I am usually (now for instance) using the 2Wire, only because it still "works", but I want to change over to the DLink. It's the DLink that we 're talking about in this question.

What would the other settings be for the connection, aside from password, for PPPoE etc?
0
 
LVL 20

Expert Comment

by:ElrondCT
Comment Utility
Assuming you're in the U.S., the standard settings for DSL are simply selecting PPPoE, then entering a username and password. Everything else should pretty much happen automatically. If you have an email account with your ISP, the username and password for login to your DSL would probably be the same as your first email address and password for that. However, that can vary by ISP (and even for the same ISP depending on when you signed up; some have changed procedures over time). I'm assuming you have a standard dynamic IP address, like normal home DSL installations. If you have a business-class DSL with a static IP address, then we're in a whole different arena.

If the DLink has never been working, then I think (assuming that updating name & password doesn't change anything) you probably need to call their tech support. You may have a DOA router; it does happen. If not, they should be able to talk you through whatever adjustments are needed, as long as you can understand them through their Indian accents... It would probably be helpful to try a direct cable connection between your computer and the Dlink first if possible, but if you've got a desktop computer in another room, they should still help you.
0
 
LVL 16

Author Comment

by:krakatoa
Comment Utility
I'm in the UK. I'll have to look into the password thing again of course. But to respond to your other points: yes, I have a dynamic IP; the DLink has worked in the past - it's not new, and I'm sure it's not dead. What is odd to me is that I could access email and use some OS utilities, and, even on one occasion, http to a website on which I admin my email accounts - it was the only one that would connect. It made me wonder if the content or something was being a problem.

Anyway, sounds like you may be done with this question - would that be your position, or could there be anything else you think you want to comment on? Otherwise, I'll try to get down on my knees and plug ghe ethernet in soon. ;)
0
 
LVL 20

Accepted Solution

by:
ElrondCT earned 100 total points
Comment Utility
I would think in the U.K. that PPPoE would just have a username and password, but I'm not sure. (And I know that some European countries use a slightly different DSL login scheme called, I think, PPPoA; I know nothing about that other than that it exists.)

While I doubt it'll matter, it wouldn't hurt anything to reset the TCP/IP stack as I suggested in my first message. Given that you're working with the 2Wire, that seems unlikely to be the issue, but corrupted TCP/IP stacks can result in really odd behavior sometimes. It's quick and easy to try.

Other than that, I'm afraid I'm at the end of my suggestions. I'm sorry.
0
 
LVL 16

Author Comment

by:krakatoa
Comment Utility
I threw the D Link into the dustbin and invested in a Linksys N. Much better, no problems, and thanks for trying.
0
 
LVL 20

Expert Comment

by:ElrondCT
Comment Utility
Glad you got a solution, even if it meant spending a bit of money. Sometimes the hardware does go bad, or sometimes it's just too confusing to try to get it to do what it's supposed to!
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Cable Modem Provisioning from DPoE compliant server  This Article is to support CMTS administrators to provide an overview of DOCSIS compliance configuration file, and to provision a cable modem located at customer place from a Back office serve…
Sometimes you have to pull out old tricks to get a new firewall to work… While we were installing a new Sonicwall at a customers site we found that sites they were able to visit before were not working.  It seemed random and we could not understa…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now