Solved

Public Folder Permissions problem

Posted on 2006-11-10
9
361 Views
Last Modified: 2010-03-06
I have created a calendar folder and I have granted a user - Administrative rights - All (explicitly granted to the folder) and Client permissions - owner.  There are no deny permissions (that I can see).  I know that this is over kill but I still can get this to work.

I can create additional calendars below the "base" calendar but this user can not.  My Account is a full exchange admin.  I am running Outlook 2003 she is running Outlook 2000.

The server is Exchange 2003 SP2.

I am kinda stumped on why she can not create folders below the existing folder.

Thanks for you help.
0
Comment
Question by:e_vanheel
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
  • 2
9 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 17914708
First. I suspect that you may have damaged the permissions by fiddling with the administrative rights. With public folders you should never touch admin rights. The only permissions you need to change are client permissions.

Next. PF permissions do not propagate down automatically. The only time PF permissions propagate is when they are first created, when they take the permissions from the folder above.
After changing the permissions on the public folder, did you restart Outlook on the client's machine?

Simon.
0
 
LVL 6

Author Comment

by:e_vanheel
ID: 17914994
OK,  thanks.  I know you rarely need to touch admin permissions but I was trying the desperate shotgun approach :).

I changed the admin rights on the folder only.  Should I delete the folder and start again?

The sub-folders were created (by me) after the permissions were set.

The computer has been rebooted after the changes have been made (shut down over night).  We waited for a full day and tried it again.  She still can not create sub-folders under the base folder that she owner permission.
0
 
LVL 35

Expert Comment

by:rakeshmiglani
ID: 17915424
check the following article and see if the user has permissions to create a public folder

http://support.microsoft.com/kb/313866/en-us
0
Salesforce Has Never Been Easier

Improve and reinforce salesforce training & adoption using WalkMe's digital adoption platform. Start saving on costly employee training by creating fast intuitive Walk-Thrus for Salesforce. Claim your Free Account Now

 
LVL 104

Accepted Solution

by:
Sembee earned 300 total points
ID: 17915517
I would probably recreate the folder if possible. Trying to recreate the permissions will be quite difficult - Exchange permissions are very complex.

Create the root folder and set the permissions as required before adding any sub folders. Then create the sub folders.

Simon.
0
 
LVL 6

Author Comment

by:e_vanheel
ID: 17916705
rakeshmiglani - I am not getting those errors on the exchange server, however, I did use ADSI and noticed that the everyone account did not have Create public folder, or Create top level public folder.  I inheareded this network so I can't tell you if the defaults have been changed.  I need to read a little bit more about permissions in public folders because I don't wan't everyone to have the ability to create root folders.  I have changed it for now so everyone has Create named properties in the information store, Create public folder, and Create top level public folder.

Sembee - The user does not work today.  I have created a new folder, assinged that use as the owner and will have her test monday AM.
0
 
LVL 6

Author Comment

by:e_vanheel
ID: 17988478
The user can now create folders under the "new" folder.  

If I do not want users to have the permission to create top level folders can I remove this permission from the everyone group?

Is there a document that describes what the default admin permissions should be.  I don't have a large PF environment (yet) but I don't know what rights the previous admin might have changed.

Points to follow

Thanks Everyone!
0
 
LVL 35

Assisted Solution

by:rakeshmiglani
rakeshmiglani earned 200 total points
ID: 17988626
According to http://support.microsoft.com/kb/328808/en-us by default everyone is not granted the rights to create PF in Exchange 2003
0
 
LVL 6

Author Comment

by:e_vanheel
ID: 17988764
the link you posted above :http://support.microsoft.com/kb/313866/en-us has:

Make sure that the Everyone group has the following Allow permissions:
• Create named properties in the information store
• Create public folder
• Create top level public folder
If the Allow inheritable permissions from parent to propagate to this object check box is selected, the Everyone group should already have these permissions. Make sure that the Deny check boxes are not selected.

So I would be safe to remove the create top level public folder permssion - right?
0
 
LVL 6

Author Comment

by:e_vanheel
ID: 17988933
If I view permissions from ADSI for the everyone group they HAVE create top level folders.  If I view from system manager - they do not.
0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
In-place Upgrading Dirsync to Azure AD Connect
how to add IIS SMTP to handle application/Scanner relays into office 365.
This video discusses moving either the default database or any database to a new volume.

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question