Solved

FrontPage can't upload to virtual directlry

Posted on 2006-11-10
8
219 Views
Last Modified: 2013-12-24
Hi Experts,

I'm using FrontPage2003 SP2 and am having problems getting a form to upload a file to a virtual directory. I created a virtual directory named Incoming on my web server. I set permissions to allow read, write, directory browsing and anonymous access. I can browse to http://www.mywebsite.com/Incoming. My FP form is at http://www.mywebsite.com/upload.htm. In the form properties I've tried setting the File Upload destination to both Incoming and http://www.mywebsite.com/Incoming. In both cases when I try submitting a file via the form I get the following message:
Form Validation Error
Please correct the information you provided by following these steps, then submit the information again:
'Incoming' does not refer to a page or folder in this web. It may be a page or folder in a subweb, or it could be a badly formed URL.

Of course, when I use the full URL for the destination it says
'http://www.mywebsite.com/Incoming' does not refer to a page or folder in this web. It may be a page or folder in a subweb, or it could be a badly formed URL.

Is this a limitation of FP in that it cannot upload to a virtual directory, or am I doing something wrong?

Thanks in advance!
0
Comment
Question by:PowerBids
  • 4
  • 4
8 Comments
 
LVL 29

Expert Comment

by:coreybryant
ID: 17916642
Is this virtual directory part of your Frontpage website?  

Assumption:  Your website points to the path: D:\domains\example.com\wwwroot.  So that when I enter www.example.com I am actually seeing the index.html file located at D:\domains\example.com\wwwroot\index.html.   If this is the case (or similar) do you have D:\domains\example.com\wwwroot\Incoming or is Incoming somewhere else on your hard drive?

-Corey
0
 

Author Comment

by:PowerBids
ID: 17916765
Oops, I should have made that part a bit clearer. I of course have a local copy of the website, but the site itself - the http://www.mywebsite.com is actually on a hosting company's server - it's not local. So when I say I made a virtual directory on "my server', I meant I went to the control panel that the hosting company provided me and created a virtual directory that way.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 17923138
Is this *NIX or windows?

Windows - sign onto the server via Frontpage - File - open web - http://www.example.com and then right click on the folder and look at properties.  Check to make sure you can write to it.

If *NIX, you might have other problems because htaccess wants to control permissions and so does Frontpage.

Check your path to make sure it it pointing to the server.  http://www.example.com\Incoming should come up into a browser and be seen (put an index.html file in there so it can be read).  If not, then no, it will not work because Incoming has to be in that folder of example.com

-Corey
0
 

Author Comment

by:PowerBids
ID: 17930905
It's Windows. Not only can I see an index.html file if I put it in that virtual directory, I can also browse the directory if there is no index.html file. However, when I open the site in FrontPage, I do not see the virtual directory. That explains why I get a FP error when I use a form to save a file to the virtual directory.

So the new question is, what do I have to do to get FP to "see" the virtual directory?
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 29

Expert Comment

by:coreybryant
ID: 17930985
I think I understand when you say virtual but it cannot be a virtual folder in IIS sense.  It has to be a path in that website because of Frontpage server extensions

-Corey
0
 

Author Comment

by:PowerBids
ID: 17931015
In that case, I think I need to talk to my hosting company. Looking through their documentation, it appears the appropriate way to enable anonymous uploads and directory browsing is to create a "virtual" directory that points to a physical directory, and then set the permissions on the virtual one accordingly.

If you're telling me that FrontPage cannot recognize a virtual directory - only a physical one on the server - then I need to rethink my design.
0
 
LVL 29

Accepted Solution

by:
coreybryant earned 500 total points
ID: 17931104
Try this:

Creating a folder via your website. And have the upload go there.  Publish your site.  Now open your site 'live' - File - Open Web - http://www.example.com.  Now right click on the folder you just created and choose properties.  Uncheck Allow scripts to be run and check Allow anonymous uploads to folder.

-Corey
0
 

Author Comment

by:PowerBids
ID: 17932277
Hey that did it! I don't even need to worry about virtual directories. Thanks loads for the help!
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Suggested Solutions

When deciding to adopt any help desk solutions many factors should be explored before taking decisions. This will change from business to another but in general there are some kind of rule of thumb. Here are some quick tips: Do we need only ticket…
In this short web based tutorial, I wanted to show users how they can still use the powers of FrontPage in conjunction with Expression Web 3.  Even though Microsoft eliminated the use of Web components, we can still use them with FrontPage and edit …
The purpose of this video is to demonstrate how to connect a WordPress website to Google Analytics. This will be demonstrated using a Windows 8 PC Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php :…
The purpose of this video is to demonstrate how to set up basic WordPress SEO. This will be demonstrated using a Windows 8 PC. The plugin used will be WordPress SEO by Yoast. Go to your WordPress login page. This will look like the following: myw…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now