Solved

IIS Exchweb\bin keeps loosing Permissions settings

Posted on 2006-11-10
3
2,790 Views
Last Modified: 2008-05-30
Recently replaced Exchange 2003 server to our network.  Everything is fine, EXCEPT I keep loosing Allow Anonymous access permissions settings on the Exchweb\bin virtual directory, which causes OWA spellchecker to not function.  The Allow anonymous access check box "unchecks" and the Integrated Windows auth and Basic Auth, gets checked.  Anybody know how to correct this?
0
Comment
Question by:mbigogno
3 Comments
 
LVL 23

Expert Comment

by:rama_krishna580
ID: 17925695
Hi,

Logging off from a Front-End SP2 Server Using Outlook Web Access Requires Disabling Integrated Windows Authentication
Using Outlook Web Access while logging off from a front-end server running Exchange SP2 may result in an incomplete logoff attempt. For example, clicking Log Off in Outlook Web Access may result in a request to type your network identification and password. However, typing valid network credentials will not log you off the server. You must disable Integrated Windows Authentication for the front-end server using Internet Services Manager to completely log off using the Outlook Web Access client.

To allow an Outlook Web Access client to log off from a front-end server running Exchange SP2

Click Start, point to Programs, point to Administrative Tools, and then click Internet Services Manager.
Right-click the exchweb\bin virtual directory for the Default Web Site in the console tree, and then click Properties.
On the Directory Security tab, under Anonymous access and authentication control, click Edit.
Clear the Integrated Windows Authentication check box.
Click OK.
HTTP 500 Errors When Logging Off or Using Unified Messaging
When accessing the pages used to log off or download the Unified Messaging controls in Outlook Web Access, you may receive an HTTP 500 error. Incorrect settings on the Exchweb\bin virtual directory cause this error. This error may occur on a front-end or back-end server.

To resolve these HTTP 500 errors

Open Internet Services Manager.
Go to the Exchweb\bin virtual directory.
Right-click the bin virtual directory, and then click Properties.
On the Virtual Directory tab, click Create, and then click OK.
Outlook Web Access Help Files Must Be Updated Manually
When you install Exchange 2000 Server Service Pack 2, help files for Outlook Web Access clients are not installed. Administrators must manually update or install these help files by running an .msi file, or language pack, for each language used by Outlook Web Access clients.

Important If you previously updated your Outlook Web Access Help files with Exchange 2000 Server Service Pack 1, you must first uninstall the Service Pack 1 Help file updates before you can install the Outlook Web Access Service Pack 2 Help file updates. To remove Service Pack 1 Help, in Control Panel, double-click Add/Remove Programs.

To manually update Outlook Web Access Help

From the Exchange 2000 Service Pack 2 compact disc, run launch.exe to open the Microsoft Exchange 2000 Service Pack 2 main setup screen.
Click Outlook Web Access Help Files.
Double-click the appropriate language pack. Repeat for every language used by your Outlook Web Access clients.
If you already installed Service Pack 2, you can also access these language packs by going to <drive>:\Program Files\Exchsrvr\exchweb.
http://www.microsoft.com/exchange/downloads/2000/sp2/RNotes_us.htm

R.K
0
 

Author Comment

by:mbigogno
ID: 17930915
Ok, I'm a bit confused.  First of all Integrated Windows Authentication IS disabled.  Anonymous Access is Enabled and spell checker is working.  The problem is it looses these settings intermitently, where as Integrated Windows Authentication is Enabled and Anonymous access gets Disabled, thus making spell checker inoperable.
0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 125 total points
ID: 17951329
You should be confused... RK copied and pasted that from the http://www.microsoft.com/exchange/downloads/2000/sp2/RNotes_us.htm document which is for Exchange 2000, and has nothing at all to do with your problem.

The correct settings for the ExchWeb\bin virtual directory's Authentication Methods is to have Anonymous Access NOT enabled and to have ONLY Basic authentication checked.  This would be identical to the way that the Exchange virtual directory is configured.  

The ExchWeb virtual directory should have Enable Anonymous Access CHECKED and no other items should be selected.

Jeff
TechSoEasy
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Join & Write a Comment

Here are the symptoms: You start receiving calls from users that one of your legacy web apps isn't coming up, so you log into your IIS 5 server to check it out.  When you pull up the services, you notice that the WWW Publishing service isn't runn…
Running classic asp applications under Windows Server 2008 R2 (x64) and IIS 7 is not as easy as one may think. It took me a while to figure it out while getting error 8002801d a few times. After you install the OS you will need to install the fol…
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now