?
Solved

I get an error "Your SQL Server Service is running under the local system account.  You need to change your SQL Server Service account to have the rights to copy files over the network.

Posted on 2006-11-10
2
Medium Priority
?
969 Views
Last Modified: 2008-01-09
I get an error "Your SQL Server Service is running under the local system account.  You need to change your SQL Server Service account to have the rights to copy files over the network.  This occurs when I try and right click on the databases folder in Enterprise Manager and then go through the Copy Databases Wizard.  I can copy each database individually though.

I looked at the Services and properties of MSSQLSERVER and it has local system checked (this is the same as my local machine and production server).  I'm not sure what to do so that I can import databases from my production machine to my staging server.  I'm just setting up a new staging server...

Thanks!
0
Comment
Question by:Ike23
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 75

Assisted Solution

by:Anthony Perkins
Anthony Perkins earned 800 total points
ID: 17919520
The local system account does not have access to the network resources.  You need to:
A. Change the SQL Server service startup account to a domain account.  
B. Copy the files using a domain account to the SQL Server, before running the Wizard.
0
 
LVL 28

Accepted Solution

by:
imran_fast earned 1200 total points
ID: 17920198
Hi,
You have to change sql server servie to run under domain admin account. or as Acperkins suggested to do that.

To change SQL Server services login account information (Windows 2000)
On the Start menu, point to Programs/Administrative Tools, and then click Services.
Right-click MSSQLServer, and then click Properties.
On the Log On tab, enter and confirm the new password, and then restart services using the SQL Server Service Manager.
Repeat the password reset for SQLServerAgent and other services.

better restart the services after that.
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Why is this different from all of the other step by step guides?  Because I make a living as a DBA and not as a writer and I lived through this experience. Defining the name: When I talk to people they say different names on this subject stuff l…
Ever wondered why sometimes your SQL Server is slow or unresponsive with connections spiking up but by the time you go in, all is well? The following article will show you how to install and configure a SQL job that will send you email alerts includ…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
Viewers will learn how to use the SELECT statement in SQL to return specific rows and columns, with various degrees of sorting and limits in place.

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question