Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 443
  • Last Modified:

restricting users from accessing another users mailbox via open other user

Is there a way to block users from accessing other users mailboxes within Exchange 2003 SP2?

i.e. If a user clicks on file, open other users mailbox they can view there inbox/outbox/etc... Even thou within Outlook mailbox the user has no rights to the other users mailbox. (Is there another setting somewhere within Exchange 2003?
0
john_s99
Asked:
john_s99
1 Solution
 
mcsa_2003Commented:
HI,
Click Start, point to Programs, point to Administrative Tools, and then click Active Directory Users and Computers.
1.Right Click the Users container.
2.users properites
3.Click the Exchange Advanced tab, and then click Mailbox Rights.
4.In the Permissions list unchek allow access

regards
0
 
Exchange_AdminCommented:
Hmmmm
What exactly are you asking?
By default only the user has access.
0
 
john_s99Author Commented:
For some reason all users have access to all mailboxes. (i.e. everyone is set to full access on ALL mailboxes)

So if I remove everyone it should be ok after that.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
john_s99Author Commented:
I'm trying to restrict other users from viewing everyone's mailbox. For some reason everyone can view everyone else's mailbox...

Further to this, the group everyone has full rights to each users mailbox. (i.e. so do I put deny instead of access to all of rights under the group everyone).

Thanks
0
 
SembeeCommented:
The behaviour you are seeing is not normal and needs to be investigated. You do not have access to all other mailboxes by default. In fact no one does - not even administrators.

Therefore you need to look to see whether the users have permissions that are too high.
First thing I would check is whether everyone is domain admin or administrators and that either or both of those groups has been granted the permission.

The next thing to look at is whether "Service Account" permissions has been granted to an inappropriate group.
This KB article explains how that permission is set, so check the end result and reverse it.
http://support.microsoft.com/default.aspx?kbid=821897

Do NOT go around setting denies in a number of places hoping that you will lock the users out of the mailboxes.
With Exchange, the most restrictive setting wins, so if you set a Deny on Everyone then you could find yourself locked out of Exchange totally. Exchange permissions are very complicated and should not be touched unless you really know what you are doing.

There are very few permission settings that can grant this sort of access - Send As and Full Mailbox are the usual two. What you need to find is the group that has the inappropriate permission and remove it.
If you find the permission is inheriting the right then you will have to find where that inheritance is taking place. Don't attempt to undo the inheritance as that can also screw up the Exchange permissions.

Simon.
0
 
john_s99Author Commented:

Where does one find the everyone group as I can't seem to find it in Windows Server 2003...
0
 
SembeeCommented:
You will not find the "everyone" group listed anywhere. It is one of those built in things that you cannot modify.
You will have to look at the groups like Domain Admins to see if its membership has had Everyone included.

Simon.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now