Solved

Server Application Unavailable error

Posted on 2006-11-11
3
531 Views
Last Modified: 2012-06-21
SBS 2003: I don't know why this started happening today. I added a new virtual directory to my website then all of a sudden all my websites that use ASP 2.0 stopped working with the above error.

Searching on the internet I found some information suggesting that it was a permissions problem on the user account which the application pool within IIS uses. I changed user account to the Local System account and now everything is working. I'm concerned though because when I selected this user account, I was given a very stern warning about the security implications of doing so.

So what's the best way to sort this out?
0
Comment
Question by:ipendlebury
  • 2
3 Comments
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
Comment Utility
Can you please review your Application Event logs and find the corresponding error message which is most likely an event ID 1088.  Please post that entire error message here.

Jeff
TechSoEasy
0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 250 total points
Comment Utility
Actually... in rereading your post... you were using a USER account for your application pool identity?  If you do this, you must make that user a member of the IIS_WPG group.  See http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/12a3d96c-65ea-4210-96ad-86a801f6a88c.mspx?mfr=true for more information.

I find that it's best to NOT use individual accounts for IIS Application Pool Identity, but instead, use the Local Service or Network Service as is appropriate for the application.

Jeff
TechSoEasy
0
 

Author Comment

by:ipendlebury
Comment Utility
Hello Jeff,

Yes i'm getting 1088's logged in the Application Log:

Failed to execute request because the App-Domain could not be created. Error: 0x80070005 Access is denied.  

But I hadn't made any changes to the application pool. I just created it and it worked previously. As a default it is assigned with the Network Service account. This was working until I created a new virtual directory 3 hours ago. Now it will only work if I use the Local System Account.

Ah! Just sussed it. The IIS_WPG mentioned in your link group didn't have any permissions on the folder pointed to by the new virtual directory. I'm suprised that all my virtual directories stopped working though.

Anyway it's working now. Thanks for your help once again.

Ian
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Introduction At 19:33 (UST) on Tuesday 21st September the long awaited email arrived with the subject title of “ANNOUNCING THE AVAILABILITY OF WINDOWS SBS 7 PREVIEW”.  It was time to drop whatever I was doing and dedicate as much bandwidth as possi…
I've often see, or have been asked, the question about the difference between the Exchange 2010 SP1 version, available as part of Small Business Server (SBS) 2011, and the “normal” Exchange 2010 SP1 Standard. The answer to the question is relativ…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now