?
Solved

Trouble accessing OWA - HTTP:// returns must use HTTPS://  - HTTPS returns page not found

Posted on 2006-11-12
7
Medium Priority
?
302 Views
Last Modified: 2010-03-06
Hello,

I have removed and reinstalled a new security cert on my server.  Now when accessing Outllook Web Access I seem to have some issues:

Obviously I want it to use SSL.

When I connect to the site using standard http I get an error that says I must use HTTPS...  But when I connect using HTTPS it says the page cannot be found.  IT all worked before I screwed with the cert.

=====================================================================================
HTTP EXAMPLE

The page must be viewed over a secure channel
The page you are trying to access is secured with Secure Sockets Layer (SSL).
--------------------------------------------------------------------------------

Please try the following:

Type https:// at the beginning of the address you are attempting to reach and press ENTER.
HTTP Error 403.4 - Forbidden: SSL is required to view this resource.
Internet Information Services (IIS)
===========================================================================================
HTTPS EXAMPLE

The page cannot be displayed
The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.

--------------------------------------------------------------------------------

Please try the following:

Click the  Refresh button, or try again later.

If you typed the page address in the Address bar, make sure that it is spelled correctly.

To check your connection settings, click the Tools menu, and then click Internet Options. On the Connections tab, click Settings. The settings should match those provided by your local area network (LAN) administrator or Internet service provider (ISP).
See if your Internet connection settings are being detected. You can set Microsoft Windows to examine your network and automatically discover network connection settings (if your network administrator has enabled this setting).
Click the Tools menu, and then click Internet Options.
On the Connections tab, click LAN Settings.
Select Automatically detect settings, and then click OK.
Some sites require 128-bit connection security. Click the Help menu and then click About Internet Explorer to determine what strength security you have installed.
If you are trying to reach a secure site, make sure your Security settings can support it. Click the Tools menu, and then click Internet Options. On the Advanced tab, scroll to the Security section and check settings for SSL 2.0, SSL 3.0, TLS 1.0, PCT 1.0.
Click the  Back button to try another link.

=======================================================================================================

 
0
Comment
Question by:caw01
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 104

Accepted Solution

by:
Sembee earned 2000 total points
ID: 17925702
Turn off REQUIRE SSL on all directories connected with Exchange.
Don't confuse the setting to require SSL with your ability to use SSL.

Once you have require SSL disabled, drop in to a command prompt and type

iisreset

The test again, on both http and https

Simon.
0
 

Author Comment

by:caw01
ID: 17931341
I have unchecked the "require ssl" at the default web site level and have confirmed that the exchange virtual pages no longer have that value checked but I am having the same result.  

- Chris
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17931508
Did you run iisreset?
After removing that option you shouldn't get the SSL prompt any further.

Make sure that you removed the setting from

/exchange
/exchweb
/exadmin
/public

at least.

Simon.
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Author Comment

by:caw01
ID: 17931550
I have verified that the option is off of those.  And I did do the IISRESET several times.  I'll try it again.

should I have Ignore Client Certs checked or Accept?
0
 

Author Comment

by:caw01
ID: 17931704
Ok, I have confirmed that everything is off.  Now when I use HTTP everything works just fine.

But when I use HTTPS, I still get this:

 The page cannot be displayed
The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.

--------------------------------------------------------------------------------

Please try the following:

Click the  Refresh button, or try again later.

If you typed the page address in the Address bar, make sure that it is spelled correctly.

To check your connection settings, click the Tools menu, and then click Internet Options. On the Connections tab, click Settings. The settings should match those provided by your local area network (LAN) administrator or Internet service provider (ISP).
See if your Internet connection settings are being detected. You can set Microsoft Windows to examine your network and automatically discover network connection settings (if your network administrator has enabled this setting).
Click the Tools menu, and then click Internet Options.
On the Connections tab, click LAN Settings.
Select Automatically detect settings, and then click OK.
Some sites require 128-bit connection security. Click the Help menu and then click About Internet Explorer to determine what strength security you have installed.
If you are trying to reach a secure site, make sure your Security settings can support it. Click the Tools menu, and then click Internet Options. On the Advanced tab, scroll to the Security section and check settings for SSL 2.0, SSL 3.0, TLS 1.0, PCT 1.0.
Click the  Back button to try another link.



Cannot find server or DNS Error
Internet Explorer  
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17932189
That would appear that SSL hasn't been setup correctly.
Export your certificate, then remove it. Run IISRESET again. When you look in IIS manager you should find the SSL port column is empty.

Then reinstall the SSL certificate by importing it. Don't request a new certificate, as you already have one.

Simon.
0
 

Author Comment

by:caw01
ID: 17935040
too bad you cant split that twice on the same person.  There was an issue with my cert AND I needed to turn off the require auth.
0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question