?
Solved

How to configure SBS so typing remote.abc.com will load RWW

Posted on 2006-11-12
20
Medium Priority
?
439 Views
Last Modified: 2008-02-01
Hello,

I have a working SBS 2003 system and NetworkSolutions is hosting my external website.  My www domain name is pointing to the external website at NetSol.  In order for me to access RWW over the Internet, I have to type my static ip address and then "/remote".  Today, I configured a new subdomain, remote.abc.com, which I am pointing at the SBS' static ip address.  I would like to type remote.abc.com to load RWW, but I have not found any information on making this change, although it seems like it would be a simple IIS tweak.  I'd appreciate any help!

Thanks,

Mike
0
Comment
Question by:mjgardne
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 5
  • 5
20 Comments
 
LVL 30

Expert Comment

by:irwinpks
ID: 17925862
in your DNS add in a forward zone

remote.abc.com A record with that hosts static IP address (make sure you tick add PTR record)

update the server datafiles
0
 

Author Comment

by:mjgardne
ID: 17925983
Hi!  Thanks for the quick reply.  I created a forward zone named remote.abc.com and then created a reverse zone for 216.67.12.
Finally, I created a HOST record in the forward zone to 216.67.12.123, and clicked to create a PTR record in the reverse zone.
When I nslookup remote.abc.com, I get 216.67.12.123.  When I nslookup 216.67.12.123, I get remote.abc.com.  So, it looks like DNS is properly configured.  When I try to go to https://remote.abc.com, I get the SSL security alert, which is good, but when I click the "OK" button, I get an error, "You are note authorized to view this page.  The Web server you are attempting to reach has a list of IP addresses that are not allowed to access the Web site, and the IP address of your browsing computer is on this list."  IIS time?

Thanks!

Mike
0
 

Author Comment

by:mjgardne
ID: 17926026
Oh!  The error is "HTTP Error 403.6 - Forbidden: IP address of the client has been rejected.
Internet Information Services (IIS)"
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 30

Expert Comment

by:irwinpks
ID: 17926060
is your IIS for that remote.abc.com set to the IP address 216.67.12.123?
0
 

Author Comment

by:mjgardne
ID: 17926091
Yes, I am using IIS that came with SBS and they both reside on the same server.  WAN 216.67.12.123.  I googled this error message and saw replies discussing changing directory permissions for everyone to access RWW.   I looked in IIS' Manager.  Found "Default Web Site".  Found an entry entitled, "Remote".  Looked at its properties.  Directory Security->Ip Address Restrictions, None.   Is that the correct one?  

Thanks,

Mike
0
 

Author Comment

by:mjgardne
ID: 17926107
...  So, our goal is to tell IIS that whenever someone knocks on the door at 216.67.12.123, it should forward it to "/remote" virtual directory entry?  Right?  If so, how???  :)
0
 
LVL 30

Expert Comment

by:irwinpks
ID: 17926108
Are you sitting behind a router?

You need to forward ports 4125 and 443 for RWW, port 3389 is for RDP access.
0
 

Author Comment

by:mjgardne
ID: 17926167
Hi, Yup, but we are getting beyond the router since I am getting IIS' SSl confirmation page and the webserver is generating the error that I mentioned....  
0
 
LVL 30

Expert Comment

by:irwinpks
ID: 17926174
0
 

Author Comment

by:mjgardne
ID: 17926654
Hmmmm... It didn't help much...  If I enter remote.abc.com/remote, I get the SSL confirmation and login page, but without the /remote I get the error...
0
 
LVL 30

Expert Comment

by:irwinpks
ID: 17926677
in IIS does the site properties for the Documents folder point directly to the correct folder?
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17927470
Well, now we know why there is a separate SBS Small Business Server Topic area...  :-)

You need to run the Configure Email and Internet Connection Wizard (CEICW -- which is linked as Connect to the Internet in the Server Management Console > Internet and Email) to create a new certificate for your new remote.abc.com address and to make sure that it gets configured properly in the right places.

Then, you would definitely need to have the /remote on the end of remote.abc.com unless you created a redirect page for your default web site.  (I've done this for a couple of clients and it works nicely).  The reason for using the /remote is because you can also use /exchange for OWA only.  But I kinda like just being able to use https://remote.abc.com and go directly to RWW.

So for the redirect...

You must create a file called index.html which has only the following line in it:

<meta http-equiv="refresh" content="0;URL=/remote">

Place this file in C:\Inetpub\wwwroot

Then open a command prompt and run "iisreset" to restart IIS.

That should do the trick for you!

Next time... post your question to the SBS Small Business Server Topic Area in order to get a response which accounts for the unique nature of SBS.

:-)

Jeff
TechSoEasy



0
 

Author Comment

by:mjgardne
ID: 17928770
Hi Jeff,

I ran the CEICW wizard and on the "Web Server and Certificate" page, I selected "Create a new web server certificate, and entered remote.abc.com.  Otherwise, I kept all my other previous settings...  It completed successfully.  I created the index.html file with the redirect in it and placed it in C:\Inetpub\wwwroot.  I restarted IIS.  When I entered https://remote.abc.com, I get the security SSL certificate page.  When I accept it, I get the same error as before...  :(  Your suggestions make good sense to me...  Basically, we are jumping to the /remote virtual directory when we try to access the default webserver through the SSL port.  Since we are seeing the SSL certificate page, I assume that we made it through the router and firewall to the SBS box.  We are soooo close to resolving my issue!!!

Thanks for your help!

Mike
0
 

Author Comment

by:mjgardne
ID: 17928805
I've just noticed that I received an e-mail from SBS with instructions about accessing RWW after running CEICW, but it provides the https:/remote.abc.com/remote URL, which works, but the version without /remote doesn't work.  

==================================
Your administrator has granted you access to the Windows Small Business Server Remote Web Workplace.

Using the Remote Web Workplace, you can reach your Windows Small Business Server network from almost any computer that has Internet access. You can access:

Your e-mail and calendar
Your desktop
Your company's internal Web site

This Web site is located at https://remote.abc.com/remote. Note that this address might be different from any you have previously received. We recommend that you record this address for reference when you are away from your company.

For more information, see Information and Answers or click View Remote Web Workplace Help after opening Remote Web Workplace.
=================================
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17937246
Okay, if the version with the /remote works then you're close.  

Rerun the CEICW and be sure to enable the last item on the Web Services screen for: Business Web Site (wwwroot).

Jeff
TechSoEasy
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17937289
Also... if you created those DNS zones on your SBS for remote.abc.com get rid of them.  You don't need it.

Jeff
TechSoEasy
0
 

Author Comment

by:mjgardne
ID: 17949561
Hi Jeff,

I ran CEICW and kept my defaults, but the last page with the checkboxes, including Business Web Site, didn't appear.  The last configuration page that I see is the one dealing with e-mail attachments, and then I go to the "Complete..." page to reconfigure my system.  I know the page to which you are referring, but it is on siesta!  Any ideas about finding it?

Thanks!

Mike
0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 1000 total points
ID: 17952743
It's not on the last page... it's on one of the pages that was skipped because you selected "Do not Change".

Visual of the CEICW is here:  http://sbsurl.com/ceicw

Jeff
TechSoEasy
0
 

Author Comment

by:mjgardne
ID: 17953325
You ROCK, Jeff!  That did the trick!  Thank you very much!!!

Mike
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17960712
No problem!  :-)

Thanks!

Jeff
TechSoEasy
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The HP utility "HP Lights-Out Online Configuration Utility for Windows Server 2003/2008" could be of great use when it comes to remotely configure a HP servers ILO WITHOUT rebooting the server. We would only need to create and run scripts using thi…
Setting up a Microsoft WSUS update system is free relatively speaking if you have hard disk space and processor capacity.   However, WSUS can be a blessing and a curse. For example, there is nothing worse than approving updates and they just have…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question