Solved

VPN client cannot access inside network resources.

Posted on 2006-11-13
19
202 Views
Last Modified: 2013-11-16
We can connect to the VPN using the Cisco VPN client. But when we try to ping inside addresses they do not respond. The machines with the assigned IP addresses are up and we can ping them from the pix506e.

Here's a copy of the current running config

tchpix506e# show run
: Saved
:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname tchpix506e
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside xxx.xxx.xxx.35 255.255.255.0
ip address inside 192.168.1.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool1 192.168.1.1-192.168.1.253
ip local pool vpnpool2 192.168.2.1-192.168.2.10
pdm history enable
arp timeout 14400
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.1 1
route inside 192.168.2.0 255.255.255.0 128.2.0.114 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set trmset1 esp-aes-256 esp-sha-hmac
crypto dynamic-map map2 10 set transform-set trmset1
crypto map map1 10 ipsec-isakmp dynamic map2
crypto map map1 interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup tch address-pool vpnpool1
vpngroup tch idle-time 1800
vpngroup tch password ********
vpngroup pim address-pool vpnpool2
vpngroup pim idle-time 1800
vpngroup pim password ********
telnet timeout 5
console timeout 0
terminal width 80
Cryptochecksum:00000000000000000000000000000000
: end
tchpix506e# exit
0
Comment
Question by:bjbennett
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 6
  • 4
19 Comments
 
LVL 3

Expert Comment

by:bugsaif
ID: 17931374
you need this line in your config
 
      isakmp nat-traversal 20

Saif
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17931822
Which VPN group are you having the issue with ? By the way the pix config output is not complete. Post the complete output.


Cheers,
Rajesh
0
 

Author Comment

by:bjbennett
ID: 17931853
Rajesh,

That is the complete output.. other than the password hashes I took out.

Saif,

That didn't work, although It wasn't in the config.
0
Surfing Is Meant To Be Done Outdoors

Featuring its rugged IP67 compliant exterior and delivering broad, fast, and reliable Wi-Fi coverage, the AP322 is the ideal solution for the outdoors. Manage this AP with either a Firebox as a gateway controller, or with the Wi-Fi Cloud for an expanded set of management features

 
LVL 32

Expert Comment

by:rsivanandan
ID: 17931944
With this configuration, you would be able to get out from your lan to internet itself, so you need these as well in there;

nat (inside) 1 0 0
Global (outside) 1 interface

and there needs to be one more line which prevents natting when the traffic goes from your internal network to the vpn network which would be of this form;

nat (inside) 0 access-list X

access-list X permit ip <Internal Network> <Subnet Mask> <VPN POOL> <Subnet Mask>

So it is incomplete.

Cheers,
Rajesh
0
 

Author Comment

by:bjbennett
ID: 17932157
Rajesh,

I've added the commands in you've said to

Here is another copy of the current config


: Saved
:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
hostname tchpix506e
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 102 permit ip 128.2.0.0 255.255.0.0 192.168.1.0 255.255.255.0
access-list 102 permit ip 128.2.0.0 255.255.0.0 128.2.0.0 255.255.0.0
access-list ACL_1 permit udp any host 128.2.0.222 eq isakmp
access-list ACL_1 permit udp any host 128.2.0.222 eq 4500
access-list 103 permit ip 128.2.0.0 255.255.0.0 192.168.2.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside xxx.xxx.xxx.35 255.255.255.0
ip address inside 128.2.0.222 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool1 192.168.1.1-192.168.1.253
ip local pool vpnpool2 192.168.2.1-192.168.2.10
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 103
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set trmset1 esp-aes-256 esp-sha-hmac
crypto dynamic-map map2 10 set transform-set trmset1
crypto map map1 10 ipsec-isakmp dynamic map2
crypto map map1 interface outside
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup tch address-pool vpnpool1
vpngroup tch split-tunnel 102
vpngroup tch idle-time 1800
vpngroup tch password ********
vpngroup pim address-pool vpnpool2
vpngroup pim split-tunnel 102
vpngroup pim idle-time 1800
vpngroup pim password ********
telnet timeout 5
ssh 129.71.197.0 255.255.255.0 outside
ssh timeout 60
console timeout 0
terminal width 80
Cryptochecksum:9e38c101aecf278ca379de3733a7ae62
: end
tchpix506e(config)#
0
 
LVL 32

Accepted Solution

by:
rsivanandan earned 250 total points
ID: 17932221
You inside interface ip address has changed????? I don't understand.

>>access-list 102 permit ip 128.2.0.0 255.255.0.0 192.168.1.0 255.255.255.0

needs to have this as well;

access-list 102 permit ip 128.2.0.0 255.255.0.0 192.168.2.0 255.255.255.0

this isn't required >>access-list 102 permit ip 128.2.0.0 255.255.0.0 128.2.0.0 255.255.0.0

After doing them, try to connect using the group 'pim' and see if you can ping the inside ip address (Not by names yet since you aren't giving the dns servers to the vpn clients).

See if that works, if not post back. I'm going to catch some sleep now, will look at it tomorrow morning my time :-)

Cheers,
Rajesh
0
 

Author Comment

by:bjbennett
ID: 17932311
Rajesh,

Sorry I'd changed the pim ip pool to not conflict with the inside addresses (if this is possible)

I've added the "access-list 102 permit ip 128.2.0.0 255.255.0.0 192.168.2.0 255.255.255.0"
But it still doesn't work. Prehaps I should've not changed the pim pool addresses?
0
 
LVL 3

Expert Comment

by:bugsaif
ID: 17933070
since you have now configured access list 102, do this...
      no nat (inside) 0 access-list 103
      nat (inside) 0 access-list 102

and what IP are you tying to ping from the vpn client? try pinging 128.2.0.222

Saif
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17935290
Bjbennett,

  Your inside ip address on the pix box is different from the first post and second post, I hope your internal address range is 128.2.x.x (I am wondering because these ip addresses are public range).

 Now you're saying that you've changed the vpn pool not to conflict, can you clarify on your internel network ? whether it is 192.x.x.x or 128.x.x.x ???

Cheers,
Rajesh
0
 

Author Comment

by:bjbennett
ID: 17937567
Rajesh,
The internal network is both 128.x.x.x and 192.x.x.x , i want the one VPN client that can see and talk on to the 128.x.x.x and the other VPN client can see and talk to 192.x.x.x .
I hope this makes thing clear.
Bill
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17939564
Ok, in that case with the commands I gave you, first lets see if one of them talk to 128 first.

Cheers,
Rajesh
0
 

Author Comment

by:bjbennett
ID: 17949389
Rajesh,
I cannot ping 128.2.0.222 which is the inside interface.
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17949418
No, don't try with the inside interface, it is not allowed by default for security reasons on PIX firewall. Try to ping some other machine inside your network.

Cheers,
Rajesh
0
 

Author Comment

by:bjbennett
ID: 17949435
Rajesh,
Yeah I've tried that.. still doesn't work
We have a server with the ip of 128.2.0.114
0
 

Author Comment

by:bjbennett
ID: 17964697
Still not working, anyone with any ideas????
0
 
LVL 3

Expert Comment

by:bugsaif
ID: 17970479
Can you post your configuration as it is right now and I'll try to give it a shot...
0
 

Author Comment

by:bjbennett
ID: 17971875
Bugsaif,

Here is the current config.

PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password **** encrypted
passwd **** encrypted
hostname tchpix506e
domain-name tazecommhospital.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol tftp 69
names
access-list 102 permit ip 128.2.0.0 255.255.0.0 192.168.1.0 255.255.255.0
access-list 102 permit ip 128.2.0.0 255.255.0.0 128.2.0.0 255.255.0.0
access-list 102 permit ip 128.2.0.0 255.255.0.0 129.168.2.0 255.255.255.0
access-list ACL_1 permit udp any host 128.2.0.222 eq isakmp
access-list ACL_1 permit udp any host 128.2.0.222 eq 4500
access-list 103 permit ip 128.2.0.0 255.255.0.0 192.168.2.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside xxx.xxx.xxx.35 255.255.255.0
ip address inside 128.2.0.222 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool1 192.168.1.1-192.168.1.253
ip local pool vpnpool2 192.168.2.1-192.168.2.10
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 102
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.1 1
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set trmset1 esp-aes-256 esp-sha-hmac
crypto dynamic-map map2 10 set transform-set trmset1
crypto map map1 10 ipsec-isakmp dynamic map2
crypto map map1 interface outside
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup tch address-pool vpnpool1
vpngroup tch split-tunnel 102
vpngroup tch idle-time 1800
vpngroup tch password ********
vpngroup pim address-pool vpnpool2
vpngroup pim split-tunnel 102
vpngroup pim idle-time 1800
vpngroup pim password ********
telnet timeout 5
ssh xxx.xxx.xxx.0 255.255.255.0 outside
ssh timeout 60
console timeout 0
terminal width 80
Cryptochecksum:a42a75dba1e55c08c1450b7cc1810fa9
: end
[OK]
0
 
LVL 3

Assisted Solution

by:bugsaif
bugsaif earned 250 total points
ID: 17972259
ok, lets make a few modifications and try again... you can make a note of these changes and put them back later... I'm just trying to narrow down where exactly the issue is...

        no access-list 102 permit ip 128.2.0.0 255.255.0.0 128.2.0.0 255.255.0.0
        no vpngroup tch split-tunnel 102
        no vpngroup pim split-tunnel 102
        no isakmp nat-traversal 20

first try pinging from your inside interface to an inside server/PC...
then try from the vpn client...
if it still won't work, we'll attempt something bolder... :)


0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Windows Server 2012 network 51 119
Logging pfSense on Kiwi 4 77
Sonicwall Traffic 17 102
How to restrict all websites and allow only citrix website 5 76
Wikipedia defines 'Script Kiddies' in this informal way: "In hacker culture, a script kiddie, occasionally script bunny, skiddie, script kitty, script-running juvenile (SRJ), or similar, is a derogatory term used to describe those who use scripts or…
If you are like regular user of computer nowadays, a good bet that your home computer is on right now, all exposed to world of Internet to be exploited by somebody you do not know and you never will. Internet security issues has been getting worse d…
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question