Solved

The DiskPart.exe utility cannot extend a logical drive in an extended partition in Windows Server 2003

Posted on 2006-11-13
12
1,817 Views
Last Modified: 2012-06-27
Im stuck in the process of extending my RAID 5 hardware based configuration.  I recently installed a 4th drive to my array with the intent to increase disk space.
Current configuration:
OS: 2003 Server Standard
Array Type: RAID 5 Hardware based RAID
Array Specs: It has four 35 GB drives allocated onto one logical drive.
Disk Type: Basic

Problem 1: The OS only recognizes the amount of disk space that it originally had which was ~68GB and does not see the new disk space amout of 34GB.  

Using HP's RAID configuration utility, I am at the last part of the phase where I have to use Microsoft disk part utility to extend the disk space.

Problem 2:  When I use disk part, I get this error:
ERROR:
The volume you have selected may not be extended.
Please select another volume and try again.

I discovered that Microsoft has a hot fix for 2003 server which can be referenced in the link below.  According to the link http://support.microsoft.com/kb/841650 , once the hot fix it applied, the following files will be updated:
Date         Time   Version            Size    File name
   --------------------------------------------------------------
   30-Apr-2004  19:03  5.2.3790.169      167,424  Diskpart.exe    
   30-Apr-2004  19:47  5.2.3790.169      107,008  Vdsbas.dll      

Where can I find the hot fix referenced in KB 841650 because it is not included anywhere on the page?  Thank You!
0
Comment
Question by:stressedout2004
  • 4
  • 4
  • 3
  • +1
12 Comments
 
LVL 11

Expert Comment

by:elbereth21
ID: 17931087
Hi stressedout2004,
you have to call Microsoft Help Desk: on this page:http://support.microsoft.com/contactus/?ws=support, you'll find the phone number for your country. There is no other way to get this patch, anyway this method is free, I have done it many times.

Elbereth.
0
 
LVL 14

Expert Comment

by:theruck
ID: 17931770
if i do such tasks i se a 3rd party software (acronis disk director suite) it comes allways handy and works perfectly with HP and IBM RAID controllers (and it is cheap)

anyway there are 2 extending steps in the ACU are you sure you did extend the array AND ALSO the logical volume in the Array Configuration Utility?
0
 
LVL 9

Author Comment

by:stressedout2004
ID: 17932117
theruck
I expeaded the array, and then allocated that space into the array using the array configuration utility.  Would this be the correct answer?
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 26

Expert Comment

by:Pber
ID: 17932165
If you have premier support with M$ you can just go to http://premier.microsoft.com login and search for the KB and download the hotfix directly.  If you don't have premier you have to do what elbereth21 mentioned and follow the link on the page.
0
 
LVL 14

Expert Comment

by:theruck
ID: 17932261
i mean that in the first step you expand the RAID5 array to use the new hard drive and in th esecond one you have to expand the volume(s) located on that array (you probably did it but i can not describe it correctly) the array expansion of a raid5 array usually takes more than 1 whole day of counting
anyway after that if you run the disk manager you HAVE TO BE ABLE TO SEE THE FREE SPACE AFTER THE LAST PARTITION
if the space is there you should be able to resize the partition (i am not sure if the diskpart.exe supports resizing of the c: drive too and if it supports resizing logical partitions)
0
 
LVL 9

Author Comment

by:stressedout2004
ID: 17933732
You are correct the process took about 2 days to complete in growing the disk space.  So I am stuck with unallocated space.  Would their be anything wrong with formatting the remaining space and give it a drive letter? I take it that that 34 gb is spanned across all 4 drives, is that correct?
0
 
LVL 14

Expert Comment

by:theruck
ID: 17936514
yes it is correct
do you see the free space in the disk manager?
0
 
LVL 9

Author Comment

by:stressedout2004
ID: 17938141
I see the space and I can create a partition.  I tried to create a seperate partition and it worked for both primary and extended partition types.  I rather have the space merge into the existing space in that way I dont not have to worry about having a 68GB drive and a 34GB drive.  I know I could use a third party utility, but why wont diskpart work the way it is supposed to?
0
 
LVL 11

Expert Comment

by:elbereth21
ID: 17938188
Are yopuo trying to expand the system or the boot partition? This is not possible with diskpart. If you really want to, you'll have to use a third part utility. See also here:
http://technet2.microsoft.com/WindowsServer/en/library/cc3398fb-cb8d-4516-9529-e726cf3ee63d1033.mspx?mfr=true
0
 
LVL 11

Accepted Solution

by:
elbereth21 earned 280 total points
ID: 17938197
Sorry: "yopuo trying" reads "you trying"...
0
 
LVL 9

Author Comment

by:stressedout2004
ID: 17938746
I am trying to extend the boot partition and system.  Looks like this is a no go.  Thank you all Ill have to use a third party utility.  You have all been great.
0
 
LVL 14

Expert Comment

by:theruck
ID: 17938816
you are great too... i have posted the correct answer and got no points at all... and look what message was selected as a solution...
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Copy an entire Active Directory Domain to a dev environment 4 164
Dentrix G4 1 74
Unknown AD user under VMWare OU 4 65
Event-ID 3001, 3011 - LoadPerf - Windows Server 2003 14 59
Preface Having the need * to contact many different companies with different infrastructures * do remote maintenance in their network required us to implement a more flexible routing solution. As RAS, PPTP, L2TP and VPN Client connections are no…
by Batuhan Cetin In this article I will be guiding through the process of removing a failed DC metadata from Active Directory (hereafter, AD) using the ntdsutil tool in a Windows Server 2003 environment. These steps are not necessary in a Win…
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question