FTP server setup - cannot log in


Running Windows 2003 server standard fully patched.
I have created an FTP site but I cannot connect to it.
 
I have successfully installed FTP services.  When I click on Internet Information Services I can see *ftp-server
I created an FTP site called FTP1
I right click on this and click properties
 - Description is FTP1
 - IP address is 192.168.1.49
 - TCP port is 21
 
Connection:
  limited to 3
  Connection timeout = 900
 
Enable Logging is checked
 
Security accounts
  Allow Anonymous Connections is unchecked
 - I added an account called FTP1 to the Active directory.  I added this to FTP SITE OPERATORS
 - Home directory is c:\ftp\ftp1
 
Question:
1.)  I start a dos session on a Windows 2000 Pro pc connected to the same network as the ftp server.
  I type:  
  ftp
  open 192.168.1.49
and I get the proper response (enter user name)
I enter the user name (FTP1) and the appropriate password and the ftp server will not log me in
 
How do I troubleshoot this?

donpickAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Steve KnightConnect With a Mentor IT ConsultancyCommented:
0
 
Irwin SantosComputer Integration SpecialistCommented:
add the DOMAIN USER group for authentication
0
 
Steve KnightIT ConsultancyCommented:
That will more than likely work unless it is a server that is a DC as domain users will not have rights to login locally which is the user right needed for ftp IMHO.

Open the local security policy from the admin tools and drill down under local policy and user rights assignment.
click into Log on locally and make sure this user is specified there either directly or through a group that is in there.

If this is a domain controller then adjust the domain controller security policy in the same way instead.
If this is a domain member server then this may be set through group policy.  The above right when set should show in the effective column once the local security policy program has been restarted.

Steve
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
Steve KnightIT ConsultancyCommented:
Here's an article I've googled for that explains.

hth

Steve
0
 
donpickAuthor Commented:
Thank you for your link.  It answered some questions.

I guess I am confused on one thing:

The ftp server is named ftp-server.
 It is a domain member, not a domain controller.
The ftp user name is mtnftp.

On the domain controller, in Active Directory (AD) I added user mtnftp.

On the ftp server, I went to Security Settings > User Rights Assignment > Log on Locally and clicked Add
I added mtnftp there.

I opened port 21 on the firewall and pointed it to frp-server.

I followed the instructions in  http://www.iisfaq.com/default.aspx?View=A294&P=14  and configured the IIS FTP service.

When I try to connect to the ftp server (ftp://mtnftp:password@192.168.1.49)
  I get a dialog box asking for a password.  When I type in the correct password, I still cannot log in.

Must I also change the Security settings on the domain controller also?  Or is there something else I need to fix / change?

How can I troubleshoot this to find the blocking point?
0
 
donpickAuthor Commented:
With regard to my question at 01:37:

There are multiple ftp sites defined on ftp-server.  When using the login:
(ftp://mtnftp:password@192.168.1.49)

how do I specify to which ftp site to login?  
0
 
Steve KnightIT ConsultancyCommented:
If it is an AD account try domain\username as the username or create the account locally on the machine.  

Might be other issues here too but try that for starters.

Steve
0
 
Steve KnightIT ConsultancyCommented:
As to your next question there can be only one per combination of ip address and port.  It is unusual to run ftp sites on different ports perhaps there are multiple ips ?
0
 
donpickAuthor Commented:
Thanks VERY MUCH for your help.  The link was very useful.
The answer was to create a local user on the member ftp server and set local log in for it.
Then I used the method described in the link to access the ftp server.

It now works very well.
0
 
Steve KnightIT ConsultancyCommented:
No problem... and thankyou to as you've just taken me over a nice round 1,000,000 points

Steve
0
All Courses

From novice to tech pro — start learning today.