Solved

Can connect the vpn client but cannot access network resources

Posted on 2006-11-13
1
1,219 Views
Last Modified: 2013-11-16
What happens, is that i can ping ip's on the inside interface of the pix, but i cant browse the servers via \\servername.

However, if i pull up a cmd line, i can do a nbtstat -A 192.168.10.x and once it resolves the name, i can then browse via \\servername.

It sounds like a dns problem, but the vpn group has the 192.168.10.2 for dns and then an outside dns from isp. this is the same dns setup that our internal lan uses. Does this need to be changed?

Here's the config

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password DjGOaLXBWWiqnfoU encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname PixFirewall
domain-name brainstate.local
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
<--- More --->
               
 names
name 192.168.10.2 exchsvr
access-list Outside_In permit tcp any host x.x.49.67 eq https
access-list Outside_In permit tcp any host x.x.49.67 eq 444
access-list Outside_In permit tcp any host x.x.49.67 eq smtp
access-list Outside_In permit tcp any host x.x.49.67 eq 3389
access-list Outside_In permit tcp any host x.x.49.67 eq 4125
access-list Outside_In permit tcp any host x.x.49.67 eq pptp
access-list Outside_In permit icmp any any echo-reply
access-list Outside_In permit icmp any any time-exceeded
access-list Outside_In permit icmp any any unreachable
access-list bstvpn_splitTunnelAcl permit ip 192.168.10.0 255.255.255.0 any
access-list inside_outbound_nat0_acl permit ip 192.168.10.0 255.255.255.0 192.168.20.0 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip any 192.168.20.0 255.255.255.0
pager lines 24
icmp deny any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside x.x.49.66 255.255.255.224
ip address inside 192.168.10.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool bstvpnpool 192.168.20.1-192.168.20.254
<--- More --->
               
 pdm location exchsvr 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp x.x.49.67 www exchsvr www netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.49.67 https exchsvr https netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.49.67 444 exchsvr 444 netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.49.67 smtp exchsvr smtp netmask 255.255.255.255 0 0
access-group Outside_In in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.49.65 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
<--- More --->
               
 aaa-server LOCAL protocol local
http server enable
http 192.168.10.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside 192.168.10.49 /c:\TFTP-Root\
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp nat-traversal 800
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup bstvpn address-pool bstvpnpool
vpngroup bstvpn dns-server exchsvr 65.106.1.196
<--- More --->
               
 vpngroup bstvpn default-domain brainstate.local
vpngroup bstvpn split-tunnel bstvpn_splitTunnelAcl
vpngroup bstvpn idle-time 1800
vpngroup bstvpn password ********
telnet 192.168.10.0 255.255.255.0 inside
telnet timeout 10
ssh timeout 5
console timeout 0
dhcpd address 192.168.10.61-192.168.10.254 inside
dhcpd dns exchsvr 65.106.1.196
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain brainstate.local
dhcpd auto_config outside
dhcpd enable inside
username $$$ password $$$ encrypted privilege 2
terminal width 80
banner motd Brain State Technologies Security Message - Terms of Use
banner motd
banner motd The Brain State Technologies computer system is RESTRICTED to official business by authorized users only. Unauthorized entry is prohibited by law and subject to prosecution. All activities and access attempts are monitored and logged for auditing.
banner motd
banner motd Use of this system is your consent to the current Terms of Use. If you are not authorized to use this system, or do not agree to the current Terms of Use, please exit now.
Cryptochecksum:3bda5b186466c06d8ca8024dd4b556e6
: end
<--- More --->
               
 
 PixFirewall#
0
Comment
Question by:jaysonfranklin
1 Comment
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 17934699
Add a WINS server to the network, add that WINS server IP to the VPN client config.
Else create a LMHOSTS file on the client PC that has only two lines in it to resolve the domain and the domain controller
Example lmhosts:

How to Write an LMHOSTS File for Domain Validation and Other Name Resolution Issues
http://support.microsoft.com/support/kb/articles/Q180/0/94.ASP
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
The DROP (Spamhaus Don't Route Or Peer List) is a small list of IP address ranges that have been stolen or hijacked from their rightful owners. The DROP list is not a DNS based list.  It is designed to be downloaded as a file, with primary intention…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now