Solved

Setting up a cisco 1600 router to allow traffic to 'pass through' so that I can graph SNMP

Posted on 2006-11-13
18
637 Views
Last Modified: 2008-01-09
I have a strange scenario.  We recently switched to a new dual T-1 connection in our office.  The network hardware we use is a Sonicwall Firewall and a Cisco 2600.  The problem I am facing is that I am not given access to the 2600 by the ISP.  Even if I did have access, the running configuration gets flashed every hour, so my changes would not stick.

I do however, have a second Cisco router.  The second router is a Cisco 1600.  Is what I want to do is put the Cisco 1600 in between the Sonicwall firewall and the Cisco 2600.  The Cisco 1600 in between will need to not interfere with the connection but rather just allow us to graph internet usage via SNMP.

How can I setup the Cisco 1600 to basically be a 'pass-through' and allow the Sonicwall to use multiple IP addresses and bandwidth etc?  Below is a copy of the 1600's running configuration:



----------------------------------------------------------------------------

Building configuration...                        

Current configuration:                      
!
version 11.2            
service password-encryption                          
no service udp-small-servers                            
no service tcp-small-servers                            
!
hostname SNMP-Router                    
!
enable secret 5 $1$9rEL$aMsl8s4FRFgMnv.j2Tz2I0                                              
enable password 7 074B354D5C2E18111243                                      
!
ip subnet-zero              
no ip source-route                  
ip domain-name den.verio.net                            
ip name-server 209.162.64.15                            
ip name-server 207.159.5.10                          
!
interface Ethernet0                  
 ip address 10.0.6.240 255.255.255.0                                    
 no ip directed-broadcast                        
!
interface Serial0                
 no ip address
!
interface Serial1
 description External Interface For T1
 ip address 207.159.9.146 255.255.255.252
 no ip directed-broadcast
 no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial1
snmp-server community public RO
!
line con 0
 exec-timeout 10 20
 password 7 06421B205E69080D0046
 login
line vty 0 4
 exec-timeout 10 20
 password 7 03404F0A142820584B58
 login
!
end
0
Comment
Question by:CBIA
  • 8
  • 8
18 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 17934669
Sorry, but I can't see any value in putting this router in-line as a pass-through bridge.
It doesn't have two Ethernet interfaces to bridge together. Even if it did it would not give you an accurate picture of the bandwidth of the T1s that you're using.
Either ask the ISP to provide you read-only SNMP access to the router, or ask them for on-demand useage statistics/graphs.

Else your sonicwall should be able to give you some reports of outside bandwidth use..
0
 

Author Comment

by:CBIA
ID: 17934877
This is what our ISP (XO) wanted us to do.  We can have read-only SNMP activated on the Cisco 2600, but it voids our warranty for the hardware.  Also, sonicwalls are not good for the kind fo reporting I want to do.  I use Cacti to graph SNMP enabled devices, and would like to continue doing so.  The sonicwall does not support all of the SNMP OID's I need.

So even if you cannot personally see the value, I would still like to know how to do it and give it a shot.  =)
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17934967
You would still need to have 2x Ethernet ports on the router and you only have 1 Ethernet and 1 T1
You can't do it with what you have.
If you did have 2 Ethernet ports:

 bridge 1 protocol ieee
 bridge irb
 interface Ether0
  no ip address
  bridge-group 1
 interface Ether1
  no ip address
  bridge-group 1
 interface BVI0
  ip address 1.2.3.4 255.255.255.0  <== this is the IP you would use to monitor with snmp

The BVI ip address would have to be in the same IP subnet as your Sonicwall outside and the XO router Ethernet

 
0
 

Author Comment

by:CBIA
ID: 17991177
Thanks for your reply.

Now today I received a new Ethernet card to slip into the Cisco 1600.  So I took out the Serial card and put in the ehternet and booted it up.  However, I am seem to not be able to configure the card.  Do I need to wipe the configuration clean adn start over to get Ethernet1 setup?  If so, how exactly so I go about doing that?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17991742
You might need to upgrade the IOS version to get the drivers for the Ethernet card
Post output of "show version"
0
 

Author Comment

by:CBIA
ID: 17991875
Below is my the output from show version.  FYI I wiped it out by doing the following:

write erase
reload

I will wait for your response before continuing.


Router>show version
Cisco Internetwork Operating System Software                              
IOS (tm) 1600 Software (C1600-NOSY-L), Version 12.2(6a), RELEASE SOFTW-LOSTCARR: Unit 0, lost                                              
Compiled Sat 01-Dec-01 16:40 by pwade                        
00:47:01: %Q
Image text-base: 0x080530C4, data-base: 0x02005000eiver problem?                                    

ROM: System Bootstrap, Version 11.1(10)AA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc
ROM: 1600 Software (C1600-BOOT-R), Version 11.1(10)AA, EARLY DEPLOYMENT RELEASE
SOFTWARE (fc1)

Router uptime is 3 minutes
System returned to ROM by reload
System image file is "flash:yes"

cisco 1601 (68360) processor (revision C) with 13824K/4608K bytes of memory.
Processor board ID 10598642, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
1 Serial(sync/async) network interface(s)
WIC T1-DSU
System/IO memory with parity disabled
2048K bytes of DRAM onboard 16384K bytes of DRAM on SIMM
System running from FLASH
7K bytes of non-volatile configuration memory.
16384K bytes of processor board PCMCIA flash (Read ONLY)

Configuration register is 0x2102

Router>
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17991906
If this is the module that you got, it will not work in the 1600
http://www.cisco.com/en/US/products/hw/routers/ps221/products_data_sheet09186a0080088714.html

0
 

Author Comment

by:CBIA
ID: 17992003
Bad news, you are right, that is the card I got.  (damn eBay!)

Good news, I won't continue to try to make it work.  I will get a new card asap.  Any recommendation for a product number?

Thank you again for all your help, if I could award 10,000 points I would!
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 79

Expert Comment

by:lrmoore
ID: 17992153
You could put a hub in between the Sonicwall and the 2600 router and hook up a NTOP PC to the hub
Put a 2nd NIC in the NTOP system to enable you to access the web interface from your LAN.
http://www.ntop.org

0
 

Author Comment

by:CBIA
ID: 18125648
Current configuration : 583 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname LightSaber
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 25
no aaa new-model
ip subnet-zero
!
!
!
ip cef
!
!
bridge irb
!
!
interface Ethernet0
 no ip address
 half-duplex
 bridge-group 1
!
interface FastEthernet0
 no ip address
 speed auto
 bridge-group 1
!
interface BVI1
 ip address 10.0.6.160 255.255.255.0
!
ip classless
no ip http server
!
snmp-server community public RO
bridge 1 protocol ieee
!
line con 0
line aux 0
line vty 0 4
 login
!
end

I replaced the cisco 1600 and got a cisco 1700 on Ebay that work's with that WIC.  I upgraded the IOS firmware and then configured according to what you gave me above.

This is my lab configuration setup.  I have my PC placed behind the router, and the bridging is working great!  The problem I am now having is that I cannot get to the BVI1 interface.  No reply on ping and I cannot pull SNMP from it.

Any idea why they may be happening?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18126275
Is BVI1 on the same IP subnet as the outside of your sonicwall?

 ISP router --> Eth0 bridged to Eth1 --> hub/swich -->Sonicwall
                                                                \
                                                              Your PC?

0
 

Author Comment

by:CBIA
ID: 18126372
I am actually just testing it within the network, so right now it looks like this:

ISP Router --> Sonicwall --> ESwitch --> Eth0 bridged to Eth1 --> My PC

I will be placing the router in the correct spot once I can confirm that it is operating correctly.  My PC is on the same subnet and IP address range.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18127192
So, you have a crossover cable from PC to router's E1?
PC's IP address is 10.0.6.xxx?
0
 

Author Comment

by:CBIA
ID: 18127229
PC Address is 10.0.6.xxx

What do you mean by E1?  Is that the auxilary port in the back?

This part of a cisco router is totally new to me, please excuse my uneducated venture to get this working right.  =)
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 18127667
E1 = Ethernet 1
You have to use a crossover if going directly to a PC. Else you need a hub/switch in between your PC and the router
0
 

Author Comment

by:CBIA
ID: 18127709
ahhhhhh....  I thought that E1 was somethign else

My workstation is gigabit so it takes advantage of autocrossover, so this is not a problem.  So when the router is between my workstation and the switch, I can surf the internet and use resources just fine.  I just cannot ping that 10.0.6.160 ip I gave the router.  (Nor does SNMP work)

0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Traffic monitoring on Tunnel 7 74
NTP Server in VMware 5 115
Comms between vlans via router 2 22
iPad Won't Connect 16 41
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now