Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Cannot format drives or assign drive letters after changing SATA RAID controller

Posted on 2006-11-14
4
Medium Priority
?
744 Views
Last Modified: 2008-02-01
Hi
I'm running a Windows SBS 2003 box with an Intel SE7210TP1-E motherboard, an 80Gb IDE drive for the system, and a 160Gb  RAID 1 SATA array attached to the onboard Adaptec Hostraid controller that is set up as an extended partition containing two logical drives (D and E) of 120Gb and 40Gb for data and mail. This setup works OK, but I acquired an Adaptec 2410SA hardware SATA RAID controller I wanted to use instead of the software Hostraid.

I backed everything up on the existing RAID 1 array, unmounted the Exchange stores, then shut down the server completely and removed the two WD 160Gb drives. I powered up the server as far as the BIOS setup, disabled the Hostraid controller and switched it off again. Next I installed the 2410SA with two new 160Gb Seagates and configured them as a RAID 1 array using the ARC BIOS utility, then finally booted into SBS 2003 and installed the drivers. Apart from expected complaints from Exchange, the real trouble began when I tried to configure the array with Disk Manager. Basically, nothing worked!

I could initialise the volume using the Initialise and Convert wizard, but I couldn't format the drive or assign it any drive letter. If I chose to not assign a drive letter or path, that didn't work either, merely generating terse and unhelpful messages about internal errors and the format not being able to complete. If I quit Disk Management and opened it again, the Initialise and Convert wizard would appear again and invite me to repeat the whole procedure. If I plugged in a USB flash drive, that was assigned drive letter G:, and not D: or E: as might have been expected. It appears as though Windows 2003 remembers that there was a D: and E: drive and prevents their assignment to removable drives, but why won't it allow any drive letters to be given to the new disk array, and why can I not format it?
Adaptec's Storage Manager reports nothing amiss.

Both the Hostraid and the 2410SA have the latest firmware and drivers, and I have installed the latest version of Adaptec's Storage Manager.

Is there a realistic prospect of simply moving the array to the new controller and expecting it to work, as both are Adaptec?  

I've trawled EE and the web extensively, but to no avail. I am probably overlooking something obvious, but maybe I've been too close to the problem for too many hours now...
0
Comment
Question by:Perarduaadastra
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 8

Accepted Solution

by:
Disorganise earned 1000 total points
ID: 17936597
First off, disable all exchange services so they aren't trying to access the disappeared drive letters.  Repeat for any other services you have like SQL, IIS etc that use your D and E drives.  That should allow for reboot without error messages if its done right.

The inability of the OS to see the drive properly suggest a dodgy cable - I realise the controller see the drives fine, but let me share a recent experience:  we have a recently installed SAN and had a SQL box configured with dual paths to the SAN.  3 of the 4 LUNs worked fine, the 4th would not format.  After some troubleshooting, it appeared the dual pathing software was installed badly and so we re-installed but still had odd issues like the entire server locking up solid.  A full OS re-installed had no effect.  we eventually worked out the cable connecting the racks (not the server to the patch panel) was dodgy and used another port - voilla, all good.  Through all this, the switches etc reported an occassional CRC error but that was it.

you may also need to remove the old drivers as they may be confusin each other.  Also try safe mode to see if the drive letter appear - you may have to tell the OS they're gone
0
 
LVL 15

Author Comment

by:Perarduaadastra
ID: 18413970
That's OK by me.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I previously wrote an article addressing the use of UBCD4WIN and SARDU. All are great, but I have always been an advocate of SARDU. Recently it was suggested that I go back and take a look at Easy2Boot in comparison.
The business world is becoming increasingly integrated with tech. It’s not just for a select few anymore — but what about if you have a small business? It may be easier than you think to integrate technology into your small business, and it’s likely…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question