Solved

Link to msg file

Posted on 2006-11-14
7
2,555 Views
Last Modified: 2010-08-05
I have a web page with links to files on a share on the web server. I have  no problem opening the links when they point to .pdf, .doc, .xls files but if  the link points to a file with the .msg extension (Outlook Express message) I get  the "HTTP Error 404 - File or directory not found" error message, even though the file is in the correct folder. I am able to open the file from the web server after installing Outlook on the server.  I have the default application for .msg files to be outlook.

Running IIS 6.0 on Win 2003 Server w/ SP1


Any ideas as to why I am not able to open the .msg file?
0
Comment
Question by:estackpo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 31

Accepted Solution

by:
alorentz earned 500 total points
ID: 17939337
If you want to allow this, you have to set up IIS to serve .msg file.  They are not allowed by default.
0
 
LVL 31

Expert Comment

by:alorentz
ID: 17939348
Add .msg to MIME types in IIS.
0
 
LVL 1

Author Comment

by:estackpo
ID: 17939450
alorentz

I added a new mime type and put .msg as the extension and application/outlook as the MIME type: and got the same error. What did I do wrong?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 31

Expert Comment

by:alorentz
ID: 17939540
Never tried it with msg files... naybe this will help:
http://support.microsoft.com/default.aspx?scid=kb;en-us;326965 
0
 
LVL 1

Author Comment

by:estackpo
ID: 17939888
I discovered that if I go into the properties of the Virtual directory of the specific Web App I am concerned with and change add the Mime Type there then the link opens with outlook. The only problem now is I get a message that netscape doesnt know how to handle the file type and gives the option to open with the default. This would be ok but the box to always perform this action is grayed out.

If I go to the properties of Netscape and add the mime type to the helper apps then if I select Outlook it opens a blank message with the linked message as an attachment which is not acceptable. In any case it does not let me not ask do I want to do this.

Any ideas on how to handle this last hurdle.
0
 
LVL 31

Expert Comment

by:alorentz
ID: 17940224
This is ASP section, not browser support.  Changing the MIME type as I suggested worked for you.
0
 
LVL 1

Author Comment

by:estackpo
ID: 17940319
Ok, I will check there. Thanks for all your help!
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently decide that I needed a way to make my pages scream on the net.   While searching around how I can accomplish this I stumbled across a great article that stated "minimize the server requests." I got to thinking, hey, I use more than one…
I would like to start this tip/trick by saying Thank You, to all who said that this could not be done, as it forced me to make sure that it could be accomplished. :) To start, I want to make sure everyone understands the importance of utilizing p…
I've attached the XLSM Excel spreadsheet I used in the video and also text files containing the macros used below. https://filedb.experts-exchange.com/incoming/2017/03_w12/1151775/Permutations.txt https://filedb.experts-exchange.com/incoming/201…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question