Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

'PRIMARY' filegroup is full error in SQL Express

Posted on 2006-11-14
17
Medium Priority
?
2,361 Views
Last Modified: 2008-01-09
I am using SQL Express 2005. I am accessing the database through an application that uses C#. When inserting records via my application, I am recieving an error message:

Could not allocate space for object 'abc' in database 'xyz' because the 'PRIMARY' filegroup is full.

There is plenty space left on the disk where the server is stored. That file size of the database is about 2 GB. The database is set to autogrow and unrestricted growth. What else can I be missing? The log file is not real big. All of the things that I have seen that cause this problem are not an issue with the database server. Any suggestions? Thanks in advance.
0
Comment
Question by:lmred
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 4
  • +1
17 Comments
 
LVL 11

Expert Comment

by:regbes
ID: 17940356
Hi crchisholm,

if no one can help

0
 
LVL 143

Expert Comment

by:Guy Hengel [angelIII / a3]
ID: 17940369
please try to add a second datafile to the primary filegroup.
0
 
LVL 11

Expert Comment

by:regbes
ID: 17940375
lmred,

AFIK the limit for SQL express databases is 2GB if you need more than this you will have to up grade to SQL standard ED

0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 1

Author Comment

by:lmred
ID: 17940385
The limit for MSDE is 2 GB, for Sql Express its 4 GB.
0
 
LVL 11

Expert Comment

by:regbes
ID: 17940427
lmred,

correction it is 4GB

http://www.microsoft.com/sql/prodinfo/features/compare-features.mspx

your best bet is angels advice
0
 
LVL 143

Accepted Solution

by:
Guy Hengel [angelIII / a3] earned 375 total points
ID: 17940526
ie, I guess that your filesystem's limit is at 2GB per file
0
 
LVL 29

Expert Comment

by:Nightman
ID: 17940629
Is your hard drive formatted as FAT32 or NTFS?
0
 
LVL 1

Author Comment

by:lmred
ID: 17940637
The second data file sounds like a great idea. I never thought of that. Somebody is currently working on the server. When he finishes, I am going to try that idea.

Let me tell you something guys....you are sure fast with your responses. I don't think I've ever been in another section before that responds this fast. Thanks guys!!! If anybody else can think of another idea until I can check the second data file option, please let me know.
0
 
LVL 1

Author Comment

by:lmred
ID: 17940658
I think its NTFS, but I will have to check after the guy gets off the server.
0
 
LVL 1

Author Comment

by:lmred
ID: 17941305
Ok guys. I found out what the problem is. Duh! SQL Express is installed on the server. However, the database I am using is an MSDE database. So it's hitting the 2 GB limit.

Now how should I go about accepting the right answer?
0
 
LVL 29

Expert Comment

by:Nightman
ID: 17941344
Are you restoring the MSDE database to SQL Express? Or accessing it on an MSDE instance? I have never heard of the limitation after an upgrade - doesn't mean it can't happen, just that I have never heard of it ;)

As for right answer - well, you can always split.
0
 
LVL 1

Author Comment

by:lmred
ID: 17941916
I attached the MSDE database to the SQL Express instance. There is a limit on SQL Express whether you attach or create a new database.
0
 
LVL 29

Expert Comment

by:Nightman
ID: 17941934
Except as already noted the limit on SQL Express is 4GB, not 2GB. So this should not be an issue.
0
 
LVL 1

Author Comment

by:lmred
ID: 17941954
Originally the database was actually MSDE database. I thought it was SQL Expresss since SQL Express was installed on the server. When I realized this, I attached the MSDE db to SQL Express and there was no longer an issue.
0
 
LVL 29

Expert Comment

by:Nightman
ID: 17941980
Oh, OK - sorry. I thought you were having the problem with a backed up MSDE on a SQL Express instance, which made no sense. And since this wasn't the case, that explains why I was confused ;)
0
 
LVL 11

Expert Comment

by:regbes
ID: 17944815
Hi Scripter25,

Import SSIS and DTS type operations are not supported in Express

http://www.microsoft.com/sql/prodinfo/features/compare-features.mspx

save the spreadsheet to a .csv

then use BCP or bulkinsert to get the data in


HTH

R.
0
 
LVL 11

Expert Comment

by:regbes
ID: 17944921
Sorry guys im having a bad time posting answers to the wrong questions
0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
An alternative to the "For XML" way of pivoting and concatenating result sets into strings, and an easy introduction to "common table expressions" (CTEs). Being someone who is always looking for alternatives to "work your data", I came across this …
Using examples as well as descriptions, and references to Books Online, show the different Recovery Models available in SQL Server and explain, as well as show how full, differential and transaction log backups are performed
Viewers will learn how to use the SELECT statement in SQL and will be exposed to the many uses the SELECT statement has.

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question