Solved

Companyweb "Contributors" Group Cannot Complete a Survey

Posted on 2006-11-14
26
880 Views
Last Modified: 2012-06-22
Hi Guys..  
Here is my latest problem with SBS2003.  This one involves Sharepoint.  I have made no modifications to Sharepoint permissions whatsoever.  All of my SBS users are Sharepoint "Contributors".  I've created a survey on companyweb.  Contributors can take the entire survey, but upon submission of the survey, the are prompted with an authentication box.  The box does not dissappear even after entering their network credentials.  If I change the permissions for contributor just for that particular 'list', I can get them to be able to successfully submit the survey, but then they are able to see everyone else's responses.  I want them to not be able to see anyone else's responses, but also be able to complete the survey without authentication, etc..   Any ideas on this?  (Jeff?)  :)

Thanks!!

Chris
0
Comment
Question by:zagnutttt4
  • 14
  • 11
26 Comments
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17942841
On a survey, there are special "item-level" permissions which can be set.  After creating a survey through Create > Surveys go to the General Settings > Change permissions for this survey > Modify item-level security.

Here is where you can change the Read access to "Only their own"

Jeff
TechSoEasy
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17942844
P. S. I'm not sure what other permissions you may have changed that caused the problems to begin with... so just create a new survey to test.

Jeff
TechSoEasy
0
 

Author Comment

by:zagnutttt4
ID: 17949764
Jeff,

I've created a new survey, and I am still getting the same results as with the previous survey.  Here is exactly what is happening:

Under Survey Settings, I make changes so that User Names are shown in survey results.  Also, I am selecting "no" to multiple responses.  
For "Read Access", Users are allowed to only read their own responses.
For "Edit Access", Users cannot edit any responses.

As mentioned earlier, all users are in the category "Contributors", with all of the default permissions for that group.  To see this, I can go under Permissions for that group for the Survey, and the 2nd choice is selected :"View,insert,edit,delete items".  

If I choose "Advanced Permissions", these Contributors have the following permissions listed there:  "View List Items, Add List Items, Edit List Items, Delete List Items, Manage Personal View".  The final 2 choices, "Manage List Permissions, and Manage Lists" are not selected.

With the permissions that I have just quoted, these users can take the entire survey up until the point that they have to submit it, at which point an authentication box pops up for the user.  Upon typing in their Network Credentials, the box just reappears.  After about 3 times of them doing this, the "Request Access to this resource" screen comes up.

Now the only thing that I have tried that has actually allowed these users to complete the survey, is giving them the permission to "Manage Lists".

HOWEVER, once I give them that permission, they are allowed to complete the survey, but then they can see everyone else's responses by clicking on "Show all responses".  

So, somewhere along the line, one of the Sharepoint Permissions, or IIS Permissions, or NTFS Permissions, or SOME type of permission, must be wrong.  Or at least that is what I'm assuming given the behavior that Companyweb is demonstrating.  

On a side note (This may be related to the same problem), If I go into the "Server Management" screen on the SBS Server, and I go under "Monitoring and Reporting", my right side screen shows "The Page Cannot be Found".  

Help Jeff!!!

Chris
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17952734
On the results screen (that comes up after the authentication box pops up) are there any images which are not standard to SharePoint?  

If not, then check the images that ARE there to make sure that their permissions are set correctly in the NTFS folder in which they reside.  The default directory for icons and the like is C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\TEMPLATE\LAYOUTS\1033\IMAGES

The other thought, if it's not the images, is where you've chosen to store the results of the survey.  Or some such thing like that... because what its sounding like to me is that there is SOME element that's being introduced at that moment which is not already authenticated.

Jeff
TechSoEasy
0
 

Author Comment

by:zagnutttt4
ID: 17953062
Good idea with the images..

I will check that out tomorrow.  I agree with your line of thought on this...

I will keep you posted..

Thanks,

Chris
0
 

Author Comment

by:zagnutttt4
ID: 17956188
Jeff,

I have tried a few things that you mentioned.  Here are responses to your previous comment:

"On the results screen (that comes up after the authentication box pops up) are there any images which are not standard to SharePoint?"
     [Chris]  There are no images here that are not standard to Sharepoint.  Once the user clicks on "Save" for submitting the survey, the authentication box pops up and they are unable to do anything.  After several tries, the screen comes up asking them to fill out a request for resources.  Bear in mind that even if they fill this out, I recieve an email asking me to grant, or deny them, access to this resource.  If I grant them access, they still get the same result.

"The default directory for icons and the like is C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\TEMPLATE\LAYOUTS\1033\IMAGES"
     [Chris] I have checked this directory and all NTFS permissions on this directory are correct, as well as all files within that directory.

 
"The other thought, if it's not the images, is where you've chosen to store the results of the survey."
     [Chris] How would I check where the results of the survey are being stored?  I wasn't aware that you could even choose the physical location that these items could be stored.  If I could locate this directory and/or file, I could quickly check the NTFS permissions on that as well.

Thanks,

Chris

0
 

Author Comment

by:zagnutttt4
ID: 17962019
Can I insert this thread into an additional Topic Area (Sharepoint) to broaden its scope?

Chris
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17962552
Sure... post a 20pt POINTER question over there.  See this for how:  http://www.experts-exchange.com/help.jsp#hi262

Or you can use the POINTER question wizard found at:  http://ee-stuff.com/Expert/pointer/  (use your EE username and password to log in).

Jeff
TechSoEasy
0
 

Author Comment

by:zagnutttt4
ID: 17984572
Any ideas, anyone?
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17984751
Chris,

If you create a new user with the SBS's add-user wizard... does that user also have the same issues?

Jeff
TechSoEasy
0
 

Author Comment

by:zagnutttt4
ID: 17984926
Hi Jeff..

I have not tried that yet.  However, each user that has already attempted access to the survey was initially created with the Wizard to begin with.
I will try that, though.

Chris
0
 

Author Comment

by:zagnutttt4
ID: 17992048
Jeff,

Another update.  Today, I created a new survey from scratch.  I created several users with the Wizard.  Same results as before..
Also, when the server sends me my performance report each morning at 6 A.M., it is now a blank page with "Bad Host Name".  
I can manually browse to the Performance Report and it shows up fine.  However, I would like it to show up in my auto-emails each morning as well.

Chris
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17992099
Okay... let's take a look at your IIS configuration.  Please open IIS Manager > Servername > Web Sites.  Then, right click in the blank space in the right pane under the list of web sites and select "Export List...".  Post that list back here.

Jeff
TechSoEasy
0
 

Author Comment

by:zagnutttt4
ID: 17992276
They aren't lined up very well, but the information is there.
--------------------------------------------------------------------------------------------------------------------------------


Description      Identifier      State      Host header value      IP address      Port      SSL Port      Status
Default Web Site      1      Running            10.0.0.1      80      443      
Microsoft SharePoint Administration      2      Running            * All Unassigned *      8774            
SharePoint Central Administration      3      Running            * All Unassigned *      8081            
companyweb      4      Running      companyweb      10.0.0.1      80      444      
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17992423
No problem with the formatting...

Your Default Web Site needs to be set as *All Unassigned*.  This is most likely something you changed when you were fiddling with the RPC over HTTPS issue.

Also, I'm wondering if this whole issue isn't related to this:  http:Q_21935501.html

Jeff
TechSoEasy
0
 

Author Comment

by:zagnutttt4
ID: 17992457
Jeff,

I will set my Default Web Site to listen on "All Unassigned" IP Addresses, but how will this have any affect on my companyweb functionality, which is a completely different website in IIS?

Also, in reference to my previous problem with the password settings, I will look into that again, but at that point I had made literally no changes to AD, Sharepoint, etc..   So I'm not so sure if it is directly related to the Sharepoint issues I am having, but I'm sure it is possible.

For what it's worth, what affect will changing the listening IP on my default website have?

Thanks,

Chris
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17992468
Well, the All Unassigned should fix the Monitoring Emails at the very least.  You should restart IIS after making that change.  You might also want to run the CEICW as well.  Do you get any errors when running the CEICW?

Jeff
TechSoEasy
0
 

Author Comment

by:zagnutttt4
ID: 17992479
I haven't tried the CEICW lately since I've been having these problems w/ Sharepoint.  I am going to attempt to change the listening IP to All Unassigned on Default WebSite and see if I can send myself an email containing the performance report.  (monitoring email).
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17992486
Also, lets just doublecheck the security settings on the companyweb site.  Just in case something was modified.

Open the Properties of that site > Directory Security Tab.

Then, Click the first Edit... button and you should ONLY have Integrated Windows authentication checked.  Nothing else.

Jeff
TechSoEasy

0
 

Author Comment

by:zagnutttt4
ID: 17992516
Jeff,

I changed the default Website to listen on All Unassigned, and it fixed my "Monitoring and Reporting" functionality.  Sweet!!

On to my next task..  I will now check the Directory Security Tab of Companyweb, and see which methods of authentication are checked.

0
 

Author Comment

by:zagnutttt4
ID: 17992529
Update:

On my Companyweb Directory Security Tab, two forms of authentication were checked:  Integrated Windows, AND Basic.
I have unchecked Basic, and the only form of authentication that is checked now is "Integrated Windows Authentication".

Anonymous Access, of course, is still disabled.

0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17996091
If that doesn't resolve the permissions issue for SharePoint, I would go ahead and reinstall it by following this KB article:

http://support.microsoft.com/kb/829114

Jeff
TechSoEasy
0
 

Author Comment

by:zagnutttt4
ID: 17996232
Hi Jeff..

I was just about to type you back, and tell you that changing the authentication method on my companyweb did not fix the permissions issues regarding my surveys.

Do you feel that reinstalling it will be necessary?

Chris
0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 250 total points
ID: 17997064
Do I feel that it will be necessary?  I think it will fix your problem.... so if you think fixing the problem is necessary, then I would say that reinstalling is a well.  :-)

Truth is that reinstalling is not a distructive process... it'll just fix things to the way they need to be.  But, as always, be sure to completely backup your server before doing any major installation.  Also, make a copy of your MSSQL$SHAREPOINT folder... especially the mdf data files.

Jeff
TechSoEasy
0
 

Author Comment

by:zagnutttt4
ID: 17997132
Thanks Jeff,

I will be setting aside a period of downtime for uninstalling/reinstalling Sharepoint.  I agree that it will probably fix my problem.

I will keep you posted...

Chris
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

In the event you manage a Small Business Server 2003, and you are audited for PCI compliance, there are several changes you must make in order to pass the audit. I can take no credit for discovering any of these fixes or workarounds, but there is no…
I work for a company that primarily works with small businesses as their outsourced IT vendor. As such the majority of these customers utilize some version of Small Business Server. Due to the economics of running a small business, many of these cus…
This video discusses moving either the default database or any database to a new volume.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now