Solved

Opening network path from Windows Mobile 5.0

Posted on 2006-11-14
13
3,977 Views
Last Modified: 2013-12-27
I am trying to open a shared folder on a Windows Server 2003 server from my Windows Mobile 5.0 device. The sever is also a domain controller for my Active Directory domain. It comes up with the login screen the first time I connect, I enter a valid username and password and it just keeps coming up with this screen again and again.

I have sucessfully connected to a shared folder on a Windows XP machine that is part of the domain using the same username and password and it connects with no problems.

Has anybody been able to get this working or know if it is possible?
0
Comment
Question by:lecutis
13 Comments
 
LVL 1

Expert Comment

by:jkanisut
Comment Utility

On the username, did you try to prefix the domain.  e.g.:  {domain}\{username}  ?

Also, I don't think it's possible to connect to a folder via the handheld.
0
 
LVL 3

Author Comment

by:lecutis
Comment Utility
Yes, I have tried the username in the format you suggested but did not work.

I have managed to connect to a shared folder on an XP machine, it just does not work on the 2003 machine.
0
 
LVL 1

Expert Comment

by:jkanisut
Comment Utility

Can you ping the handheld from the W2003 machine?
0
 
LVL 3

Author Comment

by:lecutis
Comment Utility
Yes I can ping the Windows mobile from the 2003 machine
0
 
LVL 7

Expert Comment

by:CJCraft
Comment Utility
You are correct. It should work. Try connecting to the c$ machinename\c$\ and see what happens. Do you have the machine admin account information try that also
0
 
LVL 3

Author Comment

by:lecutis
Comment Utility
Have just tried that, and still getting the same thing
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 1

Expert Comment

by:jkanisut
Comment Utility

Double-check to make sure you have a connected network connection before trying...
0
 
LVL 3

Author Comment

by:lecutis
Comment Utility
Not quite sure what you mean, but the server is on the network and can be browsed to by an XP machine.
0
 
LVL 1

Expert Comment

by:jkanisut
Comment Utility
Can you connect; say to a website via the browser on the hand-held?  Maybe a web page on that server just to check connectivity?

Is the device cradled and a conduit opened (ActiveSync)?
0
 
LVL 3

Author Comment

by:lecutis
Comment Utility
I have just secessfully connected to a website on the server and on the internet.

I am connecting via WIFI
0
 
LVL 1

Expert Comment

by:jkanisut
Comment Utility

Looking back at your original question... are you supplying the domain name?

When I try to connect to a shared folder I get the "Network Path was not found" when using the file explorer.  However, when I set the share to be web shared, I can connect and open the files from IE on the handheld... it just uses a ftp like interface.

0
 
LVL 9

Accepted Solution

by:
checoo earned 500 total points
Comment Utility
Actually the problem is related to the higher SMB protocol security settings in a W2k3 domain controller (note, the problem doesn't occure with shares exported by W2k3 or XP domain members).

Unlike a domain member the W2k3 domain controller requires all clients to use SMB signing. It seems Windows Mobile 5.0 doesn't
support SMB signing which is the cause for the problem. To disable it, on the domain controller in the registry set:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]"requiresecuritysignature"=dword:00000000

Then stop the LanManager server and all dependent services either from the GUI or from the command line:

net stop server

Confirm to stop the dependent services and then start them again:

net start server
net start netlogon
net start dfs
net start browser

The above changes might help you in connecting your WM5 to Win2K3 but I ma not sure if this will cause any security hazard!!!
0
 
LVL 3

Author Comment

by:lecutis
Comment Utility
Thanks checoo, I did'nt follow your instructions but after you mentioned SMB signing I remembered an option in the Default Domain Controller Group Policy. Under Computer Configuration>Windows Settings>Security Settings>Local Policies>Security Options I disabled 'Microsoft network server: Digitally sign communications (always)'. And I was able to sucessfuly connect to a share on the server.
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

When I was a beginner in Windows Mobile programming, even for small test I used to create a single MFC dialog-based application with one button, and put my test code in the OnLButtonDown method. For Pocket PC it worked fine, on some Windows CE d…
As the title indicates, I have done this before. It chills me everytime I update the OS on my phone, (http://www.experts-exchange.com/articles/18084/Upgrading-to-Android-5-0-Lollipop.html) because one time I did this and I essentially had a bricked …
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now