Solved

IIS 6.0 How to create FTP site with any home directory

Posted on 2006-11-14
13
677 Views
Last Modified: 2013-11-29
Hello!  

Please help!

Is it possible to create FTP site that point to home directory that is not under c:\Inetpub\ftproot, but under c:\Inetpub\wwwroot instead?  Please provide details on how to.
0
Comment
Question by:vchitta
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 3
  • +1
13 Comments
 
LVL 7

Expert Comment

by:instillmotion
ID: 17942670
Sure,
Go to:

Internet Services Manager console > Right click the Ftp site > Properties > Home Directory Tab.
Browse to the new directory.

0
 
LVL 7

Expert Comment

by:dlangr
ID: 17942755
don't forget to give the appropiate permissions to the account that is accessing the directory
0
 

Author Comment

by:vchitta
ID: 17943237

I did all that and now I'm getting home directory not accessible error.  
0
Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

 
LVL 17

Expert Comment

by:kadadi_v
ID: 17947597
I think you have to add the user as administrator in that ftp site (Right CLick to that ftp site >properties>directory security>edit anonymous access & authetication) coz default is IUSR_computername .
0
 
LVL 7

Expert Comment

by:instillmotion
ID: 17948557
If it was working with C:\Inetpub|ftproot. Make sure the permissions are the same on the wwwroot directory. Make sure the local user you created has rights on their user directory under wwwroot.
0
 

Author Comment

by:vchitta
ID: 17951586
Hmm..no luck so far.  I tried all of the above and still "home directory not accessible" error.  Is it because IIS 6.0 only allow ftp folder to be accessible only under C:\Inetpub\ftproot.  My is under C:\Inetpub\wwwroot instead, but I want my web user to be able to access his application folder though.

 I'm runing SBS 2003; Is there another way beside IIS?
0
 
LVL 7

Expert Comment

by:instillmotion
ID: 17951630
The location of the folder is not the problem. It's a rights issue.
Do you have directories under wwwroot for each user? each directory needs to have the user's rights assigned to it.
Also the parent directory need at least read&execute, List Folder Contents and Read rights to a group that all users belong to.
0
 

Author Comment

by:vchitta
ID: 17951773
I tried all that.  Please let me know if I'm missing a step somewhere.  Here's what I did:

Just for testing purpose
- created a new user "ftpuser1" using admin template
- added user to wwwroot with full access
- added user to inventory folder with full access
==> got same result

I then tried
- created a new user under active directory (type = user)
- grant full access like above
==> same result

Then I tried
- created new ftp site using active directory option
- grant access like above
==> same result

I tested using
IE6 ==> I could not get pass the logon pop up.  error = "could not login to the ftp server using username and password"  
WSFTP==> home directory not accessible

Not sure what to try next







0
 

Author Comment

by:vchitta
ID: 17951785
I also added user to ftp site under "permission" and set home directory to Inventory folder under wwwroot
0
 
LVL 7

Expert Comment

by:instillmotion
ID: 17951804
try changing the name of Inventory folder under wwwroot to "ftpuser1". Basically let the name of the folder match the name of the user.
0
 

Author Comment

by:vchitta
ID: 17953624
did that also.
0
 
LVL 7

Expert Comment

by:dlangr
ID: 17972737
Try this:

- Create a new ftp site, choose "user isolation mode" (not the AD option)
- make a virtual directory in the ftp site, with the name of the user, wich points to the directory where you want the user to go to.
- Make sure to have an real directory with the same name as the user in wwwroot.
- Make sure the home directory of the ftp site points to the wwwroot.

Now try again.

0
 
LVL 7

Accepted Solution

by:
dlangr earned 125 total points
ID: 17972740
i forgot, if the above does not work, create a directory with the name of your domain under wwwroot and then create a directory with the name of the user under the directory with your domain name.
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Did you know that more than 4 billion data records have been recorded as lost or stolen since 2013? It was a staggering number brought to our attention during last week’s ManageEngine webinar, where attendees received a comprehensive look at the ma…
Active Directory security has been a hot topic of late, and for good reason. With 90% of the world’s organization using this system to manage access to all parts of their IT infrastructure, knowing how to protect against threats and keep vulnerabil…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question