relay errors

hi i've just set up an exchange server.  the link to my initial issues are below.  please read first for background.

http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_22059647.html#17937213

now i can send internally, i can recieve externally but get relay error when sending externally.  5.7.1 relay permission error.
i have tried adding my ip range to the relay permission, no luck.

i also noticed in my queues that i have a queue of server 1 (old server) could this be causing any problems  (refer to previous post)

please help and also help me make this a secure exchange so i dont get bombarded with spammers using my mail server and then i get blacklisted.

thankyou

LVL 6
rick81Asked:
Who is Participating?
 
ikm7176Sr. IT ManagerCommented:
You can uninstall exchange from the server1, the proceedurs is described in the link i posted above.

There are several drawbacks of running exchange on the Domain Controller. see the link below for details
http://www.microsoft.com/technet/prodtechnol/exchange/Analyzer/7423376e-686b-4cda-b90f-cf5cff4f8981.mspx?mfr=true

Before uninstalling server1 make sure that you  Rehome any public folders and roles held by the old Exchange Server computer to the new Exchange Server computer.
Also move all your mailboxes to your server2.

cheers !!
0
 
ikm7176Sr. IT ManagerCommented:
If the Allow all computers which successfully authenticate to relay regardless of the list above check box is not selected on the SMTP virtual server, you may receive NDRs that contain error code 5.7.1. To select the Allow all computers which successfully authenticate to relay regardless of the list above check box, follow these steps:1. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
2. In Exchange System Manager, expand the following object:
Servers\Your_Exchange_Server_Name\Protocols\SMTP
3. Right-click the SMTP virtual server object, and then click Properties.
4. Click the Access tab, and then click Relay. Click to select the Allow all computers which successfully authenticate to relay regardless of the list above check box.


Read the link below
http://support.microsoft.com/kb/895853
0
 
rick81Author Commented:
no good.  tried that already

any other suggestions
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
ikm7176Sr. IT ManagerCommented:

Enable the message tracking to track the messages
http://www.msexchange.org/tutorials/Exchange-2003-Message-Tracking-Logging.html

can you send mail using telnet
http://support.microsoft.com/kb/153119

Do you have any 3rd party softwares on your exchange server?

As you are using your ISP's smarthost, it is possible that your smarthost is not allowing your server to relay. If it needs authentication, configure your SMTP virtual server to provide authentication to smarthost.



0
 
rick81Author Commented:
i have no 3rd party software.  i am using my ISP as smarthost.  I have used a user account to authenticate.  no luck.  they are not a massive ISP, im hoping i dont have to authenticate.  ive tried anonymus also.

i cannot send via telnet.  recieve the same relay error

i have not enabled the message tracker as i recieve the relay email error straight away when sending.  there is no delay or anything.

have you read my previous post (link at the top)  i think this may have something to do with the first exchange installation on another server i have causing the problem.

i am also using a test domain that i have, to intially setup exchange.  it is not the same as my server domain.  the test domain is used soley to get mail working before moving the server domain over. (as mail is hosted elsewhere for this domain)  i have noticed the FQDN is my server domain. (the one thats hosted remotely)  it is not my test domain.  could this be the problem?  i have set the test domain as the primary recepient policy aswell as the server domain (not that i expect the server domain to work yet.

if i send an email internally it comes up with user@testdomain.com which is fine and like i said i can do everything but send externally

im stuck, hope this makes sense
0
 
ikm7176Sr. IT ManagerCommented:
Is your 1st server still online ? can you shutdown it, what error u get if you shutdown that server. This is to rule out the possiblity that this problem is related to you exchange server1

Its a classic problem of relay authentication, i have read your other post. i guess that you want to retire your old server. follow the link below

http://www.swinc.com/resources/exchange/faq_db.asp?status=questions&faqID=1001&faqname=Exchange%202000§ionID=1024§ionName=Exchange%202000%20Move%20Server%20Method

Read the additional resources carefully. I gues you missed something in the process of moving to your new exchange server.

cheers !


0
 
Nilesh RoySenior Manager - Technology ManagementCommented:
hi,

can u give me the exact smtp error message?

i hope your IP address is not blacklisted.

regards,

nilesh roy.
0
 
rick81Author Commented:
5.7.1 is the exact error.  i will shut down server 1 2nite and try it.

i am not on a blacklist.  i have checked that

ill get back to you on this.  thanks
0
 
rick81Author Commented:
i was going to try and uninstall exchange from server 1.  is this ok
i dont want to demote it as both server are DC's
0
 
rick81Author Commented:
the server 1 was a failed installation.  it has no mailboxes or public folders attached to it.  as far as i know anyway.
thats y i have installed on server2.  will keep you posted.
0
 
Nilesh RoySenior Manager - Technology ManagementCommented:
Hi!!

Check out this m/s link --> http://www.microsoft.com/exchange/techinfo/tips/trblsht_tip01.asp

Resolving Nondelivery Reports Caused by 5.7.1 or 5.7.3 Errors

- Nilesh.
0
 
rick81Author Commented:
I resolved my issue today successfully.
After uninstalling the exchange on server1 successfully.
Setting the appropriate relay authentication, works great!!

thanks for all your help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.