Solved

SBS2003 / Acronis True Image Server / USB Drivers Question

Posted on 2006-11-15
7
1,051 Views
Last Modified: 2016-10-27
Hi

Not specifically an SBS based question, but it's related to an SBS installation so there seemed no better place to ask this question ...

I'm trying to use Acronis True Image Server to backup to an external USB2.0 drive.  When its in progress, I get critical performance alerts from the server as it takes 95-100% of cpu time.  The priority is to LOW.  I have yet to get a backup to complete ...
I can back up to the same USB drive from XP Pro using Norton Ghost and I get no such similar problems.  The XP PC remains responsive and the backup completes in an acceptable time.

Now, either True Image Server 9 is rubbish, or there's a server issue.
In looking at the drivers for the USB ports on the server, there are 4 instances of USB Universal Host Controller, and 1 instance of USB Enhanced USB2.0 Controller.  The motherboard is an Asus P4C800 Deluxe and features 4 rear USB2.0 ports and 2 front panel USB2.0 ports. The usb drive is connected to an external port.

Assuming that part of the issue is that data is being transferred at USB1.1 speeds, I have a few questions :

1. How can i identify which physical port(s) are installed as usb 2, and which as usb 1.1 ?
2. Why aren't all the USB controllers installed as enhanced (usbehci.sys) ?  I have tried updating the drivers for the controllers not installed as USB2, but it won't let me (not without warning that they are the wrong drivers at least).
3. Any comments appreciated ...

I'm running 2003 SBS Service Pack 1.

Thanks
Jase
0
Comment
Question by:eMicros
  • 4
  • 2
7 Comments
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 25 total points
ID: 17948225
Well, considering that the Asus P4C800 Deluxe is not really designed as a Server Mother Board, I'd first question why you are using it.  It's not as simple as the USB drivers or even if the ports are 2.0 or 1.1 (even though they are all 2.0 on the P4C800).  But rather the bus that those ports are attached to and what else needs to run on that bus, the type and configuration of the drives you are imaging as well as the type and speed of the drive you are backing up to, the L2Cache as well as the specific memory space that Acronis uses are just some of the things that can affect this.

To tell you the truth though, I don't know enough about this stuff to tell you why Acronis runs so much slower than Ghost, but I do know that I've been using Acronis True Image Server 9 on various SERVERS for the past year with no issues that you're referring to.  Most of the servers I deploy are Dell PowerEdge 1800's,  1850's, 2600 or 2650's.  These machines are designed to be used as servers and thus I don't spend any time at all troubleshooting things like you describe.  

Jeff
TechSoEasy
0
 

Author Comment

by:eMicros
ID: 17960487
Hi Jeff

It's not a production server, it's just my own test rig.  It copes alright ...

When I updated my entertainment PC, I built a second from the old parts - a P4C800 Deluxe, 1Gb DDR400 Dual Channel and a hyperthreaded 3.0ghz P4 800FSB 1Mb L2.  I needed to familiarise myself with SBS2003, so i added a 10,000 RPM Raptor HD & installed onto that.  It's a decent enough spec, it's not under any strains and doesn't have any domain clients connected to it.  It just serves a single pc with files, email & a laser printer.

The laser printer is the only device connected to usb, and that spends 99.9% of its life on standby ... but when I run Acronis on it, it kills it.  I accept your comments that it's not a "server board", but it's more than capable of backing up to a USB drive (which incidentally is a 250gb Western Digital 7200RPM, 8Mb Cache, in a USB 2.0 caddy).

Most of my USB ports are using 1.1 drivers, but it makes no sense why.  When it was installed under XP, they were all USB2.0.  Now under SBS2003 SP1, they're 1.1.  I can find no manufacturer drivers for USB2, they're just delivered with Windows now.  And it simply won't let me update to 2.0. Frustrating.  I have the Release 2 cd from microsoft for SBS2003 and was toying with installing that, but didn't think it would make any difference to USB drivers, and besides I want to keep my server on the same release as my clients server.

Have you backed up to an external USB drive using Acronis, Jeff ?

Thanks
Jase
0
 
LVL 6

Assisted Solution

by:manicsquirrel
manicsquirrel earned 50 total points
ID: 17961402
"Have you backed up to an external USB drive using Acronis, Jeff ?"

We do it all the time.  I have several customers using USB JBOD enclosures with removable drive bays backing up their servers with Acronis TrueImage 9.x and 10.x .  I haven't had a problem yet.

You did mention that when Acronis is running (and I am assuming writing to the USB HDD) that it kills your laser printer.  Power hog maybe?  Is the USB HDD passively powered.  In other words, is it getting its juice from the USB port or an external power supply?  Either way, I would try using a powered USB2.0 hub.  Plug the HDD into that.

As far as how to tell which USB ports are which, I couldn't say.  Your motherboard should be more than capable of running all that you need wether it was "designed" for a server or not.  I've got SBS2003 running on an OLD, OLD Dell PowerEdge 1500 with a Pentium III and 1 GB of RAM.  I've never had a problem and I beat the thing to death.  It also runs Acronis nightly, although to a NAS not a USB drive.  The troughput on USB 2.0, in practice, is much, much faster than 10/100 over ethernet.
0
Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.

 

Author Comment

by:eMicros
ID: 17961813
Hi

Thanks for your reply.

Sorry, I wasn't clear in my last post.  When Acronis runs (is backing up to the usb drive), the SERVER is killed, NOT the laser.  I was just indicating that the only other USB device connected to the server is a laser (on standby when backups occur).

As soon as Acronis starts to backup to the USB drive, the server generates perfomance reports to my admin email, task manager shows 95-100% usage by Acronis, and eventually it will blue screen before any backup completes.

The server works perfect (as much as anything can be i guess) for everything else.  It's never down and it does everything i need it to, which is mostly to collect my email and send it on to my blackberry ...

It's reasonable to assume that even under usb1.1, Acronis shouldn't kill my server.  Quite likely the speed of usb is not the issue, but i was disconcerted to note that 2003sbs sp1 has my usb2 ports installed with the wrong drivers and won't let me replace them.  So i guess the question is really a 2 parter.

1. how to correct the driver issue under 2003 / identify which ports are on which host controller ...
2. ascertain that acronis can backup fine to a usb drive and that my experience isn't a common one.

I'm sure we've dealt with part 2, so it just remains : how can i get these host controllers to use the correct usb2 driver?
If i can at least get up to 2.0 and still have problems with Acronis, at least then I know not to convert my evaluation version into a $600 licence purchase.

Any ideas welcomed.  

0
 

Author Comment

by:eMicros
ID: 17961827
oh, and the usb hdd is mains powered and connected directly to usb on the motherboard, not via a hub.
0
 
LVL 6

Assisted Solution

by:manicsquirrel
manicsquirrel earned 50 total points
ID: 17961900
What build of Acronis are you using?  The current build is 3832.

Some background with me and Acronis: we have been a Partner for several years.  In the rare instances that Acronis does have a problem contact their support staff.  If needed they will send you a small executable to run on your system which takes a snapshot of your server.  On more than one occasion they have produced a custom build for my customers at no charge to accomodate their setup.  Turn around time was a couple of days.

They could better answer you though.  Even though you are in trial mode, you can submit questions or problems to their official forum which is monitored by their support staff at http://www.wilderssecurity.com/forumdisplay.php?f=65 .  They may have an answer for you.
0
 

Author Comment

by:eMicros
ID: 17972996
Well, I gave up trying to work out why my USB ports are using the wrong drivers and just backed up to another partition of the same hard drive to test out Acronis.  The server would just flatline at or just below 100% as soon as the backup job starts - even while preparing data to be written and not actually writing to a drive.

I've played around with the windows sbs backup feature, and that is able to backup my server drive and important data to my USB drive each night without ever going over 20% (in peaks and troughs) - the backup completes and verifies and I've restored the archives to test its all ok - and it is.

At least I just saved myself $600 on Acronis, which just won't work for me.  I'm actually quite impressed with the Windows SBS backup facility ...

I've split the points amongst the contributors as they are all valid points, but ultimately Acronis was just not important enough to me to spend any more time worrying about it.  

Thanks
Jase
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Join & Write a Comment

This guide is intended to provide step by step instructions on how to migrate from Small Business Server 2003 to Small Business Server 2011. NOTE: This guide has been written using the preview version of SBS2011 therefore some of the screens may …
If you are a user of the discontinued Microsoft Office Accounting 2008 (MSOA) and have to move to a new computer running Windows 8, you will be unhappy to discover that it won't install.  In particular, Microsoft SQL Server 2005 Express Edition (SSE…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now