Solved

FreeNX and NXclient problem

Posted on 2006-11-15
14
511 Views
Last Modified: 2008-01-09
I have a FC4 system, setup with FreeNX Server.

The NX system works perfectly fine when I am on my intranet. I can do my stuff easily like that.

However, when I leave my intranet, (ie work) I can't connect to it.

I though oH, it must have been the SSH port not being forward, so I double checked it with SSH, it works.

I can do everything via bash from work. so the port must not be blocked.

The following is how my NX Client failed.

replaced my ip with xxx.xxx.xxx.xxx

NX> 203 NXSSH running with pid: 3324
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: xxx.xxx.xxx.xxx on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.5.0-50-SVN OS (GPL)
NX> 105 which: no xauth in (/usr/local/bin:/bin:/usr/bin)
hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: chungs
NX> 102 Password:
NX> 103 Welcome to: server.home.net user: chungs
which: no xauth in (/usr/local/bin:/bin:/usr/bin)
NX> 105 listsession --user="chungs" --status="suspended,running" --geometry="1280x1024x32+render" --type="unix-gnome"
NX> 127 Sessions list of user 'chungs' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: chungs
NX> 105 startsession  --link="modem" --backingstore="1" --nodelay="1" --encryption="1" --cache="8M" --images="32M" --media="0" --session="home" --type="unix-gnome" --geometry="1280x1024" --kbtype="pc102/en_US" --screeninfo="1280x1024x32+render"

which: no xauth in (/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin)
NX> 1000 NXNODE - Version 1.5.0-50-SVN OS (GPL)
NX> 700 Session id: server.home.net-1000-D468732CBAC756D51FAB15AF45372707
NX> 705 Session display: 1000
NX> 703 Session type: unix-gnome
NX> 701 Proxy cookie: 55bdef46c9b8124fb043f3fea92efe52
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: 55bdef46c9b8124fb043f3fea92efe52
NX> 704 Session cache: unix-gnome
NX> 707 SSL tunneling: 1
NX> 105 /usr/bin/nxserver: line 1077:  1963 Terminated              sleep $AGENT_STARTUP_TIMEOUT
NX> 596 Session startup failed.
Killed by signal 15.

0
Comment
Question by:SamsonChung
  • 9
  • 5
14 Comments
 
LVL 24

Expert Comment

by:slyong
ID: 17950983
Hi,

Is xauth giving you the problem?  You might want to try putting in xauth:

# yum install xorg-x11-xauth

should do the trick to install.. not sure if that is the problem though
0
 
LVL 6

Author Comment

by:SamsonChung
ID: 17951079
Yum said.

Nothing to do

I guess either I already have it, or just don't have the repo set

btw, i did a

yum install *xorg-x11-xauth*
0
 
LVL 24

Expert Comment

by:slyong
ID: 17951117
can you check:

# which xauth
0
Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

 
LVL 6

Author Comment

by:SamsonChung
ID: 17951134
/usr/X11R6/bin/xauth

0
 
LVL 24

Expert Comment

by:slyong
ID: 17951445
Weird because you seems to have xauth installed but then NX complains that you don't have xauth... are you on the server.home.net machine just to make sure?
0
 
LVL 6

Author Comment

by:SamsonChung
ID: 17956293
No..

What I am trying to do is a remote dial in.

So, basically, NX works perfectly fine when I am on my local Intranet.... I have a some what of a decent network setup at home.

I am trying to access the NX server from outside of my intranet. and that was the error that poped up.

I tried SSH, and ssh worked fine.
0
 
LVL 24

Expert Comment

by:slyong
ID: 17958705
xauth should be installed in server.home.net machine.
0
 
LVL 6

Author Comment

by:SamsonChung
ID: 17958790
yep it is.

what I am puzzled about is.

why is there a reference to 127.0.0.1 too..

is it possible that my problems occur due to a routing issue?

I did forward port 22 to server.home.net

0
 
LVL 24

Accepted Solution

by:
slyong earned 500 total points
ID: 17959066
hmmm... I am not sure.. let me do a quick test may be later in the evening.
0
 
LVL 6

Author Comment

by:SamsonChung
ID: 17959089
i was also testing NoMachine's systems.. i was having amazing link to them. so that means my current system is capable of going there.

so, the question should be limited to, if FreeNX need configuration to work properly if it is behind a router, with a private IP address inside.

0
 
LVL 6

Author Comment

by:SamsonChung
ID: 17982377
Are there any other things one can do??

would Freenx requires another port beside 22?
0
 
LVL 6

Author Comment

by:SamsonChung
ID: 17990305
T_T no one know what else I can do??

I still can't answer why nxserver works within the private network, but it won't work if I am outside....

T_T
0
 
LVL 6

Author Comment

by:SamsonChung
ID: 18020950
T_T
0
 
LVL 6

Author Comment

by:SamsonChung
ID: 18076520
Hey, I've decided to close this thread.

I believe my solution was FreeNX is not completely setup to work with routed users.

I'll most likely install NXServer OSv to see if there is a difference

Thanks
0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question