• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1290
  • Last Modified:

Ghost background image showing when printing images in Indesign file -HELP!

I try to add a logo in InDesign that has transparent background in a brochure. On screen looks great but when I print it I can see lighter ghost background where the transparent background should be. THIS ONLY HAPPENS on documents with colored background. I tried to insert the image as psd file instead of jpg,or npg but it still has the ghost background when I print!!! I even tried adding color background on the logo to match the background of the document but it still shows lighter when I print it. I also set transparency blending space on CMYK, but when I try to set transparency flattener presets to high res, they always go back to low res! I don't know if that's causing the problem.
Please help as I lost hope that I can fix this!

  • 4
  • 3
1 Solution
I would highly recommend using a clipping path and not rely on transparency, but what settings are you using when you print? What printer are you using?
Shiseiryu1Author Commented:
I am using Dell Laser Printer 3000cn, but I don' think it's the printer, because I tried on couple of them. For print settings, I used High Quality, without any image compression.
Now, I've heard about using clipping paths but I have no idea how to do it.
Can you please tell me the steps?

Thank you very much
Slow down a second...

By High Quality, what do you mean? Are talking about the Advanced tab where you can choose the Transparency Flattener?

In the Print Dialogue box, can you tell me what you choose for the
Marks and Bleed
Color managment

Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

Shiseiryu1Author Commented:
This is what I did:

General - didn't change anything
Setup -Centered
Marks and Bleeds -Use document bleed settings
Output - Composite gray (I have no clue why it doesn't let me select composite CMYK here)
Graphics-Send data-ALL
Color Management -Print Document-(U.S. Webcoated SWOP v2) -I don't know if this is right either!
Advanced: High Res transparency

Sounds like a clipping path is in order.

I would save a flattened copy out and use it. Open it, open the paths tool, and draw your path around the area you want to display. You will need to know bezier curves, here is a couple tutorials:

Open the paths pallette, create new path via the drop down menu, name the path, draw the path, and then designate it a clipping path via the drop down menu. You will need to save it out as an eps or tiff, but if you place this, it should work.
Shiseiryu1Author Commented:
That works! Now I wish there was a more intuitive way of doing it, because the image that I was doing the path around contains text,and several vector shapes. It is very time consuming to go around all the letters, but at least I know one method that really works.

Thanks BongSoo for your help!
I wish we could have solved it  the other way, but it may have something to do with your PPD.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Train for your Pen Testing Engineer Certification

Enroll today in this bundle of courses to gain experience in the logistics of pen testing, Linux fundamentals, vulnerability assessments, detecting live systems, and more! This series, valued at $3,000, is free for Premium members, Team Accounts, and Qualified Experts.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now