Solved

Continuously receiving an HTTP 401.3 error on images (localhost)

Posted on 2006-11-15
5
868 Views
Last Modified: 2012-05-05
I'm running IIS 5.1 on XP Pro sp2 - everything is running on local host.  I'm logged in as a local admin with the IIS service running under a local system account.  Everything is running under the default website with all access on the Home Directory enabled.  I also have Anonymous access enabled - it's as wide open as you can get.

When I create images (using Fireworks MX), 99% of the time I cannot view the image when I drop it into the site - I just get a 401.3 error.  I can get it to work most of the time by a weird combination of recreating the files, copying them from one spot to another, sometimes restarting the service.  I've never had to adjust directory permissions to get it to work - so I don't think that the problem lies there.

I've got an image that this is happening with right now and the normal "fix" is not working, so would love to test some things out.

This has been an ongoing annoyance for me and I'd like to know if anyone else has run into the problem and can offer any assistance.

Thanks in advance...
0
Comment
Question by:bowline
5 Comments
 
LVL 10

Accepted Solution

by:
AndresM earned 250 total points
ID: 17950441
The site is anonoymous, so to confirm that this is not a security problem, you can try putting IUSR_machinename inside the administrators group, restart IIS, and see what happens.
0
 
LVL 34

Expert Comment

by:Dave_Dietz
ID: 17950477
401.3 means 'Access denied due to ACL on resource' - the account you are using to try and access the content doesn't have proper permissions to access the content.

What authentication method are you using for the site?

If the image files are in a specific directory what authentication method is configured for that in IIS?

What are the NTFS permissions on the file itself and the directory it is located in?

Is the site running in Medium Isolation?

Chances are that you are using anonymous authentication and the IUSR_<machinename> account doesn't have proper permissions.

A couple things to try would be:
 - give EVERYONE Read, List amd Read/Execute permissions on the file in question.
 - change the authentication on the site to Integrated and remove Anonymous.

Dave Dietz
0
 
LVL 23

Expert Comment

by:rama_krishna580
ID: 17950568
Hi,

Check the security permissions of the file. Try going to the file within your browser. If it returns an HTTP 401.3 error, then you need to have a problem with permissions.

To fix it, simply change the permissions of the file to be in-line with the rest of the files used in the website, as the IUSR_{computer} account won't have sufficient access.

And Authentication May Fail with "401.3" Error If Web Site's "Host Header" Differs from Server's NetBIOS Name
http://support.microsoft.com/default.aspx?kbid=294382

Many more, but this will get you started.

R.K
0
 
LVL 2

Author Comment

by:bowline
ID: 17950706
Alright, I feel like an idiot right now, I added the Administrators role to IUSR_XXXX, restarted IIS and it worked.  So it is a permissions issue - but for some reason I can't see any security options on my folders so I can't give everyone access to that folder...need to research that one a little more...
0
 
LVL 2

Author Comment

by:bowline
ID: 17950745
Disabled Simple File Sharing for Windows so I could see those options (was a new one for me), enabled Full Access for the IUSER, and it worked...

Many thanks!
0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
ASP.NET MVC site showing code blocks 3 65
IIS Question 8 54
Error viewing ASP page 12 146
Cannot upload files above 1mb IIS7 11 39
Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.
Delivering innovative fully-managed cloud services for mission-critical applications requires expertise in multiple areas plus vision and commitment. Meet a few of the people behind the quality services of Concerto.

947 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now