Solved

Error : IWAS0126E problem encountered while connection Con4.

Posted on 2006-11-15
3
569 Views
Last Modified: 2007-10-18
Hi

i'm trying to get a connection from WebSphere Studio Application Developer to a oracle 9i using the OracleDriver. The jdbctest Program from the IBM Homepage is running successfully after I copied the classes12.jar . But when I try to get the same connection with Studio I'm getting the error message:

Error:

IWAS0126E problem encountered while connection Con4.
Reason: 'Io exception: The Network Adapter could not establish the connection'


What I did:

To view the definition of an existing database, I first have to create a JDBC
connection to the database. To create a new connection, I switeched in the DB Servers view. Then right-click anywhere in the view and select New Connection to display the Database Connection wizard.

When I click on finish it is giving error message


The standard program is working fine... but when I am trying to create new database connection it is giving above error message

Can you please help me what I have to do.

Thanks


0
Comment
Question by:basirana
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 10

Expert Comment

by:jaggernat
ID: 17950830
0
 
LVL 15

Expert Comment

by:bpmurray
ID: 17951750
I don't know about Oracle, but is it possible that it's a dev version that only accepts a single connection at a time, so that the initial connection (int he DB Servers view) blocks subsequent connections?
0
 
LVL 29

Accepted Solution

by:
bloodredsun earned 500 total points
ID: 17955365
I have Oracle running in WSAD.

What settings have you chosen for the DB in the DataSource tab of the server?

Remember it's easier to specify a container managed authentication alias ,and that you only need to specify a url in the resource properties in the form of
jdbc:oracle:thin:@<server>:<port>:<sid>, you don't need to specify values in the databasName and serverName fields.
0

Featured Post

Enroll in June's Course of the Month

June's Course of the Month is now available! Every 10 seconds, a consumer gets hit with ransomware. Refresh your knowledge of ransomware best practices by enrolling in this month's complimentary course for Premium Members, Team Accounts, and Qualified Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For anyone that has accidentally used newSID with Server 2008 R2 (like I did) and hasn't been able to get the server running again because you were unlucky (as I was) and had no backups - I was able to get things working by doing a Registry Hive rec…
This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question