Solved

Spellcheck and Links do not work properly in OWA after OWA was configured not to require the Domain name in the username field at logon

Posted on 2006-11-15
7
791 Views
Last Modified: 2007-12-19
I have setup my Exchange 2003 SP2 server to get rid of quite a few annoyances that give end-users fits. One Microsoft fix has given me some undesirable side effects. I used this method to bypass the need for the end user to enter their domain\username at the OWA logon http://support.microsoft.com/kb/903942.

It works like a charm except for the two following items, at least these are the only two items I have noticed to date.

If you logon to OWA without entering the domain:

1) Links require you to reenter your username in the form of domain\username and the password to open up links. The password box pops open when you try and click on links.

2) Spell check fails when you reply to an email in OWA. For some reason spell check works fine in newly constructed email in OWA but fails in a reply.

I haven't been able to find out any documentation on how to fix these items or if it is even possible. They aren't critical but they are definitley annoying.
0
Comment
Question by:ditobot
  • 2
  • 2
7 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 17951373
Are you using SSL? If not you should.
If you were using SSL then you can use Forms Based Authentication. There was an undocumented change in SP2 where the forms based authentication page does not require domain\ in the username.

Ensure that anonymous authentication ONLY is set on the /exchweb virtual directory in IIS manager.

Simon.
0
 

Author Comment

by:ditobot
ID: 17951497
I am using SSL and am not using Forms Based Authentication. I remember seeing documentation on removing this subject for the forms based authentication but really prefer using the standard OWA logon. I kind of hoped since this was a Microsoft fix that it wouldn't have any major negative side effects.

anonymous authentication is the only thing selected in my /exchweb virtual directory in IIS manager.
0
 
LVL 104

Accepted Solution

by:
Sembee earned 250 total points
ID: 17951533
I find that there is a much higher acceptance level when using forms based authentication. The users seem to accept OWA more when using that and it avoids the domain\ problems.
From a security point of view it is also the best option as it brings in the cookie control which stops someone accessing the session if it isn't closed down properly.

I wouldn't have made the change that Microsoft have outlined in ESM. I would have set a default domain and default realm through IIS Manager.

Simon.
0
 
LVL 26

Expert Comment

by:Vahik
ID: 17954687
0
 

Author Comment

by:ditobot
ID: 18141555
It seems to be working under Forms Based Authentication but I wish I had a better answer as to why it won't work without it.

At least it is working, thanks for the suggestion Sembee
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
Read this checklist to learn more about the 15 things you should never include in an email signature.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question