Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 246
  • Last Modified:

php do not install anymore

Hi all,

I'm sure this is a rather dumb question but it seems I can not find a reason to it.

LoadModule php5_module C:/php/php5apache2.dll

I have the above line in the apache config file, when ever i try starting apache, i get the error:
cannot load C:/php/php5apache2.dll into Server: The specific module does not exist

any ideas?

thanks
0
sakuya_su
Asked:
sakuya_su
  • 3
  • 2
1 Solution
 
Robin HickmottSoftware DeveloperCommented:
Which version of apache and php are you using?

If its 2.2.x you will need a different moule.

0
 
sakuya_suAuthor Commented:
apache 2.2.x
0
 
sakuya_suAuthor Commented:
i just upgraded from my old 1.3.x so i think there is something im missing
0
 
Robin HickmottSoftware DeveloperCommented:
Yes you will need to use PHP 5.2.0

and use the php5apache2_2.dll

there is no official support for Apache 2.2.x BELOW PHP 5.2.0
0
 
Robin HickmottSoftware DeveloperCommented:
To clarify

Apache.dll = Apache 1.3.x
Apache2.dll = Apache 2.0.x
Apache2_2.dll = Apache 2.2.x

You can blame Apache for changing their modules all the time :(
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now