Solved

40GB HDD won't format above 23GB - Again!

Posted on 2006-11-16
19
353 Views
Last Modified: 2010-04-27
This drive was set up with a Dynamic Drive Overlay.

I originally posted the problem here:
http://www.experts-exchange.com/Storage/Q_22033242.html

garycase suggested nuking the drive with dban (Darik's Boot & Nuke - use with care)
This worked, I had 40GB back, points allotted to garycase with grateful thanks - problem solved.

Some time later I needed to reformat and the drive suddenly reverted to 23GB. This time dban won't do the trick. I'm tempted to try the old marine engineer's "float test" - throw it overboard.

Seagate Barracuda 7200.7 IDE drive.

Is dynamic overlay controlled by firmware on the controller?


0
Comment
Question by:Alan Henderson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
  • 5
  • +2
19 Comments
 
LVL 6

Expert Comment

by:durindil
ID: 17959862
Do you think you have an EISA or OEM partition?  If so, have you tried to use diskpart in Windows XP?

Run:

diskpart
list disk
select disk <disk #>
list partition
select partition <partition #>
clean

But this would only work if it is a partition issue.
0
 
LVL 24

Author Comment

by:Alan Henderson
ID: 17960625
Thanks durindil,
No, this is blank disc now formatted as one NTFS partition. It shows in Disk Management as 23MB whether formatted or not.
0
 
LVL 5

Expert Comment

by:drawlin
ID: 17961929
I'm not familiar with Derricks boot& nuke.  But just maybe your computer's BIOS has incorrectly detected the number or size of your Disks Heads/Cylinders/Blocks/Sectors etc....  You could try to read the info off of the drive and manually enter it into the BIOS.  Also, check Large Block Addressing settings in BIOS.
0
Don't Cry: How Liquid Web is Ensuring Security

WannaCry is just the start. Read how Liquid Web is protecting itself and its customers against new threats.

 
LVL 30

Expert Comment

by:pgm554
ID: 17962668
Does the MOBO BIOS see it as 40 GB?

If it sees it as 23 ,then the disk is hammered and maybe a float test is in order.
0
 
LVL 70

Expert Comment

by:garycase
ID: 17962718
vallis -- what does the BIOS report for the drive?

... and is it set to auto-detect?

... also, how did you reformat it?  [right-click, Format?   Disk Management?  etc.]
0
 
LVL 30

Expert Comment

by:pgm554
ID: 17962832
Download the Seagate utility for drive overlay and run the uninstall.


http://www.seagate.com/support/kb/disc/howto/use_dwse_maint.html
0
 
LVL 24

Author Comment

by:Alan Henderson
ID: 17963179
drawlin
I will check tomorrow, thanks.

pgm554
I suspect you're right, I'm only using the disc as for installing Ubuntu and 23GB is enough for the job. But I now have a personal grievance with it. :o)
I've used the Seagate utilities, the bootable and the windows version. The "remove DDL" choice is greyed out.

garycase
My main 2 drives are SATA, this one is the only IDE and is set to Master. I've also tried setting it up on a USB connection and reformatting.
I've reformatted it normally, via Disk management and with Acronis Disk Director. I've zero filled it with Seagate Disk Wizard and dban.

Thanks for the input people.
0
 
LVL 70

Expert Comment

by:garycase
ID: 17966194
... what does the BIOS report for the size?  ... and is the BIOS set to Auto-Detect the drive?
0
 
LVL 24

Author Comment

by:Alan Henderson
ID: 17966594
garycase

Sorry, meant to put that in my last comment.
BIOS shows the disc as 25601MB.

Seagate support's response:
"Unfortunately, at this point, there is no way to fix or resolve your issue. There has been too much done between installing the DDO and trying  to remove it."

0
 
LVL 70

Accepted Solution

by:
garycase earned 250 total points
ID: 17967100
The BIOS report indicates the drive itself is mis-reporting its size ... this is not good.   It WAS resolved at one point (since you did see all 40GB after DBAN "nuked" it) ... but obviously something has happened since then.   When you reformatted it, were you using XP?   Also, you said DBAN didn't do the trick this time --> did you run it in full "nuke" mode ??

... do you by any chance have a copy of Spinrite ??   If so, run it against the drive and see what it reports for the low level drive parameters.

... While the "float test" might be appropriate here [I understand your frustration :-) ], it sounds like the low level drive formatting parameters (which you can't, unfortunately, change) may have been reset to report a 23GB drive (not sure how this might have happened, but I'm sure it's related to Seagate's DDO) ==> if this is the case, the drive will work fine as a 23GB drive ... and for what you want to use it for, I'd just do that rather than "float" the drive :-)     The good news is this is not an expensive issue ... at today's prices a 40GB drive is < $40  (with rebates I've seen them for $10).

... by the way, I have avoided drive overlays like the plague for over a decade => it is amazing how many issues they have caused (and continue to cause).   While the drive manufacturer's mean well, I simply do NOT recommend using any of their tools (except the diagnostics) that ship with their disks.
0
 
LVL 24

Author Comment

by:Alan Henderson
ID: 18072044
My apologies for the delay. Too many other problems.
I suspect I'm beaten by this, but have not given up.
Thanks all.
0
 
LVL 70

Expert Comment

by:garycase
ID: 18072972
Dump the MBR and post it here ...
0
 
LVL 30

Expert Comment

by:pgm554
ID: 18073013
Sounds like he needs a hex editor.
0
 
LVL 30

Assisted Solution

by:pgm554
pgm554 earned 250 total points
ID: 18073026
0
 
LVL 30

Expert Comment

by:pgm554
ID: 18073039
zap63 looks interesting
0
 
LVL 24

Author Comment

by:Alan Henderson
ID: 18150170
zap63 didn't fix it. I've given up - it must be a low level problem and it's not worth wasting any more time on it. If nobody has any objections I'll split the points between pgm554 & garycase.

Thanks for the input. I've learned a bit more and found a useful tool in zap63.

garycase: I have no idea how to dump the mbr.
0
 
LVL 70

Expert Comment

by:garycase
ID: 18150665
Sorry for being less explicit ... I wrote that comment as I was leaving for the evening that day.   ... as pgm554 noted afterwards, you needed to get a hex editor; then just load cylinder 0, sector 0 (which contains the master boot record) and post the contents.   There are also a few MBR tools which are designed to do exactly that (load the MBR, let you save a copy, etc.).   Since you never asked for details on how to do it, I presumed you had resolved the problem yourself.
0
 
LVL 24

Author Comment

by:Alan Henderson
ID: 18152962
Curiouser & curiouser.
I installed Suse 10.1 on this disc this morning. Suse default set it up as 40GB!

Unfortunately I can't get Ubuntu, Suse or Fedora to run on that PC - another problem to add to the todo list.
So I deleted the 3 Linux partitions in Acronis disk director. It immediately reverted to 23GB of unformated space.

All is not lost.
I'm about to try the same thing on my main PC.
0
 
LVL 70

Expert Comment

by:garycase
ID: 18153698
"... It immediately reverted to 23GB of unformated space ..." ==> Is the BIOS still just showing 23GB?

This definitely sounds like a residual issue caused by a drive overlay ... but I'm at a loss as to why it reverted after the iniital fix with dBan; and also why the linux distro is "seeing" the correct size.   It will be interesting to see if the linux distro sees the same thing on your main PC.   Also, post what the BIOS shows for the size of the drive on your main PC.

0

Featured Post

WordPress Tutorial 2: Terminology

An important part of learning any new piece of software is understanding the terminology it uses. Thankfully WordPress uses fairly simple names for everything that make it easy to start using the software.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lets start to have a small explanation what is VAAI(vStorage API for Array Integration ) and what are the benefits using it. VAAI is an API framework in VMware that enable some Storage tasks. It first presented in ESXi 4.1, but only after 5.x sup…
The business world is becoming increasingly integrated with tech. It’s not just for a select few anymore — but what about if you have a small business? It may be easier than you think to integrate technology into your small business, and it’s likely…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question