?
Solved

EtherChannel and VLAN Trunking in Catalyst 3750

Posted on 2006-11-16
12
Medium Priority
?
1,448 Views
Last Modified: 2008-01-09
Hi.  I have the following configuration in my Cisco Catalyst 3750 switch.  I would like to know what are they for:

vlan internal allocation policy ascending
!
!
interface Port-channel1
 switchport access vlan 2
!
interface Port-channel2
 switchport access vlan 2
!
interface Port-channel3
 switchport access vlan 2
!
interface Port-channel4
 switchport access vlan 2
!
****(output suppress)****
!
interface GigabitEthernet1/0/10
 switchport access vlan 2
 channel-group 1 mode on
!
interface GigabitEthernet1/0/11
 switchport access vlan 2
 channel-group 1 mode on
!
interface GigabitEthernet1/0/12
 switchport access vlan 2
 channel-group 2 mode on
!
interface GigabitEthernet1/0/13
 switchport access vlan 2
 channel-group 2 mode on
!
****(output suppress)****
!
interface GigabitEthernet1/0/49
 switchport access vlan 3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
****(output suppress)****
!
interface GigabitEthernet2/0/10
 switchport access vlan 2
 channel-group 3 mode on
!
interface GigabitEthernet2/0/11
 switchport access vlan 2
 channel-group 3 mode on
!
interface GigabitEthernet2/0/12
 switchport access vlan 2
 channel-group 4 mode on
!
interface GigabitEthernet2/0/13
 switchport access vlan 2
 channel-group 4 mode on
!
****(output suppress)****
!
interface GigabitEthernet2/0/48
 switchport access vlan 6
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 6,7
 switchport mode trunk
!
!
!
Pls explain what the Port-channel and channel-group are for?  and also the vlan 3 and vlan 6 in the trunk ports (GigabitEthernet1/0/49 and GigabitEthernet2/0/48).  Thanks.
0
Comment
Question by:hoggiee
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +1
12 Comments
 
LVL 57

Accepted Solution

by:
giltjr earned 1000 total points
ID: 17962391
--> interface Port-channel1

Creats Etherchannel  #1.  Seems that you have 4 Etherchannels.

--> interface GigabitEthernet1/0/12
-->  switchport access vlan 2
--> channel-group 2 mode on

Adds the interface GigabitEthernet1/0/12 to the Etherchannel #2.

It seems that this box is maybe a core switch connected to 4 other swichtes with two links to each of the other 4 switches.

The switchport access vlanx (x=3 and 6) on the trunk ports should be ignored.  It looks like at one time these ports where not trunk ports and somebody changed them to trunk ports and forgot to remove the access definitions.
0
 
LVL 20

Assisted Solution

by:calvinetter
calvinetter earned 1000 total points
ID: 17962402
>interface Port-channel1
  This defines an EtherChannel virtual interface; this is "EtherChannel #1"

>interface GigabitEthernet1/0/11
>...channel-group 1 mode on
   This tells the switch that this physical interface is a member of the EtherChannel #1 explained above.
   'mode on' forces the port to form an EtherChannel, regardless of whether the partner device seems to support EtherChannel or have it configured.

>interface GigabitEthernet2/0/48
> switchport access vlan 6     <-- port assigned to VLAN 6 if it was in access mode & not in trunk mode
> switchport trunk encapsulation dot1q
> switchport trunk allowed vlan 6,7  <- what VLANs are allowed to traverse the trunk

 See also "Configuring EtherChannels" (Cisco's website):   http://tinyurl.com/3a7nq

cheers
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 17962409
D'oh! giltjr beat me by 2 min!  Should've hit refresh!  ;)
0
Supports up to 4K resolution!

The VS192 2-Port 4K DisplayPort Splitter is perfect for anyone who needs to send one source of DisplayPort high definition video to two or four DisplayPort displays. The VS192 can split and also expand DisplayPort audio/video signal on two or four DisplayPort monitors.

 
LVL 57

Expert Comment

by:giltjr
ID: 17962446
Well since we both said the same thing at least the asker know he has the correct answers.

What really weird is not only did we give the same answers (of course we did because they are right), but in the same way and almost the same words.
0
 

Author Comment

by:hoggiee
ID: 17962597
interface GigabitEthernet2/0/48
 switchport access vlan 6
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 6,7
 switchport mode trunk

The switchport access vlan 6 shoud not appear in an interface configured as trunk port?
0
 
LVL 8

Expert Comment

by:yasirirfan
ID: 17963300
Yes ur right remove the command

no switchport access vlan 6


cheers

Yasir
0
 
LVL 57

Expert Comment

by:giltjr
ID: 17964753
--> switchport trunk allowed vlan 6,7

Just to make sure you know, this mean that even though this is a trunk only traffic to or from a host in  VLAN 6 and 7  can go over this port.
0
 
LVL 8

Expert Comment

by:yasirirfan
ID: 17965461
it allows traffic only from vlan 5  and 6
0
 
LVL 57

Expert Comment

by:giltjr
ID: 17967995
What?  
0
 

Author Comment

by:hoggiee
ID: 17973441
giltjr and calvinetter:
Well...since you both have given the correct answer, at almost the same time, i think you two should have the same points.....fair enough ?! :)
0
 
LVL 57

Expert Comment

by:giltjr
ID: 17973468
Fine with me.  Thanks.
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 17973701
Thanks hoggiee!
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

766 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question