Solved

Howdo I stop CF 6.1 from intercepting requests for JSP pages?

Posted on 2006-11-17
5
242 Views
Last Modified: 2013-12-24
Ok, I'm running IIS 6, CF 6.1, and trying to route requests for JSPs to Tomcat (using jspISAPI).

The problem is, I've already set IIS to use jspISAPI rather than the CF server for JSP requests, yet CF is still intercepting.  I've also restarted both IIS and CF several times.

Anyone done this before?  Any ideas?


0
Comment
Question by:substand
  • 2
  • 2
5 Comments
 
LVL 25

Expert Comment

by:dgrafx
ID: 17971101
did you go into iis and pull up properties for a site and on "Home Directory" tab click "Configuration" button.
Then find your .jsp extension and modify the executable path.
0
 
LVL 10

Author Comment

by:substand
ID: 17971587
Yes, that's what I meant by "I've already set IIS to use jspISAPI rather than the CF server for JSP requests."  Sorry for not being clearer. =)

Thanks for your help.
0
 
LVL 12

Accepted Solution

by:
mmc98dl1 earned 500 total points
ID: 18025330
Are you running CF server or the JRun edition?

either way, I believe if go find your web.xml or web-default.xml in path\to\CF\servers\coldfusion\SERVER-INF there is a line in there that forces jrun to intercept  jsp

!!!!BACKUP your web.xml before trying this so you can restore it if it goes wrong. !!!!

You can try removing these lines:

<servlet-mapping>
   <servlet-name>JspLicenseServlet</servlet-name>
   <url-pattern>*.jsp</url-pattern>
 </servlet-mapping>

There are some other lines in there that reference .jsp pages that you can also try removing.
0
 
LVL 10

Author Comment

by:substand
ID: 18027489
mmc98dl1 - thanks.  That seems to have worked.  But, I wonder if you might have some more helpful experience to that could benefit me before I close this question out?  Now, IIS seems to just be serving the jsp as a text file, rather than making the call to jspISAPI as I have set it to do for the *.jsp files.  

I even added the JspISAPI to the ISAPI filters under the website, and it shows it as not loaded.  If I put it under the home directory -> configuration -> wildcard application maps, it asks me for a username and password (like, Windows-style)

Any more insights?

0
 
LVL 12

Expert Comment

by:mmc98dl1
ID: 18032056
mmm no cant help you there - I dont know much about IIS and Tomcat. So I can only assume that Tomcat isnt picking up the mapping from IIS.

What I have seen is that Tomcat and CF on the same server has been problematic for most people.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
OpenLDAP set password to expire 7 635
Web server load balancing technologies and methods 3 91
Website URL redirection 10 69
Setting Up Local Lan Web Server 1 60
This is a guide to setting up a new WHM/cPanel Server to be used for web hosting accounts. It is intended for web hosting company administrators and dedicated server owners. For under $99 per month (considering normal rate of Big Data Cetnters like …
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
This Micro Tutorial will teach you how to censor certain areas of your screen. The example in this video will show a little boy's face being blurred. This will be demonstrated using Adobe Premiere Pro CS6.
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…

803 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question