Solved

Cisco ASA 5200 and ISA 2k4

Posted on 2006-11-17
14
7,235 Views
Last Modified: 2013-11-16
Hello. Recently I have decided to purchase and add a Cisco ASA 5200 to our existing network which currently only exists of ISA 2k4 serving as both a firewall and web proxy. I am wanting to keep the ISA but have it only serve as a proxy (I have BT Webfilter installed on the ISA box) so I am definately wanting to keep the filtering product in place.  I have already started configuring the ASA firewall and will post the configuration below. Also, right now we have a flat network with no dmz for web servers, etc. I am wanting to incorporate and configure an interface on the new firewall for a DMZ to incluse 3-4 web servers as well as a couple of other Terminal servers accessible by the outside world through RDP. Right now our T1 terminates to a cisco 1720 series router. All internal hosts gateway point to the router address of 172.16.0.5. The router is configured to route all traffic to the ISA box 172.16.0.19.  Also if the config copied below looks horribly bad please don't hesitate to let me know what needs to be changed :)

Questions:

1.)  What is the most efficiant and easiest way to incorporate the new firewall while keeping the ISA box in place? What will I need to change on ISA to make it no longer serve as a firewall but only as a proxy & filtering.  Is there a wizard to change from a edge firewall to a back end? Will I just leave the clients gateway pointing to .5 (router) and then just change the internal interface of the cisco asa firewall to the old internal ip of the ISA box.. Right now we have a route command on the router (ip route 0.0.0.0 0.0.0.0 172.16.0.19) that routes all traffic to the isa box. So that is why I was thinking maybe just change the internal interfae of the cisco firewall to .19.

2.) Configuring DMZ --> Does anyone have a sample config that incorporates a DMZ so that I can see how the access-lists, and interface are set up?

3.) OWA/ActiveSync --> I have created my static entry and access-list for https. Does anything else need to be configured or added in order for OWA/ActiveSync to work properly? I am a bit confused because currently we have all the certs needed for OWA/ActiveSync residing on our ISA box itself. Where will the certs need to be now that the ISA box will not be serving as a firewall?

Here is my configuration on the ASA box thus far.

:
ASA Version 7.0(5)
!
hostname ASA
domain-name XXX
enable password
names
no dns-guard
!
interface GigabitEthernet0/0
 description outside interface - WAN
 shutdown
 nameif outside
 security-level 0
 ip address 66.xxx.xxx.xxx.xxx 255.0.0.0
!
interface GigabitEthernet0/1
 nameif INSIDE
 security-level 100
 ip address 172.16.0.19 255.255.224.0
!
interface GigabitEthernet0/2
 description DMZ
 shutdown
 security-level 10
 ip address 10.0.0.1 255.0.0.0
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 shutdown
 no nameif
 no security-level
 no ip address
!
passwd
ftp mode passive
clock timezone cst -6
clock summer-time CDT recurring
dns domain-lookup INSIDE
access-list inbound extended permit tcp any host 66.xxx.xxx.xxx eq smtp
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq www
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq https
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq ssh
access-list inbound extended permit udp any host 66. xxx.xxx.xxx eq dnsix
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq domain
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq pop3
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq imap4
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq 135
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq 3389
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq 3389
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq 3389
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq 3389
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq www
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq 1755
access-list inbound extended permit udp any host 66. xxx.xxx.xxx eq 1755
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq https
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq https
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq https
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq https
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq www
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq ssh
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq www
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq www
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq www
access-list inbound extended permit tcp any host 66. xxx.xxx.xxx eq www
access-list nonat extended permit ip 172.16.0.0 255.255.224.0 192.168.30.0255.255.255.0
access-list 101 extended permit ip 172.16.0.0 255.255.224.0 any
pager lines 24
mtu outside 1500
mtu INSIDE 1500
ip local pool vpnremote 192.168.30.1-192.168.30.100
no failover
icmp permit any outside
icmp permit any INSIDE
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (INSIDE) 0 access-list nonat
nat (INSIDE) 1 0.0.0.0 0.0.0.0
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.115 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.6 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.56 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.57 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.31 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.15 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.44 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.40 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.11 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.46 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.61 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.62 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.63 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.47 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.75 netmask 255.255.255.255
static (INSIDE,outside) 66. xxx.xxx.xxx 172.16.0.58 netmask 255.255.255.255
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 66. xxx.xxx.xxx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server vpn protocol radius
aaa-server vpn host 172.16.0.2
 key ciscotest
group-policy VPNClients internal
group-policy VPNClients attributes
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value 101

split-dns value 172.16.0.2
 webvpn
group-policy vpn5520 internal
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set FirstSet esp-3des esp-md5-hmac
crypto dynamic-map dyn1 1 set transform-set FirstSet
crypto dynamic-map dyn1 1 set reverse-route
crypto map mymap 1 ipsec-isakmp dynamic dyn1
crypto map mymap interface outside
isakmp identity address
isakmp enable outside
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption 3des
isakmp policy 1 hash md5
isakmp policy 1 group 2
isakmp policy 1 lifetime 86400
isakmp nat-traversal  20
isakmp disconnect-notify
tunnel-group Remote type ipsec-ra
tunnel-group Remote general-attributes
 address-pool vpnremote

default-group-policy VPNClients
tunnel-group Remote ipsec-attributes
 pre-shared-key *
telnet timeout 5
ssh timeout 5
console timeout 0
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
0
Comment
Question by:Llarissa21
  • 6
  • 4
  • 3
  • +1
14 Comments
 
LVL 51

Expert Comment

by:Keith Alabaster
ID: 17968377
On the ISA side it is a reconfigure job. You will need to select the single-nic template (wizard0 from configuration - networks. Open the toolbar on the right-hand side - select single nic and this will remove the existing configuration file so make sure you backup it up (export the confog, objects and rules) before you start.

You cannot use the ISA as a back-end but only in proxy mode. If you want the box to act as a backend then it must be a firewall and proxy device. Backend and frontend are firewall templates; not proxy-only templates.

I would also recommend you remove one of the nic's also or if its a capable machine, team the two nics together. Having the second nic in place unused, even disabled, can cause some funnines to the system but teaming is fine.

Personally I would leave ISA exactly as it is and set the ASA to forward the traffic to the external NIC on the ISA. this will negate the need to change all of the certificates around, mess with the OWA/activesysnc and the like but it has to be your call. For specific help on the ASA box I'll need to hand over to one of my colleagues as ISA is my baby.

Regards
keith
0
 

Author Comment

by:Llarissa21
ID: 17968495
Hi. Thank you for the reply. One question, suppose I did leaev the ISA exactly the way it is I am guessing that it would mean that no acl's or static routes would need to be in place on the ASA firewall? I am confused because if I did that, then what would the purpose of the firewall be besides to act as a router, routing all the traffic to the ISA box. I am guessing that would be the easiest way but then my boss would insist on my reasoning for purchasing the ASA box in the first place. Could you elaborate a bit more?  Say I went ahead and used the ISA server as a backend firewall and proxy device how would it act as firewall if I already have the ASA in place with all of the static routes, ACL's, VPN connection, etc.

0
 
LVL 51

Expert Comment

by:Keith Alabaster
ID: 17968537
Interesting question and one I would have to leave you to answer.

However.

1. You could place a switch between the ISA server and the ASA device creating your dmz environment between the two firewalls. I cannot think of a much stonger combination for maximum protection.
2. The ASA will only allow traffic through that is authorised reducing any performance impact on the ISA server and improving response to the proxy service users. ASA can act as the VPN header reducing load/performance impact even further.
3. A second line of defence; should the ASA get compromised (however unlikely as it is Cisco equipment), the 'hacker' still has another firewall to face so crafted attacks are unlikely to succeed.
4. ISA can now concentrate on the application layer filtering rather than the network layer as the ASA has that covered.
5. ISA2004 is EAL 4+ accredited making it one of only two in the world (Secure Computing's Sidewinder being the other and that is used in the Pentagon) so no-one can fire you for keeping the best product, can they?
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 17970612
Heartily agree with Keith's last post...  Even if you don't currently need a DMZ, you can benefit from having an additional firewall between your internal subnets & the outside world.  And as Keith says, you can let each box do what it does best, since an ASA isn't built to be a proxy, but is a *very* secure firewall & is a rock-solid VPN server.

   I'd only add that if you decide to put the ASA in front of the ISA server, I strongly encourage you to get a 2nd pool of public IPs (even if it's just a tiny /30 subnet) to put on the internal interface of the ASA, & on the external interface of the ISA.  This way, you won't need NAT on the ASA (& having 2 NAT devices is a migraine waiting to happen), just do all your NAT on the ISA.

BTW, Keith is a longtime ISA guru, who I'm sure falls asleep each night counting ISA servers instead of sheep! LOL

cheers
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 250 total points
ID: 17971826
Just to add my $0.02 to the conversation:
You've already purchased the ASA firewall. It is the best firewall on the market, and very capable. It is also EAL4 certified (no +)
I dare say that it is
<duck for cover>
more capable as a firewall than the ISA in many respects
</duck for cover>

Personal opinion here only, so bear with me...
Use the ASA as your first line of defense - your firewall, IDS, NAT control, entry point. The ISA will never be able to match the ASA's Adapative Security Algorythm, protocol inspection (deep packet inspection), Intrusion Detection features, or reliability.
Keep the ISA as a cache-proxy only, as in your original post. Take Keith's advice to disable one NIC or team them. Do not use the ISA as a router.
Keeping it as is with the ASA in front of it can only be a troubleshooting nightmare when things do not go as you expect. It also makes it difficult to VPN into the ASA, and then have to have some access rules on ISA for VPN clients to get through the ISA to internal systems.
Restrict all outbound traffic except from the ISA Proxy IP address, but keep the ASA's inside IP as the default gateway.
Remove ISA firewall clients from PC's because they are not required.

> Right now our T1 terminates to a cisco 1720 series router. All internal hosts gateway point to the router address of 172.16.0.5. The router is configured to route all traffic to the ISA box 172.16.0.19.
This is very inefficient. Apparently the router is doing your NAT for you? How are you publishing OWA and other applications with the 1700 router doing NAT?

2.) Configuring DMZ --> Does anyone have a sample config that incorporates a DMZ so that I can see how the access-lists, and interface are set up?

interface GigabitEthernet0/2
 description DMZ1
 nameif DMZ1
 no shutdown
 security-level 90
 ip address 10.120.10.1 255.255.255.0
!
static (DMZ1,outside) 66.x.x.22 10.120.10.22 netmask 255.255.255.255
static (inside,DMZ1) 172.16.0.0 172.16.0.0 netmask 255.255.224.0
!
\\-- remember that all traffic from lower security (dmz 90) to higher (inside 100) requires
\\-- explicit access-list entries. higher (dmz 90) to lower (outside 0) does not
\\-- permit ip from dmz host1 to internal host (perhaps web server to back-end DBserver)
\\-- restrict to specific ports if possible
access-list dmz1 permit ip host 10.120.10.22 host 172.16.1.100
\\-- perhaps a front-end smtp relay host in dmz forwards to Exchange server
access-list dmz1 permit tcp host 10.120.10.23 host 172.16.1.102 eq smtp
\\-- allow your web server to respond to internal hosts
access-list dmz1 permit tcp host 10.120.10.24 eq www 172.16.1.0 255.255.224.0
\\-- don't forget to deny all other traffic between dmz and inside
access-list dmz1 deny ip 10.120.10.0 255.255.255.0 172.16.0.0 255.255.224.0
\\-- don't forget to add permit all , else the implicit deny all will block everything else
access-list dmz1 permit ip any any
access-group dmz1 in interface DMZ1

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17971851
>split-tunnel-network-list value 101
>access-list 101 extended permit ip 172.16.0.0 255.255.224.0 any

Split-tunnel acls are standard and should look like this. Only define what networks the clients will talk to. You may not want to allow split-tunneling at all. Using the ISA as a proxy server, you can control what your VPN clients do on the Internet while they are connected to your network. Another added benefit of setting the ISA as a proxy only box.

access-list 101 standard permit 172.16.0.0 255.255.224.0

3.)  >Where will the certs need to be now that the ISA box will not be serving as a firewall?
It think that the certs would be on the actual OWA/Active Sync front-end server(s).

0
 
LVL 51

Expert Comment

by:Keith Alabaster
ID: 17971946
Just to finish off, on point 3 of LRMoores last post to you, this is something you will need to be sure of. Whilst you have had ISA doing the work you will have either been tunnelling the ssl to the OWA box (using ISA as a conduit simply to passthrough the traffic) or you will have been bridging.  If bridging ssl - ssl then there will be a certificate on both the ISA and the OWA box. If you have bridged from SSL - http then the certificate will only be on the OWA box.
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:Llarissa21
ID: 17972744
Wow.. That is some great information from everyone. Thank you so much. How should I split the points to both lmoore and keith alabaster? I have never split points so don't know how to go about it.

A few more points....

> Right now our T1 terminates to a cisco 1720 series router. All internal hosts gateway point to the router address of 172.16.0.5. The router is configured to route all traffic to the ISA box 172.16.0.19.
This is very inefficient. Apparently the router is doing your NAT for you? How are you publishing OWA and other applications with the 1700 router doing NAT?

I am so sorry for the confusion. I meant to say that our ethernet hand off (internet) comes in and plugs in to an intel switch which the ISA box and router is also plugged in to.. So all the NATing is done on the ISA box. I have double checked this and there is indeed a network rule for internet access - NAT.

> Keep the ISA as a cache-proxy only

According to keith I need to -->  select the single-nic template (wizard0 from configuration - networks. Open the toolbar on the right-hand side - select single nic and this will remove the existing configuration file. Is this correct and all I need to do in order for the ISA to serve only as a cache-proxy only?

on Keiths last comment. We are bridging SSL and have a cert on both the ISA and OWA boxes.

Thanks again for all of your help and ideas, it is greatly appreciated.
0
 
LVL 51

Assisted Solution

by:Keith Alabaster
Keith Alabaster earned 250 total points
ID: 17973973
Glad to have been of some help. If you are going to make the ISA a proxy only, there are additional steps which I'll add here for completeness.

1. In firewall mode (all traffic passes through the ISA regardless of type to get to the Internet) the default gateways of all devices likely point at the internal nic of the ISA server. If you move to Proxy only, ISA will only have ONE nic card enabled and will no longer be a gateway so all default gateways will need to be repointed (static and dhcp) to the internal nic of the ASA box.

2. The default gateway of the ISA server is only set on the external nic. The internal nic has no default gateway assigned (standard two-nic scenario). Once you disable the external nic, you will need to add the default gateway to the internal nic and point it also at the internal nic of the ASA box.

2. The ISA will not be to bridge anything (as it will now be a single-nic device) so the ASA box will need to interact over port 443 directly with the OWA/web server/exchange server, port 25 for smtp etc  so the forwarding from the ASA must go directly to the boxes concerned, not forwarded to the ISA server nic.

4. Proxy will continue to work as your internal users are pointed to the correct location via the proxy settings within ie.

5. The non-proxy traffic such as socks, (SQL, FTP port 21, icmp etc) will no longer mean anything to ISA as it is now simply a proxy server (http/https/ftp through browser) so this traffic will go directly to the default gateway (ASA) so you will not be able to monitor these through the ISA monitoring services anymore.

6. Finally, if you have the ISA firewall client installed on your clients then these must be removed. The ISA firewall client cannot be used with ISA when it is in Proxy state.

Very finally...... to split points.
Scroll down to the bottom of the question and click the "Split Points" link at the bottom of the page. Select the radio button of the comment who you want to Accept as the answer. Only one button can be selected. Set the point value (a text box above the comment) of how much you want this person to receive of the points. Then set the point values for each of the experts comments to whom you want to allocate points and these will be considered Assisted answers in helping you resolve the issue. Double check your information and then click the Submit button at the bottom of the page. One note: the total points of the splits must equal the amount you asked the question for itself, and no person can receive fewer than 20 points.

Regards

Keith


0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17974214
Don't hesitate to come back with specific questions. Keith's the ISA expert and I'm pretty good with the ASA so if anyone can get you going, we can...

Thanks!
0
 
LVL 51

Expert Comment

by:Keith Alabaster
ID: 17977414
Ykank you :)
0
 

Author Comment

by:Llarissa21
ID: 17979651
Lrmoore & Keith alabaster,


Thanks again for all of your help.

Lrmoore, one question. I was going through your sample configuration for the DMZ interface and I ahve a question.

what does the statement --> static (inside,DMZ1) 172.16.0.0 172.16.0.0 netmask 255.255.224.0 ... mean? The two 172.16.0.0 subnets look strange together in the one statement. I was able to add it to my ASA with out any errors but I am just curious if that was a typo on your part or if it is correct, coudl you explain to me what it does? Thanks. If you need me to open a seperate questions I can do that. Just let me know. Thanks!
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17982055
> static (inside,DMZ1) 172.16.0.0 172.16.0.0 netmask 255.255.224.0 ... mean?
No typo. This means that the resulting natted IP is the same as the original IP - same/same
This satisfys the rule that all traffic is natted between interfaces, just nat's it back to itself and basically negates the NAT.
It's just the way it's done with PIX/ASA.
There is a 'nat control' / no nat control command, but it is global. If you're natting out one interface, you have to nat out all of them.
0
 
LVL 51

Expert Comment

by:Keith Alabaster
ID: 17989402
Thanks :)
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
firewall rules 2 68
Upgrading the firmware on a XTMv 8 74
Rule Iptables 1 60
increase internet speed 3 57
If you are like regular user of computer nowadays, a good bet that your home computer is on right now, all exposed to world of Internet to be exploited by somebody you do not know and you never will. Internet security issues has been getting worse d…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now