Solved

Problem accessing internal network after successful VPN connection on Cisco PIX 501

Posted on 2006-11-17
2
199 Views
Last Modified: 2010-04-12
I am new to this but was hoping that somebody could help me here. Basically I have configured a PIX 501 for use with the Cisco VPN 4.6 client. The client connects fine but the problem is that I cannot access the internal network or even ping anything. This should be a straight forward config with 1 network and no NAT. I have attached the config if anybody would be so kind as to steer me in the correct direction.

PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password FwtGInQ5D56C1ULH encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname levypix
domain-name levyarch.com
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list inside_outbound_nat0_acl permit ip interface inside
interface outside
access-list outside_cryptomap_dyn_20 permit ip interface inside
interface outside
access-list 108 permit ip 10.0.0.0 255.255.255.0 10.1.1.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside xx.xxx.xxx.xxx 255.255.255.248
ip address inside 10.0.0.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpn_ip 10.1.1.200-10.1.1.205
pdm location 192.168.1.0 255.255.255.0 inside
pdm location 192.168.1.16 255.255.255.252 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 xx.xxx.xxx.xxx 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 10.0.0.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup levyVPN address-pool vpn_ip
vpngroup levyVPN dns-server 10.0.0.2
vpngroup levyVPN default-domain 10.com
vpngroup levyVPN idle-time 1800
vpngroup levyVPN password xxxxxx
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
username admin password n0Hm746wziOmH8fi encrypted privilege 15
terminal width 80
Cryptochecksum:08c8c33c0d5bcc25c7856a8234d1391c
: end
0
Comment
Question by:admpc
  • 2
2 Comments
 
LVL 20

Accepted Solution

by:
calvinetter earned 125 total points
ID: 17970585
Ye gods! 6.3(1)?  If your PIX has current SmartNet support on it, upgrade to 6.3(5) ASAP!  6.3(1) has a ton of bugs in it (plus some security bugs), & actually requires a reboot for silly things like VPN, NAT table, etc to be reset or take effect.  If an upgrade is possible, you'll be very glad you did it.  Ok, moving on...

   Run these commands in this order:
access-list inside_outbound_nat0_acl permit ip 10.0.0.0 255.255.255.0 10.1.1.0 255.255.255.0
no access-list inside_outbound_nat0_acl permit ip interface inside interface outside
no access-list outside_cryptomap_dyn_20 permit ip interface inside interface outside
isakmp nat-traversal
wr mem
reload  <- *must* reboot the PIX!

>crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
>crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
   Is this a typo? Surely your config doesn't have 2 identical transform-set lines?  Or I'm seeing double...

cheers
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 17970594
Note that the subnet behind the PIX (10.0.0.x) is a very common subnet...  If your VPN client will be connecting from various networks, you'll hit a routing loop when the local LAN that the VPN client is coming from is also on the 10.0.0.x range (or if any of the local subnets are in this range).  Hmm, 10.1.1.x might be common enough to occasionally cause problems as well.   Just some gotchas to watch out for.

cheers
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

One of the Top 10  common Cisco VPN problems are not-matching shared keys. This is an easy one to fix, but not always easy to notice, see the case below. A simple IPsec tunnel between fast Ethernet interfaces of routers SW1 (f1/1) and R1(f0/0). …
Sometimes, you want your microsoft VPN to route all the traffic to the remote network. Usually your employer network. This makes it possible to access all the nodes inside this remote LAN, even if they have no "public DNS" entries. To do so, you wo…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now