?
Solved

Keyboard language setting

Posted on 2006-11-17
5
Medium Priority
?
1,657 Views
Last Modified: 2009-07-29
Hi Experts,

I use the hungarian version of Outlook. And I've set two keyboard settings: english and hungarian. I need both. When I try to write into the message part I can select the HU keyboard because the default is the alphabetically first keyboard type. When I have set only the HU keyboard, I can write everywhere hungarian texts both in message text and address boxes. But if there are more keyboards to select I can't select other then the alphabetically first keyboard except for the message text.

What have I to do against? Would be possible to set default the HU keyboard?

wbr
Janos
0
Comment
Question by:kacor
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 10

Author Comment

by:kacor
ID: 17970670
When I set for the message text the HU language and the keyboard, after leaving and returning the keyboard woun't reset to HU, remains english and I have to set again to HU
0
 
LVL 9

Expert Comment

by:bernani
ID: 17985574
Hi Kacor,

you say
.... I can select the HU keyboard because the default is the alphabetically first keyboard type

If you didn'tchange the settings during install of your OS, te default keyboard is English but not necessarily the alphabetically first keyboard. I believe that you could have Arabic and Chinese installed, if you didn't choose one of these languages as default at installation time, the default keyboard would also be English. It wouldn't be the first in alphabetical order.

Yo need to set Hungarian keyboard as default input for your PC. Right-click on the languages bar, parameters. In the dialog box, you need to highlight Hungarian in the languages combobox (I've got a French system but he label above says sth like - Select one of the input installed languages to use when your computer starts up.)

The default language of your system must be highlight and in bold  under the item Installed services.

There is a second tab called Advanced. Check the first combobox: extend advances services text to all programs (or sth like that).

Click on the button apply.

I believe it should be now OK for you.

Each time you are working with text, the default parameters for keyboard input will be Hungarian (until you change to English) and when you come back to your system, it will be again Hungarian.

___________________________
Hope this help.
0
 
LVL 10

Author Comment

by:kacor
ID: 17994337
Hi bernani,

thanks for your support. My default language was set to hungarian similarly as you offered. The hungarian was highlighted. It is true that I haven't set the other page (Advanced). After setting he restarted automatically but no change was to see. The english remains start language for every applications.

Janos
0
 
LVL 9

Accepted Solution

by:
bernani earned 2000 total points
ID: 17994647

Hi,

If Office is completely installed, there is an item in the

Start Menu ->All Program -> Microsoft Office Tools -> Languages Parameters Office (or sth like this)  

When you click this last menu item, a dialog box is shown related to -> Activated languages. See what's checked or not there and do the necessary or rquired changes.

PS: I don't remember if this feature is installed by default or if it's an option during install.

If it doesn't do the trick, try to check in the Control Panel -> Regional and Local Options -> Tab Advanced Options what's checked  relatively to Languages for non Unicode Programs. Maybe it will be necessary to check one or other Conversion's Table Code Page.

Some years ago, when there was only DOS systems, it was necessary to change de code page at boot time to display correctly languages other than English and particularly for languages with diacritical signs like Polski - Magyarorszak - Hrvatski (it was if I remember well Code Page 1252) or for languages like Greek and Russian.

I believe that if the correct Code Page isn't available to the system for non unicode compliant programs (the code page for English and Hungarian is not the same), by default it will be reset to English for those non unicode aware programs. XP is unicode but all the programs are not unicode compliant. And it's maybe why it doesn't automatically switch back to Hungarian for some applications.  

Hope this could help you to find a working solution.

0
 
LVL 10

Author Comment

by:kacor
ID: 17995352
I installed completely. According your 1st proposition I've set in the Office 2003 Language Settings 1st page (allowed languages) the default language to hungarian. This minimum allows the switch over to hungarian keybord. Thanks for the superior support!

Janos
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
If you troubleshoot Outlook for clients, you may want to know a bit more about the OST file before doing your next job. IMAP can cause a lot of drama if removed in the accounts without backing up.
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question