ORA-12541 :TNS: no listener, open port on client?

I am conneting to oracle server via vpn, i have sqlnet.ora and tnsnames.ora files exactly how i was instructed by the network deptment. But i can receiving this ORA-12541 error when i try to run my .net app. The hostname and service name in tnsnames.ora are same as everyone else is using. So i am confused why it is not working for me. I have installed only oracle client on my machine.

I am not sure if i have to start some service on my machine, if so where would it be,  it's name etc. Do i have to open port 1521 on my side?

Either the tnsname files they gave me are wrong  or something else is wrong on my machine.

thanks!
kushpaw
kushpawAsked:
Who is Participating?
 
schwertnerConnect With a Mentor Commented:
YES - If you have firewall turned on on your computer or your VPN restricted the access to port 1521 and the redirected port
after the Listener answers ... Speak with the VPN administrator about allowed port usage
0
 
Mark GeerlingsConnect With a Mentor Database AdministratorCommented:
From a command prompt on your machine, can you "ping" the Oracle database server by name?  If not, can you ping it by IP address?  If not, you will *NOT* be able to get the Oracle client to connect until you fix this problem first.  If you can ping it by IP address, but not by name, you will have to change your tnsnames.ora file to use the IP address instead of the hostname.

If you can "ping" it by name, then at the command prompt yet, from your Oracle_home\bin folder, try:
tnsping [hostname]

That should return a multi-line response with "OK" on the last line.
0
 
kushpawAuthor Commented:
i can ping it. when i ran tnsping it returned me the following:

used parameter files:
C:\ ..... \sqlnet.ora
Used EZConnect adapter to resolve the alias
Attempting to contact <description = <.........

(gives me a list of host and address combinations)
ORA-12541: TNS: no listener

-kushpaw
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
Mark GeerlingsConnect With a Mentor Database AdministratorCommented:
That "no listener" error implies that the Oracle listener is not running on the server.  Can you check with someone to see if it is not running, or maybe running on a different port number?
0
 
kushpawAuthor Commented:
so there is nothing i have to change on my client machine? i will check with them
0
 
mohammadzahidConnect With a Mentor Commented:
You can issue to commands below to get the status of current listener running / configured.

LSNRCTL> status

OR

LSNRCTL> services

You can goto the LSNRCTL prompt by typing lsnrctl at the command line. These commands will only show result of listener process running. If listener is not running then you will get messages:

TNS-12560: TNS:protocol adapter error
TNS-00511: No listener



0
 
schwertnerCommented:
On the server side:
1. Turn off all firewalls and antiviruses
2. Investigate the Listener status:
a) read and publish here listener .ora fie
b)C:>lsnrctl status
  C:>lsnrctl services
3. Try to start the Listener:
c:>lsnrctl start
0
 
kushpawAuthor Commented:
i am working remotely for a client. all other developers are using same ora files. they are not having any problem so i am guessing there must be something on my side blocking it. tnsnames.ora is using port 1521, could my router/modem is blocking it?  i don't know how i can check it.
0
 
kushpawAuthor Commented:
no my firewall is turned off. vpn is not restricting port 1521.  
0
 
kushpawAuthor Commented:
I have tried all the suggestions, my port is open but i am still the only developer having trouble connecting to remote oracle database. I am sorry, but my problem is not SOLVED. As a result i am not accepting any solution. Thanks to all those who tried.

-kushpaw
0
 
schwertnerCommented:
You have to ask the professionals who have installed the VPN.
0
 
kushpawAuthor Commented:
All, every comment pointed me to right direction. Utimately it was my DSL modem firewall which was blocking my port 1521.

thanks,
kushpaw
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.