• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 291
  • Last Modified:

Showing domain instead of IP in url

Hey all,

I'm new to apache and recently bought a domain and forwarded it to my webserver's IP address.  However, now when I access the site through the domain name, the IP address of the server shows up in the url.  Is there any way to maintain the domain name in the url bar without using any masking options for the forwarding ( b/c it screws up with google analytics)

Thanks in advance.
0
Palamides
Asked:
Palamides
  • 7
  • 4
  • 2
1 Solution
 
periwinkleCommented:
What are you using for dns?  Is the domain configured into your apache webserver configuration?
0
 
PalamidesAuthor Commented:
i think so, is this it?

#
# ServerName gives the name and port that the server uses to identify itself.
# This can often be determined automatically, but we recommend you specify
# it explicitly to prevent problems during startup.
#
# If your host doesn't have a registered DNS name, enter its IP address here.
#
ServerName www.theflashresource.com:80

i don't think I have dns setup, how do you set it up?
0
 
periwinkleCommented:
Looking at the dnsreport.com report at http://www.dnsreport.com/tools/dnsreport.ch?domain=theflashresource.com , it looks like your registrar (which appears to be GoDaddy) is providing the dns for you.    Can you change the A records there for www.theflashresource.com and theflashresource.com to be 128.189.130.241 instead of 64.202.189.170 (which is what it appears to be pointing to)?
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
PalamidesAuthor Commented:
alright done, does the host name have to be anything specific?
0
 
periwinkleCommented:
err - I think you have misunderstood.  I'm not asking you to change the name servers, but to modify a record on the name servers that are already specified.
0
 
giltjrCommented:
I don't see the IP address in the URL.  I think your DNS update resloved this.

Typically a different name (or IP address) will show up  if you are going to a websever that re-directs you to another websever. This must have been what happened to you, the websever running on 64.202.189.170 must have been setup to redirect some websever was setup to redirect you to another websever using its IP address.
0
 
PalamidesAuthor Commented:
no i changed the A recored, and it now works properly, just wondering theres an option in the A record to change the host name, right now its "@" i just left it and things work.  But im wondering if it should be anything else?
0
 
giltjrCommented:
There is no option that can cause an A record to change the name.  Using dig I can see that www.theflashresource.com is actually a CNAME pointing to  theflashresource.com.  The @ record is for you domain (theflashresouce.com) name, not for the www host name.

The address 64.202.189.170 does have a websever running on it.  Do you know what address that is?
0
 
periwinkleCommented:
that's fine - a cname is basically saying that it's 'another name' for theflashresource.com.

It looks like you are now good to go!
0
 
periwinkleCommented:
64.202.189.170 is actually a godaddy hosted server.  It looks like it was being forwarded from that hosting to the IP address previously, instead of just setting the A record to the IP address directly like it is now.
0
 
PalamidesAuthor Commented:
thanks for the help guys! I think I got all my answers
0
 
periwinkleCommented:
Glad to have helped - enjoy your domain!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 7
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now