Solved

How to set the security for aceessing a file -> Only administrators on Windows XP machine ?

Posted on 2006-11-19
6
189 Views
Last Modified: 2013-12-04

I have a file (Sample.txt) in a folder (Test). Now i want to set the security for Sample.txt file. Only ADMINISTRATORS can access this file. Other than ADMINISTRATORS, no body have access to this file. This i want to do on Windows XP machine with SP2. Can you please provide the necessary steps for this ?

Thanks,
Kishore
0
Comment
Question by:kishore_peddi
6 Comments
 
LVL 3

Expert Comment

by:jeffrash
ID: 17974152
If you go to that folder, then "right click" on the file and choose "properties" you'll see a tab that is labeled "Security". Click on that tab and ensure "Administrators" is in the list and that they have the "Full Control" option in the lower section selected. Then all you have to do is remove everyone else that has permissions, and then of course click on OK.

I would suggest leaving the "SYSTEM" user there.

0
 
LVL 38

Expert Comment

by:Rich Rumble
ID: 17975642
Yep, the above should cover it, you may also want to turn off the inherit permissions from parent, when you do just select "copy current rights..." and then as pointed out above, remove all other accounts/groups with the exception of system and or your backup software's username/group, and that should do it.
-rich
0
 

Author Comment

by:kishore_peddi
ID: 17977386

I have Windows XP SP2 on my machine. I right click on the file (Sample.txt), went to "Properties". BUT i can't find the tab "SECURITY" on the dialog window. Can you say why it is so ? And i can't set the security as i have no tab for "SECURITY". Please very urgent...
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 38

Expert Comment

by:Rich Rumble
ID: 17979971
You need to disable simple file sharing: http://support.microsoft.com/kb/307874
it will appear after that.
-rich
0
 
LVL 3

Accepted Solution

by:
jeffrash earned 500 total points
ID: 17981334
Is the drive an NFTS ot FAT volume? You need to convert it to an NTFS volume to get the security option.
0
 
LVL 38

Expert Comment

by:Shift-3
ID: 17982062
Also note that if you're running XP Home you'll either have to boot in Safe Mode or use the CACLS command to adjust NTFS permissions.  The following command should do it:

cacls "c:\test\sample.txt" /G administrators:F
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Security measures require Windows be logged in using Standard User login (not Administrator).  Yet, sometimes an application has to be run “As Administrator” from a Standard User login.  This paper describes how to create a shortcut icon to launch a…
Our Group Policy work started with Small Business Server in 2000. Microsoft gave us an excellent OU and GPO model in subsequent SBS editions that utilized WMI filters, OU linking, and VBS scripts. These are some of experiences plus our spending a lo…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…

679 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question