exchange 2000 not recieveing mail

Hello I have a exchange 2000 server not recieving mail from outside. I can send out no problem but the one form outside in never arrives. I knwo wehere the quues are in excvhange 2003, but can not find the queue in 2000 please help this is a emergency thank you
Who is Participating?
redseatechnologiesConnect With a Mentor Commented:
Hi zenworksb,

Are your DNS settings and MX records correct?

Is your firewall forwarding port 25?

What is your external domain and we will test it - of if you like, you can test it yourself here ->

If you are not receiving mail it won't be in the queues but...

The queues in E2K are a subcontainer to the SMTP virtual server.

Although if mail on the inside works and sending out works but you can't receive mail from internet it is either your MX record not pointing valid external ip address your firewall is not forwarding port 25 to Exchange internally or you have possibly entered a smarthost setting on the SMTP Virtual Server. You should ONLY need to create an SMTP Connector if you need to forward to smarthost. Otherwise Exchange is ready to send receive smtp mail right off the bat. If you have been changing the settings all over during troubleshooting delete and recreate the SMTP Virt. Svr and then restart SMTP WMI and Exchqange Routing Engine services.

 You can test to see what is going on by going to command prompt and type
telnet yourmxrecordipaddress 25 <enter>
ehlo <enter>
look for X-Link2State if not then you are connecting firewall or SMTP gateway and You should start investigating there.
if you do see it then continue with the following
mail <enter>
rcpt <enter>
data <enter>
subject:Testes testes 1...2..3? <enter>
. <enter>
. <enter>
if you get a response at anytime during telnet other than 250 ok that is where it is breaking.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.