Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 365
  • Last Modified:

Accessing NTFS drives in Ubuntu

How can I find out where my NTFS partition is (like dev/hd1 etc), and how can I then mount it to be accessed in Ubuntu,

I'm an Ubuntu n00b, so consider that when answering.
0
andersonmarske
Asked:
andersonmarske
  • 3
  • 2
2 Solutions
 
data_grrrCommented:
if you want to take a quick look

in the terminal:

sudo fdisk -l

this lists the partitions.

then  write

sudo gedit /etc/fstab

it should look like this:

Kod:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda3       /               reiserfs notail          0       1
/dev/hda5       /arsiv          reiserfs defaults        0       2
/dev/hda6       /home           reiserfs defaults        0       2
/dev/hda1       /media/hda1     ntfs    defaults        0       0
/dev/hda2       /media/hda2     vfat    defaults        0       0
/dev/hda7       none            swap    sw              0       0
/dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/hdc        /media/cdrom1   udf,iso9660 user,noauto     0       0


if hda1 is ntfs then change it like this:

/dev/hda1       /media/hda1     ntfs    ro,users,gid=users,umask=0002, 0 0

i hope it helps.


0
 
data_grrrCommented:
usually ubuntu mounts the disks to the /media directory
0
 
data_grrrCommented:
"/dev/hda1       /media/hda1     ntfs    ro,users,gid=users,umask=0002, 0 0 "  line makes your ntfs partition readable. its not writable because it's risky and ubuntu doesn't support it. you might create a fat32 partition on windows and share it with ubuntu.
0
 
andersonmarskeAuthor Commented:
I type in sudo fdisk-l and I get:

/dev/sda1   *           1       24310   195270043+   7  HPFS/NTFS
/dev/sda2           24311       30259    47785342+  83  Linux
/dev/sda3           30260       30515     2056320    5  Extended
/dev/sda5           30260       30515     2056288+  82  Linux swap / Solaris

sda1 isn't listed in /etc/fstab
0
 
andersonmarskeAuthor Commented:
Ah I've done it. I modified /etc/fstab to the following:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda2
UUID=cc62f22f-6b98-4fcb-87f7-8da607cc26f1 /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda5
UUID=0670ff67-a861-4f9b-a4cf-acd9103a9431 none            swap    sw              0       0

/dev/sda1       /media/windows    ntfs    ro,users,gid=users,umask=0002, 0 0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/hdd        /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/           /media/floppy0  auto    rw,user,noauto  0       0

I already created a mount point called Windows.

Thank you!
0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now