Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 232
  • Last Modified:

vim - not allowing visual block/line selection. how to turn on?

I'm working on a server where I am not the admin, and it has vim 6.3.82 on it.  When I try to select using V or ^v, it simply beeps at me.  I've looked high or low for instructions on how to enable visual mode, and I just can't seem to cook up the right search phrase.

Help!
0
crnz
Asked:
crnz
  • 6
  • 3
1 Solution
 
crnzAuthor Commented:
I checked and I run VT100 on both servers. vim v5.6 does it (visual mode), v6.3 does not.  So how do I turn it on?
0
 
ravenplCommented:
try another teminal like
TERM=linux vim
try Ecs v instead of ^v
0
 
Duncan RoeSoftware DeveloperCommented:
Vim can be built to support visual mode or not support it. Perhaps on that server it's the latter. What's the distro?
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
crnzAuthor Commented:
centos

I requested (and got) and install of the vim-enhanced package, but it didn't help.
0
 
ravenplCommented:
Is the sequence 'ESC v' not working?
0
 
crnzAuthor Commented:
No offence ravenpl, but I'm not considering other fallback options yet (including the old Wordstar faves like ^kc ^kv ^kb) until I am forced to.  I'm looking to get V and ^v working like I know they must do - somehow.
0
 
crnzAuthor Commented:
ravenpl, I owe you an apology.  Just tried ESC v and I entered visual mode just fine.  Tried ESC V and my fave - visual line mode was all go.

Does this mean I need to change key mappings somewhere?

(You might forgive an old hacker who doesn't like change...  I'm already swapping between windows and linux, I am trying to avoid having to remember new key sequences on different linux servers too!  :)


0
 
ravenplCommented:
> Does this mean I need to change key mappings somewhere?
I guess so. It's the telnet/ssh/whatever client has to support smarter terminal than ancient vt100. What client do You use?
0
 
crnzAuthor Commented:
Gottit

It turns out V and v are unmapped in vi (goodness knows why they were mapped on the versions I have used - but I'm happy not to know this)

I just mapped them in vi

:map! V ^[V
:map! v ^[v

I put these in .vimrc and it works fine.

Thanks - I'm a happy chappie again

(for those finding this looking for answers, :map! maps edit mode keys while :map maps command mode keys.  ^[ stands for ESC)

0
 
crnzAuthor Commented:
woops - that's the othe way 'round with :map and :map!.  you'll figure it out. :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now