Solved

User accounts added to a folder without authorization

Posted on 2006-11-19
5
170 Views
Last Modified: 2013-12-04
I am the network administrator and every Friday afternoon I have to copy the DATA folder from the primary HDD to a backup HDD.  A while ago when I was doing it, Server2003 reported that I can't copy the file (or folders) because I don't have the right to it or someone is using it.  Then I right click on the folder -> properties -> security tab, and noticed that some other user accounts were added to this folder without me doing it!  Then I checked some other folders and found out that many folders are having the same weird situation - unauthorized actions of random user account being added to the folder's permission.  And often when I look at the user accounts, they will be changed to SID's - for a short period of time or stays there for a couple of hours.

This creates two problems
1. I as the administrator can't access the folder and contents of it, especially when the user account under the security tab is shown as SID's only.
2. Security issue - sensitive folders such as accounting or management have user accounts added to them and those users are not even related to either of those areas.

Note:  We run Symantec Internet Client Security 3 (NAV 10) and Windows Defender, plus programs like Ad-Aware SE, Spy-bot, etc. and found not Trojans or virus.
0
Comment
Question by:garyoy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
5 Comments
 
LVL 3

Expert Comment

by:Stekman99
ID: 17980084
Hi,

Is the DATA folder marked as a Offline folder?

Cheers,
Stefan
0
 
LVL 3

Accepted Solution

by:
Stekman99 earned 250 total points
ID: 17980109
Hi again,

Have a look at this KB as well:
http://support.microsoft.com/kb/310753

Cheers
0
 
LVL 5

Assisted Solution

by:shawnjoyner
shawnjoyner earned 250 total points
ID: 18967445
Go into the seurity tab under the folder permissions and go to the advanced button.  This will list all users that have rights to the folder.  Go into each and every account and go into the edit feature.  Uncheck "Change Permissions".  After you change all of these you will want to check the box to replace permissions on all folders and child objects.  Click apply and let it change away!  You will want to do this on the root folder.  If it says you do not have permission you will need to log in as administrator go to properties of the share and go to the secureitiess tab and go to advanced.  There you will see an Owner tab.  Take ownership of the folder and then repeat the above steps to locking down the share.  Let me know if you need more information on this!

Shawn
0
 
LVL 1

Expert Comment

by:Computer101
ID: 21101076
Forced accept.

Computer101
EE Admin
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Article by: btan
The intent is not to repeat what many has know about Ransomware but more to join its dots of what is it, who are the victims, why it exists, when and how we respond on infection. Lastly, sum up in a glance to share such information with more to help…
Container Orchestration platforms empower organizations to scale their apps at an exceptional rate. This is the reason numerous innovation-driven companies are moving apps to an appropriated datacenter wide platform that empowers them to scale at a …

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question