Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 737
  • Last Modified:

language conversion

Hi,

I want to make my website with multilingual feature. For that i use google's language translator service. I write one language translator class to translate content of my site from english to any other foreign languages. It works perfectly except chinesese, korean and japanese languages. I set charset as iso-8859-1. When i translate the site to chinese language all texts replace with question mark "?" . If I set charset as UTF-8 then it shows some jumbled up text.

My browser supports chinese language. Any chinese site comes properly. I can't understand why it's happen for my site? Do i need any configuration at server.
0
santanude
Asked:
santanude
1 Solution
 
VoteyDiscipleCommented:
Well, it's no surprise iso-8859-1 doesn't work, since that character set doesn't include Chinese, Korean, or Japanese characters.  

UTF-8, however, does.  When you switch to UTF-8 are you both converting your output to UTF-8 and setting the Content-Type header?  You should be doing this at the beginning of your script:

<?php
header('Content-Type: text/html; charset=utf-8');

mb_http_output("UTF-8");
ob_start('mb_output_handler');
?>
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now