• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5330
  • Last Modified:

WMI error 0x80070721

I am tring to install an application on clients computers.
So I need to use WMI from computer#1 to launch the an application that resides on computer#3 on the client computer#2.

I am using WMI to do it.
If the application resides on the client computer#2 than I use "RPC_C_IMP_LEVEL_IMPERSONATE"
CoSetProxyBlanket(pI,RPC_C_AUTHN_WINNT, RPC_C_AUTHZ_NONE,NULL,  
            RPC_C_AUTHN_LEVEL_DEFAULT, RPC_C_IMP_LEVEL_IMPERSONATE, &cID, EOAC_NONE);  
and it works OK.
BUT
if the application resides on computer#3 (or #1) than I must use "RPC_C_IMP_LEVEL_DELEGATE"
CoSetProxyBlanket(pI,RPC_C_AUTHN_WINNT, RPC_C_AUTHZ_NONE,NULL,  
            RPC_C_AUTHN_LEVEL_DEFAULT, RPC_C_IMP_LEVEL_DELEGATE,  &cID, EOAC_NONE);  
But now I get error 0x80070721 (A security package specific error occurred.)
    from GetObject(ClassName, 0, NULL, &pClass, NULL);
   
 

0
VapiSoft
Asked:
VapiSoft
1 Solution
 
YoungBonziCommented:
Hi, try to give this a shot: http://archives.neohapsis.com/archives/microsoft/various/dcom/2002-q2/0226.html

...the 'Network Security:LAN Manager authentication level' setting
was configured to 'Send NTLM response only'. When we changed it _any_ other
setting (e.g. Send NTLMv2 response only), it worked.

To modify the setting on the client, open up the 'Local Security Policy'
console (in the Admin tools program group). Expand 'Local Policies' and
then select 'Security options', the setting is listed in the right hand
pane.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now