Solved

NTP Server

Posted on 2006-11-20
20
1,085 Views
Last Modified: 2008-02-01
Hi experts,

At my work place there is NTP server which is running on SuSe. and it was configured by elder guy!
the problem is when i setup ntp client on one server to it ,the result is one hour ahead...

why?
and on NTP Server where could i see TZ variable which is already set on this server ? how to change it?
and how to show and enable\disable daylight saving on SuSe?

my timezone is +3 and daylight-saving
0
Comment
Question by:ikhmer
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
  • 5
20 Comments
 
LVL 5

Expert Comment

by:ircpamanager
ID: 17980560
are both time zones the same on client and server?
0
 
LVL 30

Accepted Solution

by:
Kerem ERSOY earned 250 total points
ID: 17981487
It seems that your time zomes are different.

Timezone is generalley set as linking an appropriate file to /etc/localtime. Thus if you want to change it you can:

cd /etc
ln -sf /usr/share/zoneinfo/EET localtime

or

cd /etc
ln -sf /usr/share/zoneinfo/Europe/Istanbul localtime

For displayin or seeing if it is modfied just issue :
date

the outut will be similar to this:
Mon Nov 20 20:40:17 EET 2006

Notice the time zone here is displayed as EET

Please be sure that bıoth systems are at the same timezone with date. Then make the necessary conversiion with ls and date again to see if everything is in order.

Cheers,
K
0
 

Author Comment

by:ikhmer
ID: 17985277
thank for your comment! and what is command to listing for time zone ? i want to verify if both client & server are the same timezone or not!

thanks,
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 17986576
as I told you earlier

> For displayin or seeing if it is modfied just issue :
> date
>
> the outut will be similar to this:
> Mon Nov 20 20:40:17 EET 2006

> Notice the time zone here is displayed as EET

When you issue date the timezone is displayed between seconds and year (EET) in the example above. Just issue date in both systems and see if they display the same time zone.


0
 

Author Comment

by:ikhmer
ID: 18044897
sorry for my late response! cause i just back from short holiday!

well, i'm afraid you don't get my point yet! my idea is that before i going to modify i need to know what is the existing time zone (value of variable tz?)
if i use date command i will get the same as what u show me.. in this case how can i see tz value???

thanks,

0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 18044931
In fact you are the one missing my point. As I told you when you issue the date command it will show you your timezone as I indicated. There's no other way to display it. In the date output the system shows the timezone between date and time. OK ?

The output such as this:
Mon Nov 20 20:40:17 EET 2006

shows the timezone as EET on the above ezample and EET means GMT+2
0
 
LVL 5

Expert Comment

by:ircpamanager
ID: 18044944
do both machines have X windows on them. If they do you can set the date and time, including timezone from the clock in the taskbar. Right click on clock and pick adjust date/time and choose the apropriate timezone. Also you can look at the bios of each machine and make sure both machines HW clock are same.

"i need to know what is the existing time zone (value of variable tz?)
if i use date command i will get the same as what u show me.. in this case how can i see tz value???"

not really sure what you mean? if you use the date command like KeremE said you will see the tz. This is what mine looks like.
Thu Nov 30 08:20:04 EST 2006
The EST is eastern standard timezone.
0
 
LVL 5

Assisted Solution

by:ircpamanager
ircpamanager earned 250 total points
ID: 18044957
0
 

Author Comment

by:ikhmer
ID: 18045008
in Solaris i can see or modify in /etc/TIMEZONE
it look like :

TZ=GMT-3
CMASK=022
LANG=C
/etc/TIMEZONE (END)

that why i think it could be any command  or file that i could modify it! sorry for missunderstanding!

Well, my server is : Thu Nov 30 16:23:35 EET 2006 ==> that mean GMT+2
so, what is the indicator for "GMT+3" or "GMT-3" ????

thanks,
0
 
LVL 5

Expert Comment

by:ircpamanager
ID: 18045056
try looking in /etc/sysconfig/clock  also look under /usr/share/zoneinfo
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 18046925
I understand that you would expect something like Solaris. But It is not that way here all you have is :
- date command showing the time zone and you can then compare it   and then to see it you would visit the wikipedia page: http://en.wikipedia.org/wiki/List_of_tz_zones to see whether it s GMT+2 or something else etc.
- Another way is to view the Continent/City by cat /wetc/sysconfig/clock
- To view it graphically you would start X and display timezne you will see the the place selected as time graphically over the map.

Unfortunately thre's no environment variable in linux

0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 18046951
Your /etc/sysconfig/clock must be something like:

ZONE="Asia/Riyadh"
UTC=false
ARC=false

in both systems.
0
 

Author Comment

by:ikhmer
ID: 18058960
Now, i already change zone in /etc/sysconfig/clock of both systems , but from ntp client still got one hour difference!
and i also restart ntpd, xntpd! what service should i restart without reboot system???

and here is clock and hw clock which i issue command on ntp server!
# date
Sat Dec  2 10:25:14 EET 2006

# clock
Sat Dec  2 09:25:17 2006  -0.914988 seconds

it seem not effect ! still show EET as the result
0
 
LVL 5

Expert Comment

by:ircpamanager
ID: 18059820
out of curiosity, on the ntp server where is the ntp server getting it's time?
0
 

Author Comment

by:ikhmer
ID: 18091417
it get from localhost itself!!!

anyway, it work after i restart server!
0
 
LVL 5

Expert Comment

by:ircpamanager
ID: 18101345
so your problem is solved?
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 18101519
Hi,

But there's something fishy here. First of all EET is GMT+2 not GMT+3.

Then it is strange that it was not in operation before you shutdown.

Cheers,
K.

0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question